summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuclu72021-02-11 11:02:07 +0100
committerLuclu72021-02-11 11:02:07 +0100
commitae475552549966e97c3cd903a4151a48d3294a34 (patch)
treeb65789bbfcaecdd3c0ed5c74b62b721bcba8f830
downloadaur-what-anime-cli-git.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eacb8f4623f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = what-anime-cli-git
+ pkgdesc = Find the anime scene by image using your terminal
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/irevenko/what-anime-cli
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ source = git+https://github.com/irevenko/what-anime-cli.git
+ sha512sums = SKIP
+
+pkgname = what-anime-cli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..837aba996c50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Luclu7 <me at luclu7 dot fr>
+pkgname=what-anime-cli-git
+pkgver=1
+pkgrel=1
+pkgdesc="Find the anime scene by image using your terminal"
+arch=('x86_64')
+url="https://github.com/irevenko/what-anime-cli"
+license=('MIT')
+makedepends=('go')
+source=("git+https://github.com/irevenko/what-anime-cli.git")
+sha512sums=('SKIP')
+
+warn_build_references() {
+ : # I like __FILE__ and don't consider build references to be a problem
+}
+
+build() {
+ cd "what-anime-cli"
+ go build
+}
+
+package() {
+ cd "what-anime-cli"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 what-anime-cli "$pkgdir/usr/bin/what-anime"
+}