summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2022-12-09 09:36:12 +0600
committerMubashshir2022-12-09 09:53:47 +0600
commit8c9670c2d5bed546cc6a1916587a9a60e7e1e008 (patch)
tree23a081a46cbb62dc2fb3c4bcb88a04228f73d369
parentad6f4eaf8220309348375694ba651cb55fa50b75 (diff)
downloadaur-8c9670c2d5bed546cc6a1916587a9a60e7e1e008.tar.gz
whatpulse: Fix deps
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bc279c9f06a..d68db4d68b4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = whatpulse
pkgdesc = Measures your keyboard, mouse and application usage, network traffic and uptime.
pkgver = 5.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.whatpulse.org
arch = x86_64
license = custom:whatpulse_tos
makedepends = imagemagick
- depends = qt5-svg
+ makedepends = patchelf
+ depends = qt6-svg
+ depends = qt6-charts
+ depends = qt6-5compat
depends = hicolor-icon-theme
optdepends = libpcap: for capturing network statistics
source = whatpulse.desktop
@@ -14,6 +17,6 @@ pkgbase = whatpulse
sha256sums = 5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d
sha256sums = cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619
source_x86_64 = whatpulse-5.0-amd64.AppImage::https://d2bz2twqkobp4d.cloudfront.net/latest/linux/whatpulse-linux-latest_amd64.AppImage
- sha256sums_x86_64 = 9d4579339d255152748a8d1ed842dc9e0d83347ac57c4fd3cb6e3a6e14ec7a2a
+ sha256sums_x86_64 = 80e11e721c447f8d5137905a371a51ea5b21e9e55d2f5e0c00e48be28c0b2f87
pkgname = whatpulse
diff --git a/PKGBUILD b/PKGBUILD
index bce2c43dfc68..6ab63d0e947f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_tag=latest
pkgname=whatpulse
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Measures your keyboard, mouse and application usage, network traffic and uptime."
arch=('x86_64')
@@ -14,11 +14,14 @@ url=http://www.whatpulse.org
license=(custom:whatpulse_tos)
depends=(
- qt5-svg
+ qt6-svg
+ qt6-charts
+ qt6-5compat
hicolor-icon-theme
)
makedepends=(
imagemagick
+ patchelf
)
optdepends=(
'libpcap: for capturing network statistics'
@@ -30,7 +33,7 @@ source=(
source_x86_64=("${pkgname}-${pkgver}-amd64.AppImage::https://d2bz2twqkobp4d.cloudfront.net/${_tag:-$pkgver}/linux/whatpulse-linux-${_tag:-$pkgver}_amd64.AppImage")
sha256sums=('5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d'
'cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619')
-sha256sums_x86_64=('9d4579339d255152748a8d1ed842dc9e0d83347ac57c4fd3cb6e3a6e14ec7a2a')
+sha256sums_x86_64=('80e11e721c447f8d5137905a371a51ea5b21e9e55d2f5e0c00e48be28c0b2f87')
_extract() {
./"${pkgname}-${pkgver}-amd64.AppImage" --appimage-extract "$1"
@@ -42,6 +45,7 @@ prepare() {
_extract 'whatpulse.png'
_extract 'usr/share/icons/hicolor/512x512/apps/whatpulse.png'
ln -sf squashfs-root sfs
+ patchelf --remove-rpath sfs/usr/bin/whatpulse
}
package() {