summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2021-10-27 00:24:34 +0600
committerMubashshir2021-10-27 00:32:25 +0600
commitc26c2207644ee4ab4b9fb51fae1a7a085a889e70 (patch)
treeb406b1df2e1f829dc17690fe6c35e91917d3bf8c
parent1653183ba0886da68730fdb780b5ac624d4b1687 (diff)
downloadaur-c26c2207644ee4ab4b9fb51fae1a7a085a889e70.tar.gz
Update to v3.5 and use snap as new source
* Remove the install script: 1. 'input' group is a core system group that must be present on an standard arch linux base. 2. We can setcap in build() or install() inside PKGBUILD, thus using a install script is not needed. * Remove changelog file as whatpulse.org now doesn't provide a changelog * Add license from the windows installer * Install proper icons generated & resized to needed sizes from official resources. * Add meta comments for automated scripts * Add a gitignore whitelist
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD74
-rw-r--r--whatpulse.changelog14
-rw-r--r--whatpulse.desktop1
-rw-r--r--whatpulse.install34
7 files changed, 73 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ed20b9c2d9c..bccdb294d8ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
-# Generated by mksrcinfo v8
-# Wed Jan 9 13:06:22 UTC 2019
pkgbase = whatpulse
pkgdesc = Measures your keyboard, mouse and application usage, network traffic and uptime.
- pkgver = 2.8.4
+ pkgver = 3.5.10
pkgrel = 1
url = http://www.whatpulse.org
- install = whatpulse.install
- changelog = whatpulse.changelog
arch = x86_64
license = custom:whatpulse_tos
- depends = qt4
+ makedepends = squashfs-tools
+ makedepends = imagemagick
+ depends = qt5-svg
+ depends = hicolor-icon-theme
optdepends = libpcap: for capturing network statistics
source = whatpulse.desktop
- sha256sums = aba7e6b28ccebdb6115245dae1a7ca8e88afa2ecb1619037b66f65090a284363
- source_x86_64 = http://static.whatpulse.org/files/whatpulse-linux-archlinux-64bit-2.8.4.tar.gz
- sha256sums_x86_64 = 763d603962db4a6e78d53ebbc7a2142419119ab3df40e28793ea7937260131eb
+ source = assets.zip::https://whatpulse.org/images/assets/whatpulse-assets-all.zip
+ source = LICENSE
+ sha256sums = 5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d
+ sha256sums = bbbc3e1e63e8300f247897c24487ecad6f313c1972417604bf8d991ca4408b03
+ sha256sums = cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619
+ source_x86_64 = whatpulse-3.5.10.sfs::https://api.snapcraft.io/api/v1/snaps/download/iHVATX2faqAJciG5YGNM241W8fE8UvsF_10.snap
+ sha256sums_x86_64 = ffb8dae8045f6af1ab059e12372130f85455607461d25b25cb2df69366a18623
pkgname = whatpulse
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef635db87590
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.SRCINFO
+!LICENSE
+!PKGBUILD
+!whatpulse.desktop
+!.gitignore
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6d5665e58175
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+Stats are near, but first we have to show this license:
+
+By installing WhatPulse you agree to the Privacy Policy (http://whatpulse.org/privacy) and Terms of Service (http://whatpulse.org/tos).
+
+Furthermore, WhatPulse is provided to users on an "as it is" basis, without warranty of any kind, whether expressed or implied. This includes any kind of warranty or guarentee that WhatPulse is free of defects, and any kind of warranty or guarantee that WhatPulse will not do any damage to your computer. There is no person or entity that can hold the author of WhatPulse liable for any damages caused by use of WhatPulse, or through any other means. You, the user, by continuing with the installation and use of WhatPulse, assume all risk of its use and of the consequences of its use. If you do not agree to these terms, you are not permitted to continue to use WhatPulse in any way.
+
+Enjoy your stats!
diff --git a/PKGBUILD b/PKGBUILD
index 7fe65dc281f3..6ce01eb8f1fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,67 @@
# Maintainer: Thor K. H. <thor alfakrøll roht dott no>
+# Co-Maintainer: Mubashshir <ahmubashshir@gmail.com>
# Contributor: Tim Besard <tim $dot$ besard $at$ gmail $dot$ com>
# Contributor: Jelle van der Waa <jellevdwaa @ gmail.com>
# Contributor: Pieter Kokx <pieter $at$ kokx $dot$ .nl>
+# from: snap beta
+# what: whatpulse
+_snap=iHVATX2faqAJciG5YGNM241W8fE8UvsF
pkgname=whatpulse
-pkgver=2.8.4
+pkgver=3.5.10
pkgrel=1
+
pkgdesc="Measures your keyboard, mouse and application usage, network traffic and uptime."
arch=('x86_64')
url=http://www.whatpulse.org
-# I have yet to find the actual licence, but alternatively: it's basically freeware
+
license=(custom:whatpulse_tos)
-changelog="$pkgname.changelog"
-install="$pkgname.install"
-depends=(qt4)
+depends=(
+ qt5-svg
+ hicolor-icon-theme
+)
+makedepends=(
+ squashfs-tools
+ imagemagick
+)
optdepends=(
'libpcap: for capturing network statistics'
)
-source=('whatpulse.desktop')
-source_x86_64=("http://static.whatpulse.org/files/whatpulse-linux-archlinux-64bit-$pkgver.tar.gz")
-sha256sums=('aba7e6b28ccebdb6115245dae1a7ca8e88afa2ecb1619037b66f65090a284363')
-sha256sums_x86_64=('763d603962db4a6e78d53ebbc7a2142419119ab3df40e28793ea7937260131eb')
+source=(
+ 'whatpulse.desktop'
+ 'assets.zip::https://whatpulse.org/images/assets/whatpulse-assets-all.zip'
+ LICENSE
+)
+source_x86_64=("${pkgname%*-bin}-$pkgver.sfs::https://api.snapcraft.io/api/v1/snaps/download/${_snap}_${pkgver##*.}.snap")
+sha256sums=('5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d'
+ 'bbbc3e1e63e8300f247897c24487ecad6f313c1972417604bf8d991ca4408b03'
+ 'cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619')
+sha256sums_x86_64=('ffb8dae8045f6af1ab059e12372130f85455607461d25b25cb2df69366a18623')
-build() {
- # Extract the tiny, tiny bit of license/usage information that exists
- # in this piece of software distribution.
- sed -n '/By installing/,/ any way./p' README.txt > LICENSE
+prepare() {
+ rm -rf sfs
+ unsquashfs -q -i -n -d sfs \
+ "${pkgname%*-bin}-$pkgver.sfs" \
+ usr/bin/whatpulse
}
package() {
- cd $srcdir/
- # Install the binary
- mkdir -p ${pkgdir}/usr/bin
- install -m0755 whatpulse ${pkgdir}/usr/bin/
- # Install the freedesktop shortcut
- mkdir -p ${pkgdir}/usr/share/applications
- install -m0644 whatpulse.desktop ${pkgdir}/usr/share/applications/
- # Install the input rules
- mkdir -p ${pkgdir}/etc/udev/rules.d/
- cat >${pkgdir}/etc/udev/rules.d/99-whatpulse-input.rules <<__EOF__
-KERNEL=="event*", NAME="input/%k", MODE="640", GROUP="input"
-__EOF__
+ install -Dm 755 sfs/usr/bin/whatpulse "${pkgdir}/usr/bin/whatpulse"
+ install -Dm 644 whatpulse.desktop "${pkgdir}/usr/share/applications/whatpulse.desktop"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+
+ # Set capabilities so that whatpulse can monitor network traffic
+ setcap cap_net_raw,cap_net_admin=eip "${pkgdir}/usr/bin/whatpulse"
- # Install the license
- install -Dm0755 LICENSE ${pkgdir}/usr/share/licenses/whatpulse/LICENSE
+ # Generate and install icons
+ for size in 16 20 22 24 28 32 36 44 48 64 72 96 128 150 192 256 310 384 512 1024
+ do
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps"
+ convert \
+ +gravity -crop 615x680+0+0 +repage \
+ -resize "${size}x${size}" -background none \
+ -gravity center -extent "${size}x${size}" \
+ whatpulse-logo-color.png \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/whatpulse.png"
+ done
}
diff --git a/whatpulse.changelog b/whatpulse.changelog
deleted file mode 100644
index 8f620f76e310..000000000000
--- a/whatpulse.changelog
+++ /dev/null
@@ -1,14 +0,0 @@
-2.7.1 - 2 July 2016
-* NEW: Mac: Support for macOS Sierra (10.12).
-* NEW: Windows: New updater to improve future updates and for a better update experience.
-* NEW: Keyboard Heat-map: Add a view with a table with the key counts.
-* FIXED: Pulsing: Fix situations where the client could pulse every minute.
-* FIXED: Make the "I" button clickable again for the window with all the facts.
-* FIXED: Fix premium expiration date presentation.
-* FIXED: Never allow negative application uptime (when a computers clock changes).
-* FIXED: Keyboard Heat-map: Fix the color overlay positioning of the keyboard when switching between regular and with numpad.
-* FIXED: Input - Mouse Heat-map: Show the export button.
-* FIXED: Windows: Better handle hibernation/sleep and make sure the counters are still active.
-* FIXED: Fix the sizes of the dots in the reboot dot chart when there's just 1 day of the week with reboots.
-* REMOVED: Remove psvince.dll file from installer (was used to detect if the client is running), some A/Vs seemed to have problems with it.
-* IMPROVED: Show a notice when trying to login to an account which is waiting for activation.
diff --git a/whatpulse.desktop b/whatpulse.desktop
index 81a4c365ddae..76e8f8bf239b 100644
--- a/whatpulse.desktop
+++ b/whatpulse.desktop
@@ -2,6 +2,7 @@
Type=Application
Name=WhatPulse
GenericName=Usage Statistics Tracker & Sharer
+Comment=Track & share your computer usage
Exec=whatpulse
Icon=whatpulse
StartupNotify=true
diff --git a/whatpulse.install b/whatpulse.install
deleted file mode 100644
index 1620255d6ef1..000000000000
--- a/whatpulse.install
+++ /dev/null
@@ -1,34 +0,0 @@
-post_install() {
- # Create the 'input' group
- if [ -n "`cat /etc/group | grep -e ^input:`" ] ; then
- echo "Group 'input' already exists!"
- else
- groupadd input
- echo "Created group 'input'."
- fi
- # Manage permissions for the binary
- setcap cap_net_raw,cap_net_admin=eip /usr/bin/whatpulse
-
- # Display some information about how to set-up permissions
- cat <<__EOF__
-==> Now add your user to the 'input' group:
-==> # gpasswd -a USERNAME input
-==>
-==> Now reboot to fix the input permissions, or execute this:
-==> # find /dev/input/ -iname "event*" -exec chmod 644 {} \;
-==>
-==> This temporarily grants everybody read permissions on
-==> all input devices, something you should obviously avoid if
-==> you fear somebody will eavesdrop those input devices.
-__EOF__
-}
-
-post_upgrade() {
- # Manage permissions for the binary
- setcap cap_net_raw,cap_net_admin=eip /usr/bin/whatpulse
-}
-
-pre_remove() {
- # Warn the user about the 'input' group
- echo "The \"input\" group still exists, remove it if you don't use it anymore."
-}