summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiccardo Sacchetto2021-10-24 20:58:15 +0200
committerRiccardo Sacchetto2021-10-24 20:58:15 +0200
commitfb731747f3a372a0b07a53b0bb81cb09569ac56a (patch)
tree75a5cc4120c2a797112903772b164dcc9b3d5b58
downloadaur-whatstux.tar.gz
First packaged version - v0.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
-rw-r--r--whatstux.desktop7
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b82f4488d9d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = whatstux
+ pkgdesc = Super simple Rust+GTK WhatsApp Web Client
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.com/nexxontech/whatstux
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = cargo
+ depends = gtk3
+ depends = webkit2gtk
+ source = https://gitlab.com/nexxontech/whatstux/-/archive/0.1.0/whatstux-0.1.0.tar.gz
+ source = whatstux.desktop
+ sha512sums = 1489b69967465cbcc8010d9a62b4a800d924d24b4727b712eab4772f4df0ac43d0fad53291aabf59892fa41f06f8fb959f503c332c41cfe5d8b0316ced4fc81a
+ sha512sums = c09392e9c4bae32fa59d32b3ae78b77e079ea526af96454e89638179b6357dec25edaf304f1699aaf5375a5f8e1ba82caeba441c5ab4a30c7c35440d71cf8ee1
+
+pkgname = whatstux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..205dfb6d1dd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Riccardo Sacchetto <rsacchetto@nexxontech.it>
+pkgname=whatstux
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Super simple Rust+GTK WhatsApp Web Client"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/nexxontech/whatstux"
+license=('GPL3')
+depends=('gtk3' 'webkit2gtk')
+makedepends=('cargo')
+source=("https://gitlab.com/nexxontech/whatstux/-/archive/${pkgver}/whatstux-${pkgver}.tar.gz"
+ "whatstux.desktop")
+sha512sums=("1489b69967465cbcc8010d9a62b4a800d924d24b4727b712eab4772f4df0ac43d0fad53291aabf59892fa41f06f8fb959f503c332c41cfe5d8b0316ced4fc81a"
+ "c09392e9c4bae32fa59d32b3ae78b77e079ea526af96454e89638179b6357dec25edaf304f1699aaf5375a5f8e1ba82caeba441c5ab4a30c7c35440d71cf8ee1")
+
+prepare() {
+ cd "${srcdir}/whatstux-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/whatstux-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${srcdir}/whatstux-${pkgver}"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+
+ cd "${srcdir}"
+ install -Dm644 ./whatstux.desktop "${pkgdir}/usr/share/applications/whatstux.desktop"
+}
diff --git a/whatstux.desktop b/whatstux.desktop
new file mode 100644
index 000000000000..8dbd9d8af424
--- /dev/null
+++ b/whatstux.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=WhatsTux
+Comment=Super simple Rust+GTK WhatsApp Web Client
+Exec=/usr/bin/whatstux
+Terminal=false
+Type=Application
+Categories=Chat