summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Sohier2015-06-08 15:30:32 +0200
committerAdrien Sohier2015-06-08 15:30:32 +0200
commitd40f2607b76fa6030e1ecb27eccc96ab31e3bc9d (patch)
tree2a2d2ca90d9f4ea08a0c1b68d13f602bc308065d
downloadaur-d40f2607b76fa6030e1ecb27eccc96ab31e3bc9d.tar.gz
init
-rw-r--r--.SRCINFO66
-rw-r--r--PKGBUILD116
-rw-r--r--wicd-1.7.3-urwid-1.3.0.patch15
-rw-r--r--wicd-gtk.install11
-rw-r--r--wicd.desktop11
-rw-r--r--wicd.install19
6 files changed, 238 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83389362a177
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,66 @@
+pkgbase = wicd-git
+ pkgver = 0c205a
+ pkgrel = 1
+ url = https://launchpad.net/wicd/
+ install = wicd.install
+ arch = any
+ license = GPL2
+ makedepends = python2
+ makedepends = python2-babel
+ makedepends = python2-setuptools
+ makedepends = gettext
+ makedepends = dbus-glib
+ makedepends = dhcpcd
+ makedepends = ethtool
+ makedepends = inetutils
+ makedepends = net-tools
+ makedepends = pygtk
+ makedepends = python2-dbus
+ makedepends = python2-gobject2
+ makedepends = python2-urwid
+ makedepends = rfkill
+ makedepends = shared-mime-info
+ makedepends = wireless_tools
+ makedepends = wpa_supplicant
+ makedepends = hicolor-icon-theme
+ options = emptydirs
+ source = git+git://github.com/johnboiles/wicd.git
+ source = wicd.desktop
+ source = wicd-1.7.3-urwid-1.3.0.patch
+ md5sums = SKIP
+ md5sums = 326df163a5732d38741371baa4fce9e5
+ md5sums = f7e6085e482f37f2b8529326c21cbbbf
+
+pkgname = wicd-git
+ pkgdesc = Wired and wireless network manager for Linux
+ install = wicd.install
+ depends = python2
+ depends = python2-dbus
+ depends = dhcpcd
+ depends = wpa_supplicant
+ depends = wireless_tools
+ depends = inetutils
+ depends = net-tools
+ depends = ethtool
+ depends = shared-mime-info
+ depends = python2-urwid
+ depends = python2-gobject2
+ depends = dbus-glib
+ depends = rfkill
+ optdepends = wicd-gtk: needed if you want the GTK interface
+ provides = wicd
+ conflicts = wicd
+ backup = etc/wicd/encryption/templates/active
+
+pkgname = wicd-gtk-git
+ pkgdesc = Wired and wireless network manager for Linux - GTK client
+ install = wicd-gtk.install
+ depends = wicd
+ depends = pygtk
+ depends = hicolor-icon-theme
+ optdepends = gksu: needed to access some preferences in gtk interface
+ optdepends = notification-daemon: needed if you want notifications
+ optdepends = python2-notify: needed if you want notifications
+ provides = wicd-gtk
+ conflicts = wicd-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..874668887bf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,116 @@
+# $Id$
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
+# Contributor: Rashif "Don Ray" Rahman <rayrashif@gmail.com>
+
+pkgbase=wicd-git
+pkgname=('wicd-git' 'wicd-gtk-git')
+pkgver=0c205a
+pkgrel=1
+arch=(any)
+url="https://launchpad.net/wicd/"
+license=('GPL2')
+install=wicd.install
+source=(git+git://github.com/johnboiles/wicd.git
+ wicd.desktop
+ wicd-1.7.3-urwid-1.3.0.patch)
+md5sums=('SKIP'
+ '326df163a5732d38741371baa4fce9e5'
+ 'f7e6085e482f37f2b8529326c21cbbbf')
+makedepends=('python2' 'python2-babel' 'python2-setuptools' 'gettext' 'dbus-glib' 'dhcpcd'
+ 'ethtool' 'inetutils' 'net-tools' 'pygtk' 'python2-dbus' 'python2-gobject2'
+ 'python2-urwid' 'rfkill' 'shared-mime-info' 'wireless_tools' 'wpa_supplicant'
+ 'hicolor-icon-theme')
+options=('emptydirs')
+
+pkgver() {
+ cd wicd
+ git describe --always | tr "-" "." | cut -c2-
+}
+prepare() {
+ cd wicd
+
+ find . -type f -exec sed -i 's@#!/usr.*python@#!/usr/bin/python2@' {} \;
+ sed -i 's/pybabel/pybabel2/g' setup.py
+ export PYTHON=python2
+
+ sed -i 's|/usr/sbin/|/usr/bin/|' other/wicd.service
+ patch -Np0 -i "$srcdir/wicd-1.7.3-urwid-1.3.0.patch"
+}
+
+build() {
+ cd wicd
+ python2 setup.py configure \
+ --no-install-init \
+ --resume=/usr/share/wicd/scripts/ \
+ --suspend=/usr/share/wicd/scripts/ \
+ --verbose \
+ --python=/usr/bin/python2 \
+ --lib=/usr/lib \
+ --sbin=/usr/bin \
+ --no-install-gnome-shell-extensions \
+ --systemd=/usr/lib/systemd/system
+ python2 setup.py build
+ python2 setup.py compile_translations
+
+ #HACK for https://bugs.launchpad.net/wicd/+bug/928589
+ mkdir -p translations/ast/LC_MESSAGES
+ msgfmt po/ast.po -o translations/ast/LC_MESSAGES/wicd.mo
+}
+
+package_wicd-git() {
+ pkgdesc="Wired and wireless network manager for Linux"
+ depends=('python2' 'python2-dbus' 'dhcpcd' 'wpa_supplicant' 'wireless_tools'
+ 'inetutils' 'net-tools' 'ethtool' 'shared-mime-info' 'python2-urwid' 'python2-gobject2' 'dbus-glib' 'rfkill')
+ optdepends=('wicd-gtk: needed if you want the GTK interface')
+ provides=("wicd")
+ conflicts=("wicd")
+ backup=('etc/wicd/encryption/templates/active')
+ install=wicd.install
+
+ cd wicd
+ python2 setup.py install --skip-build --optimize=1 --root="$pkgdir"
+
+ cd build/lib/wicd
+ for i in *.py; do
+ install -Dm 755 $i "$pkgdir/usr/lib/wicd/$i"
+ done
+
+ rm -rf "$pkgdir"/usr/share/autostart
+
+ #deleting the GTK stuff
+ rm -rf "$pkgdir"/etc/xdg
+ rm -f "$pkgdir"/usr/bin/{wicd-client,wicd-gtk}
+ rm -rf "$pkgdir"/usr/share/{applications,icons,pixmaps}
+ rm -rf "$pkgdir"/usr/share/wicd/{gtk,icons}
+}
+
+package_wicd-gtk-git() {
+ provides=("wicd-gtk")
+ conflicts=("wicd-gtk")
+ pkgdesc="Wired and wireless network manager for Linux - GTK client"
+ depends=('wicd' 'pygtk' 'hicolor-icon-theme')
+ optdepends=('gksu: needed to access some preferences in gtk interface'
+ 'notification-daemon: needed if you want notifications'
+ 'python2-notify: needed if you want notifications')
+ install=wicd-gtk.install
+
+ cd wicd
+ python2 setup.py install --skip-build --optimize=1 --root="$pkgdir"
+
+ install -Dm644 "$srcdir/wicd.desktop" "$pkgdir/usr/share/applications/wicd.desktop"
+
+ cd build/lib/wicd
+ for i in *.py; do
+ install -Dm 755 $i "$pkgdir"/usr/lib/wicd/$i
+ done
+
+ #deleting the core dirs which exists in wicd
+ rm -rf "$pkgdir"/etc/{wicd,dbus-1,rc.d,logrotate.d}
+ rm -rf "$pkgdir"/usr/lib
+ rm -rf "$pkgdir"/usr/share/{man,doc,locale,wicd/curses,wicd/daemon,wicd/backends,wicd/scripts,wicd/cli}
+ rm -rf "$pkgdir"/var
+ rm -f "$pkgdir"/usr/bin/{wicd,wicd-curses,wicd-cli}
+
+ rm -rf "$pkgdir"/usr/share/autostart
+ rm -rf "$pkgdir"/usr/share/dbus-1
+}
diff --git a/wicd-1.7.3-urwid-1.3.0.patch b/wicd-1.7.3-urwid-1.3.0.patch
new file mode 100644
index 000000000000..a028059f5615
--- /dev/null
+++ b/wicd-1.7.3-urwid-1.3.0.patch
@@ -0,0 +1,15 @@
+--- curses/wicd-curses.py 2015-01-27 22:35:25.414781192 -0300
++++ cursesb/wicd-curses.py 2015-01-28 01:13:48.078904587 -0300
+@@ -1153,9 +1153,10 @@
+ if not ui._started:
+ return False
+
+- input_data = ui.get_input_nonblocking()
++ ui.set_input_timeouts(max_wait=0)
++ input_data = ui.get_input()
+ # Resolve any "alarms" in the waiting
+- self.handle_keys(input_data[1])
++ self.handle_keys(input_data)
+
+ # Update the screen
+ canvas = self.frame.render((self.size), True)
diff --git a/wicd-gtk.install b/wicd-gtk.install
new file mode 100644
index 000000000000..1a05f573e594
--- /dev/null
+++ b/wicd-gtk.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/wicd.desktop b/wicd.desktop
new file mode 100644
index 000000000000..868208768ca7
--- /dev/null
+++ b/wicd.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Categories=Network;
+Encoding=UTF-8
+Exec=/usr/bin/wicd-client
+GenericName=Network Manager
+Icon=wicd-gtk
+Comment=Manage Wired/Wireless Networks
+Name=Wicd
+Terminal=false
+Type=Application
+Version=1.0
diff --git a/wicd.install b/wicd.install
new file mode 100644
index 000000000000..6bb3d3ae113b
--- /dev/null
+++ b/wicd.install
@@ -0,0 +1,19 @@
+PKGNAME=wicd
+
+pre_remove () {
+ for pyo in $(pacman -Qql $PKGNAME | grep \.py$ | sed 's|.py$|.pyo|g'); do
+ if [ -f "$pyo" ]; then
+ rm "$pyo"
+ fi
+ done
+}
+
+post_install() {
+ echo
+ echo "==> You need to restart the dbus service after "
+ echo "==> upgrading wicd."
+ echo "==> Disable networkmanager, dhcpcd or other networking "
+ echo "==> utility and add 'wicd' to your systemd configuration."
+ echo
+ echo "==> To run: wicd-cli or wicd-curses"
+}