aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarsha Kuchampudi2018-04-04 23:18:58 -0400
committerHarsha Kuchampudi2018-04-04 23:18:58 -0400
commit355717bcaaa521f47a0c1a229cd3bc5831dffc23 (patch)
tree7e3f5d85f138939540c71499536fb47f7b56e10c
parent7d8a8f842eb008b67b1a17478a5fe2ed69dfd6c0 (diff)
downloadaur-355717bcaaa521f47a0c1a229cd3bc5831dffc23.tar.gz
Windscribe CLI v1.1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--README.md28
-rw-r--r--windscribe-cli.install1
4 files changed, 57 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b21185a1e433..316d0b72d3a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,25 @@
pkgbase = windscribe-cli
- pkgdesc = Port of Windscribe's VPN command line interface
- pkgver = 1.0
- pkgrel = 4
+ pkgdesc = Port of Windscribe's command line interface
+ pkgver = 1.1
+ pkgrel = 1
url = https://windscribe.com/
install = windscribe-cli.install
arch = x86_64
+ arch = i686
+ arch = armv6h
+ arch = armv7h
license = GPL-2+
depends = openvpn
+ optdepends = stunnel
replaces = windscribe-cli
- source = .deb::https://windscribe.com/install/desktop/linux_deb
- sha256sums = 9b173b1548c04524861839ff6c2e49a2a0e6143e7438cf5f5a784301010d15d1
+ source_x86_64 = windscribe-cli_1.1_1.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.1_x64.deb
+ sha256sums_x86_64 = 3639313f36bc16a200ce31e2c2d5c3e4f555189d9ab2d8d6acd376ed33dea180
+ source_i686 = windscribe-cli_1.1_1.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.1_x86.deb
+ sha256sums_i686 = 049d8cf2231a50e43ed9c68f866219eb9d7604936ac1b9f4fdaeed3dedef4108
+ source_armv6h = windscribe-cli_1.1_1.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.1-1_armhf.deb
+ sha256sums_armv6h = 2fcf951dab5c70877660c49beb2ce35c7f1b1df47c33caa471ea0cd96f58284c
+ source_armv7h = windscribe-cli_1.1_1.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.1-1_armhf.deb
+ sha256sums_armv7h = 2fcf951dab5c70877660c49beb2ce35c7f1b1df47c33caa471ea0cd96f58284c
pkgname = windscribe-cli
diff --git a/PKGBUILD b/PKGBUILD
index a90052d09f14..5207c692641f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,33 @@
-# Maintainer: Harsha Kuchampudi <harshakuchampudi@gmail.com>
+##########################################################################
+# Maintainer: Harsha Kuchampudi <harshakuchampudi AT gmail DOT com>
+# Github: https://github.com/hkuchampudi/Windscribe
+# Updated: 2018-04-04
+##########################################################################
+
pkgname=windscribe-cli
-pkgver=1.0
-pkgrel=4
-pkgdesc="Port of Windscribe's VPN command line interface"
-arch=('x86_64')
+pkgver=1.1
+pkgrel=1
+pkgdesc="Port of Windscribe's command line interface"
+arch=('x86_64' 'i686' 'armv6h' 'armv7h')
url="https://windscribe.com/"
license=('GPL-2+')
depends=('openvpn')
+optdepends=('stunnel')
replaces=('windscribe-cli')
install="windscribe-cli.install"
-source=("$pkgname_$pkgver_all.deb::https://windscribe.com/install/desktop/linux_deb")
-sha256sums=('9b173b1548c04524861839ff6c2e49a2a0e6143e7438cf5f5a784301010d15d1')
+source_armv6h=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}-${pkgrel}_armhf.deb")
+source_armv7h=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}-${pkgrel}_armhf.deb")
+source_i686=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}_x86.deb")
+source_x86_64=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}_x64.deb")
+sha256sums_armv6h=('2fcf951dab5c70877660c49beb2ce35c7f1b1df47c33caa471ea0cd96f58284c')
+sha256sums_armv7h=('2fcf951dab5c70877660c49beb2ce35c7f1b1df47c33caa471ea0cd96f58284c')
+sha256sums_i686=('049d8cf2231a50e43ed9c68f866219eb9d7604936ac1b9f4fdaeed3dedef4108')
+sha256sums_x86_64=('3639313f36bc16a200ce31e2c2d5c3e4f555189d9ab2d8d6acd376ed33dea180')
package() {
# Extract the debian package
echo "Extracting debian package"
- ar vx $srcdir/$pkgname_$pkgver_all.deb
+ ar vx $srcdir/${pkgname}_${pkgver}_${pkgrel}.deb
mkdir $srcdir/data
mkdir $srcdir/control
tar xf "data.tar.xz" -C "${srcdir}/data"
@@ -60,4 +72,4 @@ package() {
cp -r "${srcdir}/data/usr/" "${pkgdir}/"
chmod 0755 "${pkgdir}/usr/bin/windscribe"
chmod 0755 -R "${pkgdir}/usr/share/doc/windscribe-cli"
-} \ No newline at end of file
+}
diff --git a/README.md b/README.md
index 12537814ea5e..642ab93b582e 100644
--- a/README.md
+++ b/README.md
@@ -1,24 +1,36 @@
## Windscribe VPN CLI for Arch Linux
-**Update: You can now install this package from AUR: k**
+**Update: You can now install this package from [AUR](https://aur.archlinux.org/packages/windscribe-cli/)**
### Overview
This repository contains the files necessary to build Windscribe VPN CLI for Arch Linux. Currently, Windscribe's CLI is in open beta, so users should anticipate breakages.
-### Installing
-In order the install Windscribe's CLI, use the following instructions:
+### Installation
+
+#### Installing From AUR
+- You install this package from the Arch User Repository (AUR) by using `yaourt` and running `yaourt -S windscribe-cli`.
+
+#### Installing From Source
+In order the install Windscribe's CLI from source, use the following instructions:
1. Clone this repository onto your local machine.
2. `cd` into the cloned repository.
3. Execute `makepkg -cs` to build the package.
-4. After the build process is finished, run `sudo pacman -U windscribe-cli-1.0-1-any.pkg.tar` to install the package.
-5. Close out of any active terminals (this is so that bash autocomplete works)
-6. Make sure that the windscribe daemon is running: `systemctl status windscribe.service`
-7. Now running `windscribe` in your terminal should bring-up the CLI
+4. After the build process is finished, run `sudo pacman -U windscribe-cli-1.1-1-[PACKAGE ARCHITECTURE].pkg.tar` to install the
+package.
+
+### Running Windscribe CLI
+1. After installing for the first time, close out of any active terminals (this is so that bash autocomplete works)
+2. Check to see if the windscribe daemon is running: `systemctl status windscribe.service`
+3. If the daemon is not running, you can simply run `sudo systemctl start windscribe`. (If you want the daemon to automatically start on boot, you can run `sudo systemctl enable windscribe`, otherwise you will have to execute `sudo systemctl start windscribe` every time the computer is booted)
+4. Now running `windscribe` in your terminal should bring-up the CLI
+5. To login to windscribe, run `windscribe login`
+6. To connect to windscribe, run `windscribe connect`
+7. If you need additional help, run `windscribe --help`
![Terminal](images/ready.png)
### Resources
[Windscribe](https://windscribe.com/)
-[Windscribe Linux Download](https://windscribe.com/guides/linux) \ No newline at end of file
+[Windscribe Linux Download](https://windscribe.com/guides/linux)
diff --git a/windscribe-cli.install b/windscribe-cli.install
index 319aa695b0ce..86194bf60fc8 100644
--- a/windscribe-cli.install
+++ b/windscribe-cli.install
@@ -8,6 +8,7 @@ post_upgrade() {
}
pre_remove() {
+ /usr/bin/windscribe firewall off
/usr/bin/windscribe logout
systemctl stop windscribe
}