aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarsha Kuchampudi2017-07-29 14:12:02 -0400
committerHarsha Kuchampudi2017-07-29 14:12:02 -0400
commit81b7fd0550373c2dc9641b283e09f5c1ebc5f2e5 (patch)
treef92075c60edf68524954577fbcfc0ae922bc1efa
downloadaur-81b7fd0550373c2dc9641b283e09f5c1ebc5f2e5.tar.gz
First AUR commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD57
-rw-r--r--README.md24
-rw-r--r--windscribe-cli.install22
4 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..916a1b89d331
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = windscribe-cli
+ pkgdesc = Port of Windscribe's VPN command line interface
+ pkgver = 1.0
+ pkgrel = 2
+ url = https://windscribe.com/
+ install = windscribe-cli.install
+ arch = any
+ license = GPL-2+
+ depends = openvpn
+ replaces = windscribe-cli
+ source = .deb::https://windscribe.com/install/desktop/linux_deb
+ sha256sums = 9b173b1548c04524861839ff6c2e49a2a0e6143e7438cf5f5a784301010d15d1
+
+pkgname = windscribe-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abd31ede688c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Harsha Kuchampudi <harshakuchampudi@gmail.com>
+pkgname=windscribe-cli
+pkgver=1.0
+pkgrel=2
+pkgdesc="Port of Windscribe's VPN command line interface"
+arch=('any')
+url="https://windscribe.com/"
+license=('GPL-2+')
+depends=('openvpn')
+replaces=('windscribe-cli')
+install="windscribe-cli.install"
+source=("$pkgname_$pkgver_all.deb::https://windscribe.com/install/desktop/linux_deb")
+sha256sums=('9b173b1548c04524861839ff6c2e49a2a0e6143e7438cf5f5a784301010d15d1')
+
+package() {
+ # Extract the debian package
+ echo "Extracting debian package"
+ ar vx $srcdir/$pkgname_$pkgver_all.deb
+ mkdir $srcdir/data
+ mkdir $srcdir/control
+ tar xf "data.tar.xz" -C "${srcdir}/data"
+ tar xf "control.tar.gz" -C "${srcdir}/control"
+
+ # Create systemd service
+ echo "Creating systemd service"
+ mkdir -p $srcdir/data/etc/systemd/system
+ echo "
+ [Unit]
+ Description=Windscribe VPN CLI Service
+ After=syslog.target network.target remote-fs.target nss-lookup.target
+
+ [Service]
+ Type=simple
+ ExecStart=/usr/bin/windscribe start
+ Restart=on-failure
+ PIDFile=/etc/windscribe/windscribe.pid
+
+ [Install]
+ WantedBy=multi-user.target
+ " >> $srcdir/data/etc/systemd/system/windscribe.service
+
+ # Configure bash completion
+ echo "Configuring bash completion"
+ mkdir $pkgdir/etc
+ cp -r "${srcdir}/data/etc/bash_completion.d" "${pkgdir}/etc/"
+ # Configure systemd service
+ echo "Configuring systemd service"
+ mkdir -p $pkgdir/etc/systemd/system/
+ cp "${srcdir}/data/etc/systemd/system/windscribe.service" "${pkgdir}/etc/systemd/system/"
+ chmod 0664 "${pkgdir}/etc/systemd/system/windscribe.service"
+ # Configure windscribe binary and docs
+ echo "Configuring binary and docs"
+ mkdir -p $pkgdir/usr/bin
+ cp -r "${srcdir}/data/usr/" "${pkgdir}/"
+ chmod 0755 "${pkgdir}/usr/bin/windscribe"
+ chmod 0755 -R "${pkgdir}/usr/share/doc/windscribe-cli"
+} \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..12537814ea5e
--- /dev/null
+++ b/README.md
@@ -0,0 +1,24 @@
+## Windscribe VPN CLI for Arch Linux
+
+**Update: You can now install this package from AUR: k**
+
+### Overview
+This repository contains the files necessary to build Windscribe VPN CLI for Arch Linux. Currently, Windscribe's CLI is in open beta, so users should anticipate breakages.
+
+### Installing
+In order the install Windscribe's CLI, use the following instructions:
+
+1. Clone this repository onto your local machine.
+2. `cd` into the cloned repository.
+3. Execute `makepkg -cs` to build the package.
+4. After the build process is finished, run `sudo pacman -U windscribe-cli-1.0-1-any.pkg.tar` to install the package.
+5. Close out of any active terminals (this is so that bash autocomplete works)
+6. Make sure that the windscribe daemon is running: `systemctl status windscribe.service`
+7. Now running `windscribe` in your terminal should bring-up the CLI
+
+![Terminal](images/ready.png)
+
+### Resources
+[Windscribe](https://windscribe.com/)
+
+[Windscribe Linux Download](https://windscribe.com/guides/linux) \ No newline at end of file
diff --git a/windscribe-cli.install b/windscribe-cli.install
new file mode 100644
index 000000000000..319aa695b0ce
--- /dev/null
+++ b/windscribe-cli.install
@@ -0,0 +1,22 @@
+post_install() {
+ . /etc/bash_completion.d/windscribe_complete
+ systemctl daemon-reload
+}
+
+post_upgrade() {
+ systemctl daemon-reload
+}
+
+pre_remove() {
+ /usr/bin/windscribe logout
+ systemctl stop windscribe
+}
+
+post_remove() {
+ rm -rf /etc/windscribe
+ rm -rf /usr/share/doc/windscribe-cli
+ rm -rf /etc/bash_completion.d/windscribe_complete
+ rm -rf /var/log/windscribe
+ systemctl daemon-reload
+ systemctl reset-failed
+}