summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2020-08-31 14:00:10 +0200
committerManuel Reimer2020-08-31 14:00:10 +0200
commitcb13f149ef2149527bcd781dadf05da9f09535bc (patch)
tree64f8b888fb9757d4c73acb07e4c02a6d92202026
parent8ff342604ccecaad3faf9803026efb0fd7afbe15 (diff)
downloadaur-cb13f149ef2149527bcd781dadf05da9f09535bc.tar.gz
Sync from GitHub (https://github.com/M-Reimer/wine-lol/commit/9b7b1f88ce77b7d79fa7f5c8dd78cb67f77f145d)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--wine-lol-bug-47198-fix.patch22
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2653ea1acf1..9d5441c6555f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by makepkg 5.2.2
-# Sat Aug 29 18:12:01 UTC 2020
+# Mon Aug 31 12:00:10 UTC 2020
pkgbase = wine-lol
pkgdesc = A compatibility layer for running Windows programs - Staging branch with League Of Legends fixes
pkgver = 5.6
diff --git a/PKGBUILD b/PKGBUILD
index 9a38a75dd586..cf853fd3dd16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@
# Primary bug report: https://bugs.winehq.org/show_bug.cgi?id=47198
pkgname=wine-lol
-# Note: We are forced to use Wine 5.6 until this bug is fixed:
-# https://bugs.winehq.org/show_bug.cgi?id=49025
+# Note: We are forced to use Wine 5.6 until whatever bug is fixed that makes it
+# impossible to launch a game with latest releases.
pkgver=5.6
pkgrel=1
diff --git a/wine-lol-bug-47198-fix.patch b/wine-lol-bug-47198-fix.patch
index 96220ed73eb1..504eff1e76fc 100644
--- a/wine-lol-bug-47198-fix.patch
+++ b/wine-lol-bug-47198-fix.patch
@@ -1,10 +1,11 @@
-diff -U 3 -pr a/dlls/ntdll/thread.c b/dlls/ntdll/thread.c
---- a/dlls/ntdll/thread.c 2020-08-29 17:04:09.498850399 +0200
-+++ b/dlls/ntdll/thread.c 2020-08-29 17:05:37.801890998 +0200
-@@ -226,6 +226,77 @@ int __cdecl __wine_dbg_header( enum __wi
- return unix_funcs->dbg_header( cls, channel, function );
+diff --git a/dlls/ntdll/thread.c b/dlls/ntdll/thread.c
+index c5b2008e44..96ca266921 100644
+--- a/dlls/ntdll/thread.c
++++ b/dlls/ntdll/thread.c
+@@ -268,6 +268,77 @@ static void set_process_name( int argc, char *argv[] )
}
+
+#ifdef __i386__
+#include <asm/ldt.h>
+#include <linux/audit.h>
@@ -77,13 +78,12 @@ diff -U 3 -pr a/dlls/ntdll/thread.c b/dlls/ntdll/thread.c
+
+
/***********************************************************************
- * __wine_dbg_output (NTDLL.@)
- */
-@@ -430,6 +501,11 @@ TEB *thread_init(void)
- unix_funcs->dbg_init();
- unix_funcs->get_paths( &build_dir, &data_dir, &config_dir );
+ * thread_init
+ *
+@@ -370,6 +441,10 @@ TEB *thread_init(void)
+ __wine_user_shared_data();
fill_cpu_info();
-+
+
+#ifdef __i386__
+ seccomp_init();
+#endif