summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland2023-03-04 11:43:09 +0100
committerRoland2023-03-04 11:43:09 +0100
commit2579e4b1f46f3a78ddbfb374ac39a1a48bb40554 (patch)
treea57f034e69a86456c2a1fb458e5b5df6db4f8ab9
parent93e15333c611610d85cab8cda03c43a9ff77649e (diff)
downloadaur-2579e4b1f46f3a78ddbfb374ac39a1a48bb40554.tar.gz
move libxrandr from optional to dependencies, remove opencl header hack
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9ab25ed362e..929c06661150 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-x64
pkgdesc = A compatibility layer for running Windows programs. This only configured with x64 support.
- pkgver = 8.0
+ pkgver = 8.2
pkgrel = 1
url = https://www.winehq.org/
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = wine-x64
makedepends = bison
depends = libx11
depends = fontconfig
+ depends = libxrandr
optdepends = v4l-utils
optdepends = opencl-headers
optdepends = libpulse
@@ -24,7 +25,6 @@ pkgbase = wine-x64
optdepends = libxi
optdepends = libxext
optdepends = libxxf86vm
- optdepends = libxrandr
optdepends = libxinerama
optdepends = libxcomposite
optdepends = mesa
@@ -32,15 +32,15 @@ pkgbase = wine-x64
optdepends = libusb
optdepends = libgudev
optdepends = sdl2
- provides = wine_x64=8.0
+ provides = wine_x64=8.2
conflicts = wine
options = staticlibs
- source = https://dl.winehq.org/wine/source/8.0/wine-8.0.tar.xz
- source = https://dl.winehq.org/wine/source/8.0/wine-8.0.tar.xz.sign
+ source = https://dl.winehq.org/wine/source/8.x/wine-8.2.tar.xz
+ source = https://dl.winehq.org/wine/source/8.x/wine-8.2.tar.xz.sign
source = 30-win32-aliases.conf
validpgpkeys = DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D
- sha512sums = 53ba813b260a65a271ec575822725b97631f60038fb026dcc0fe66862711eedcc29a8feb29ff54ae4f64458f85c290d8f3838eff5e4c77a5420a7d2b951fef77
- sha512sums = b13d5c00014cd87c149b0aea881e06e55a7a9a48e9b3ba8c9bf92e135a05136f570adc0201e521df1908c9c5b5f74f11459a2b2585ed074aea700f489ce86cd3
+ sha512sums = d0b8bb8c6d75034519bdf48d52b89f9d44ba4f7306a0b8f860cbb2c4c39d8fae3c2d9c12be37427b9a9cbdb7dd8701844d0a74c245dd7a9e8a423cb56962b254
+ sha512sums = 8d7df65cec24bc6bce919aa556140bcdceea2828e5283734847e31941b36fedd41b1a6397ee8ee604bf9797a0d1f8d499152403416bcd24fce7d1570c3ece891
sha512sums = 6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb
pkgname = wine-x64
diff --git a/PKGBUILD b/PKGBUILD
index b8c57d1fcb32..4b49b1457e17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Roland <hr_01y@protonmail.com>
pkgname=wine-x64
-pkgver=8.0
+pkgver=8.2
pkgrel=1
pkgdesc="A compatibility layer for running Windows programs. This only configured with x64 support."
url="https://www.winehq.org/"
@@ -15,10 +15,10 @@ license=(LGPL)
_pkgbasever=${pkgver/rc/-rc}
-source=(https://dl.winehq.org/wine/source/8.0/wine-$_pkgbasever.tar.xz{,.sign}
+source=(https://dl.winehq.org/wine/source/8.x/wine-$_pkgbasever.tar.xz{,.sign}
30-win32-aliases.conf)
-sha512sums=('53ba813b260a65a271ec575822725b97631f60038fb026dcc0fe66862711eedcc29a8feb29ff54ae4f64458f85c290d8f3838eff5e4c77a5420a7d2b951fef77'
- 'b13d5c00014cd87c149b0aea881e06e55a7a9a48e9b3ba8c9bf92e135a05136f570adc0201e521df1908c9c5b5f74f11459a2b2585ed074aea700f489ce86cd3'
+sha512sums=('d0b8bb8c6d75034519bdf48d52b89f9d44ba4f7306a0b8f860cbb2c4c39d8fae3c2d9c12be37427b9a9cbdb7dd8701844d0a74c245dd7a9e8a423cb56962b254'
+ '8d7df65cec24bc6bce919aa556140bcdceea2828e5283734847e31941b36fedd41b1a6397ee8ee604bf9797a0d1f8d499152403416bcd24fce7d1570c3ece891'
'6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb')
validpgpkeys=(DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D)
@@ -27,6 +27,7 @@ provides=("wine_x64=$pkgver")
depends=(
libx11
fontconfig
+ libxrandr
)
makedepends=(
@@ -50,7 +51,7 @@ optdepends=(
libxi
libxext
libxxf86vm
- libxrandr
+
libxinerama
libxcomposite
mesa
@@ -65,9 +66,6 @@ conflicts=(
)
prepare() {
-
- sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i wine-$_pkgbasever/configure*
-
# Get rid of old build dirs
rm -rf wine-64-build
}