summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland2019-07-18 07:09:20 +0200
committerRoland2019-07-18 07:09:20 +0200
commit7176775f6281910f4c10383b2b2d6d9c03ceffcf (patch)
tree2be5b175988e377d7d2171988268aac568242260
parent67e83c2ccafcef508762cc15ac20bebf2c8ca417 (diff)
downloadaur-7176775f6281910f4c10383b2b2d6d9c03ceffcf.tar.gz
update to new wine version, compile without mingw
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD84
2 files changed, 24 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46ff1ae29304..b7fc8a49b719 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-x64
- pkgdesc = A compatibility layer for running Windows programs
- pkgver = 4.7
+ pkgdesc = A compatibility layer for running Windows programs. This only configured with x64 support.
+ pkgver = 4.12.1
pkgrel = 1
url = http://www.winehq.com
arch = x86_64
@@ -26,12 +26,12 @@ pkgbase = wine-x64
depends = libxi
depends = freetype2
options = staticlibs
- source = https://dl.winehq.org/wine/source/4.x/wine-4.7.tar.xz
- source = https://dl.winehq.org/wine/source/4.x/wine-4.7.tar.xz.sign
+ source = https://dl.winehq.org/wine/source/4.x/wine-4.12.1.tar.xz
+ source = https://dl.winehq.org/wine/source/4.x/wine-4.12.1.tar.xz.sign
source = 30-win32-aliases.conf
validpgpkeys = DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D
- sha512sums = cb768528db510f81d464b9c1bb48847162baaa86ef00dc7a418afdce38aa51262d150c14b3362fb40c93cc2e3633fc02b2916167f21af8a708eb393da6ba9163
- sha512sums = 5ab8ee632d5cddbcc36fe68b7cfa06c5d8f77670af5ac2ed9e6eedbe4390a14d461b5920e199dc35f55b25f184f71d7718a54a250dd10fa30ced65e3c1c0f4a6
+ sha512sums = 5d226aa4f24c59949c88d377d8f3d38839179e473b7e5bbf029af8142dfa23fd046ca919b63c8c8fc7e1a46077a860d3dab9d2e040f0367c85c8d386707222c1
+ sha512sums = 28e6f64531b7f0e566424ce50f61c4115f3923c1182c726ba252ae890c1f038d94551fdddb93d7ba791c28b064e858b1c24e84417b66f6175d98581284eb0535
sha512sums = 6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb
pkgname = wine-x64
diff --git a/PKGBUILD b/PKGBUILD
index 345dcc827daa..2cf6b4c165b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,14 @@
-# Maintainer: Roland Angerbauer <roland.angerbauer@gmail.com>
+# Maintainer: Roland <hr_01y@protonmail.com>
pkgname=wine-x64
-pkgver=4.7
+pkgver=4.12.1
pkgrel=1
+pkgdesc="A compatibility layer for running Windows programs. This only configured with x64 support."
+url="http://www.winehq.com"
+arch=(x86_64)
+options=(staticlibs)
+license=(LGPL)
+
# replacing rc with -rc
# pkgver is not allowed to contain hyphens
@@ -10,85 +16,29 @@ _pkgbasever=${pkgver/rc/-rc}
source=(https://dl.winehq.org/wine/source/4.x/wine-$_pkgbasever.tar.xz{,.sign}
30-win32-aliases.conf)
-sha512sums=('cb768528db510f81d464b9c1bb48847162baaa86ef00dc7a418afdce38aa51262d150c14b3362fb40c93cc2e3633fc02b2916167f21af8a708eb393da6ba9163'
- '5ab8ee632d5cddbcc36fe68b7cfa06c5d8f77670af5ac2ed9e6eedbe4390a14d461b5920e199dc35f55b25f184f71d7718a54a250dd10fa30ced65e3c1c0f4a6'
+sha512sums=('5d226aa4f24c59949c88d377d8f3d38839179e473b7e5bbf029af8142dfa23fd046ca919b63c8c8fc7e1a46077a860d3dab9d2e040f0367c85c8d386707222c1'
+ '28e6f64531b7f0e566424ce50f61c4115f3923c1182c726ba252ae890c1f038d94551fdddb93d7ba791c28b064e858b1c24e84417b66f6175d98581284eb0535'
'6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb')
validpgpkeys=(DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D)
-pkgdesc="A compatibility layer for running Windows programs"
-url="http://www.winehq.com"
-arch=(x86_64)
-options=(staticlibs)
-license=(LGPL)
+
depends=(
libx11
fontconfig
lcms2
sdl2
-# libxml2
libxcursor
libjpeg
libxslt
libxrandr
-# libxdamage
libxi
-# gettext
freetype2
-# glu
-# libsm
-# gcc-libs
-# libpcap
-# desktop-file-utils
-)
-makedepends=(
-# autoconf
-# ncurses
-# bison
-# perl
-# flex
-# 'gcc>=4.5.0-2'
-# giflib
-# libpng
-# gnutls
-# libxinerama
-# libxcomposite
-# libxmu
-# libxxf86vm
-# libldap
-# mpg123
-# openal
-# v4l-utils
-# libpulse
-# alsa-lib
-# libxcomposite
-# mesa
-# mesa-libgl
-# opencl-icd-loader
-# libxslt
-# gst-plugins-base-libs
-)
-optdepends=(
-# giflib
-# libpng
-# libldap
-# gnutls
-# mpg123
-# openal
-# v4l-utils
-# libpulse
-# alsa-plugins
-# alsa-lib
-# libjpeg-turbo
-# libxcomposite
-# libxinerama
-# ncurses
-# opencl-icd-loader
-# libxslt
-# gst-plugins-base-libs
-# cups
-# samba
-# dosbox
)
+
+makedepends=()
+
+optdepends=()
+
makedepends=(${makedepends[@]} ${depends[@]})
prepare() {
@@ -125,6 +75,7 @@ build() {
--without-mpg123 \
--without-sane \
--without-gphoto \
+ --without-mingw \
--without-openal \
--without-cups \
--without-v4l2 \
@@ -147,3 +98,4 @@ package() {
install -m644 "$srcdir/30-win32-aliases.conf" "$pkgdir/etc/fonts/conf.avail"
ln -s ../conf.avail/30-win32-aliases.conf "$pkgdir/etc/fonts/conf.d/30-win32-aliases.conf"
}
+