summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConorIA2016-10-20 10:59:20 -0400
committerConorIA2016-10-20 10:59:20 -0400
commit630bd0a9ffe4db02db5f0ae971e40abd3d9f3468 (patch)
tree7585962ed58f7c8d8a12795e3204905fd1345720
parent05bbec34326217f80d1057fafc800be995d5a0db (diff)
downloadaur-630bd0a9ffe4db02db5f0ae971e40abd3d9f3468.tar.gz
make builds arch-specific
-rw-r--r--.gitignore4
-rw-r--r--Gruntfile.patch19
-rw-r--r--PKGBUILD10
3 files changed, 30 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e720ab4a9a3b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+src
+pkg
+wire-desktop
diff --git a/Gruntfile.patch b/Gruntfile.patch
new file mode 100644
index 000000000000..74f29fa45803
--- /dev/null
+++ b/Gruntfile.patch
@@ -0,0 +1,19 @@
+--- Gruntfile.coffee 2016-10-13 14:50:16.109307947 -0400
++++ Gruntfile.coffee.new 2016-10-18 11:38:08.136490000 -0400
+@@ -17,6 +17,7 @@
+ #
+
+ electron_packager = require 'electron-packager'
++os = require 'os'
+
+ ELECTRON_PACKAGE_JSON = 'electron/package.json'
+ PACKAGE_JSON = 'package.json'
+@@ -114,6 +115,8 @@
+ linux:
+ options:
+ platform: 'linux'
++ arch: os.arch()
++
+
+ 'create-windows-installer':
+ internal:
diff --git a/PKGBUILD b/PKGBUILD
index 667981bbf8d6..7423e1dbf71a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Conor Anderson <conor.anderson@mail.utoronto.ca>
pkgname=wire-desktop-git
_pkgname=wire-desktop
-pkgver=2.11.2661.r1.ga433bf2
+pkgver=2.11.2665.r0.g3f4c0dd
pkgrel=1
pkgdesc='Modern communication, full privacy.'
arch=('x86_64' 'i686')
@@ -11,8 +11,10 @@ conflicts=('wire-desktop-bin' 'wire-desktop')
depends=('nss' 'alsa-lib' 'libxss' 'gconf' 'gtk2' 'libxtst')
makedepends=('npm' 'nodejs-grunt-cli' 'gendesk' 'python2')
provides=('wire-desktop')
-source=("git://github.com/wireapp/wire-desktop.git")
-sha256sums=(SKIP)
+source=("git://github.com/wireapp/wire-desktop.git"
+ "Gruntfile.patch")
+sha256sums=(SKIP
+ 'fc8a2d5badde0b3049df843f497a999a8cfeff05a261343d9094d3ba35ca4202')
pkgver() {
cd ${srcdir}/${_pkgname}
@@ -21,6 +23,8 @@ pkgver() {
prepare() {
gendesk -f -n --name=Wire --pkgname=${_pkgname} --pkgdesc="${pkgdesc}" --exec=wire --categories="Network"
+ cd ${srcdir}/${_pkgname}
+ patch -p0 < $startdir/Gruntfile.patch
}
build() {