summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConor Anderson2017-07-17 09:19:37 -0500
committerConor Anderson2017-07-17 09:19:37 -0500
commitafcad6570623746efbd63259ff04a6742022bfcd (patch)
tree154c02da6003a932dde6167a5e1a1da9a56fbcb6
parentdaa10e8ef7134b315f951a237029272a88b500d2 (diff)
downloadaur-afcad6570623746efbd63259ff04a6742022bfcd.tar.gz
Use npm-installed grunt
-rwxr-xr-x.SRCINFO1
-rwxr-xr-xPKGBUILD6
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e16dc3972f6..66a9d8f57ba0 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,6 @@ pkgbase = wire-desktop-git
license = GPL3
makedepends = cargo
makedepends = gendesk
- makedepends = grunt-cli
makedepends = npm
makedepends = python2
depends = alsa-lib
diff --git a/PKGBUILD b/PKGBUILD
index de40bb635376..b98d4064319d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ url='https://wire.com/'
license=('GPL3')
conflicts=('wire-desktop-bin' 'wire-desktop')
depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nss')
-makedepends=('cargo' 'gendesk' 'grunt-cli' 'npm' 'python2')
+makedepends=('cargo' 'gendesk' 'npm' 'python2')
optdepends=('hunspell-en: for English spellcheck support')
provides=('wire-desktop')
source=("git://github.com/wireapp/wire-desktop.git")
@@ -27,7 +27,7 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
npm install
- grunt 'clean:linux' 'update-keys' 'release-prod' 'bundle'
+ $(npm bin)/grunt 'clean:linux' 'update-keys' 'release-prod' 'bundle'
if [ $CARCH == 'x86_64' ]; then
build_arch="x64"
elif [ $CARCH == 'i686' ]; then
@@ -35,7 +35,7 @@ build() {
else
echo "Unsupported architecture"; exit 1;
fi
- grunt --arch=${build_arch} --target="dir" "electronbuilder:linux_other"
+ $(npm bin)/grunt --arch=${build_arch} --target="dir" "electronbuilder:linux_other"
}
package() {