summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConor Anderson2016-11-01 19:38:58 -0400
committerConor Anderson2016-11-01 19:38:58 -0400
commitd91ce4dbfb409cc886865eed2e00b09c7f4f21d9 (patch)
tree2a2d63339db9f471a898eafcef6f5ea2a8cdde83
parentdc1a04485b7a77dd3089bacfa3d7375c8bf209f7 (diff)
downloadaur-d91ce4dbfb409cc886865eed2e00b09c7f4f21d9.tar.gz
Package improvements
-rw-r--r--.SRCINFO6
-rw-r--r--Gruntfile.patch56
-rw-r--r--PKGBUILD48
3 files changed, 29 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4be28cf533bd..734f5c366182 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = wire-desktop-git
- pkgdesc = Modern communication, full privacy.
+ pkgdesc = Modern, private messenger. Based on Electron.
pkgver = 2.11.2668.r0.gb724780
pkgrel = 1
url = https://wire.com/
@@ -7,7 +7,7 @@ pkgbase = wire-desktop-git
arch = i686
license = GPL3
makedepends = npm
- makedepends = nodejs-grunt-cli
+ makedepends = grunt-cli
makedepends = gendesk
makedepends = python2
depends = nss
@@ -20,9 +20,7 @@ pkgbase = wire-desktop-git
conflicts = wire-desktop-bin
conflicts = wire-desktop
source = git://github.com/wireapp/wire-desktop.git
- source = Gruntfile.patch
sha256sums = SKIP
- sha256sums = ca467ed7cf823e1a47cc123793bae4fc536b3a44b0013c3cb30f8b8b37909dec
pkgname = wire-desktop-git
diff --git a/Gruntfile.patch b/Gruntfile.patch
deleted file mode 100644
index 0be4e61199cb..000000000000
--- a/Gruntfile.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-*** Gruntfile.coffee 2016-11-01 13:45:17.512009583 -0400
---- Gruntfile.new 2016-11-01 13:38:20.923493955 -0400
-***************
-*** 17,22 ****
---- 17,23 ----
- #
-
- electron_packager = require 'electron-packager'
-+ os = require 'os'
-
- ELECTRON_PACKAGE_JSON = 'electron/package.json'
- PACKAGE_JSON = 'package.json'
-***************
-*** 111,116 ****
---- 112,122 ----
- ProductName: '<%= info.name %>'
- InternalName: '<%= info.name %>.exe'
-
-+ linux:
-+ options:
-+ platform: 'linux'
-+ arch: os.arch()
-+
- 'create-windows-installer':
- internal:
- title: '<%= info.nameInternal %>'
-***************
-*** 252,264 ****
- execSync "productbuild --component '#{options.dir}' /Applications --sign '#{options.sign.package}' '#{options.name}.pkg'"
-
-
-! grunt.registerTask 'release', ['build-inc', 'gitcommit', 'gittag', 'gitpush']
-
-! grunt.registerTask 'macos', ['clean:macos', 'update-keys', 'release-internal', 'electron:macos_internal']
-! grunt.registerTask 'macos-prod', ['clean:macos', 'update-keys', 'release-prod', 'electron:macos_prod', 'productbuild']
-
-! grunt.registerTask 'win', ['clean:win', 'update-keys', 'release-internal', 'electron:win_internal', 'create-windows-installer:internal']
-! grunt.registerTask 'win-prod', ['clean:win', 'update-keys', 'release-prod', 'electron:win_prod', 'create-windows-installer:prod']
-
-! grunt.registerTask 'linux', ['clean:linux', 'update-keys', 'release-internal', 'shell']
-! grunt.registerTask 'linux-prod', ['clean:linux', 'update-keys', 'release-prod', 'shell']
---- 258,271 ----
- execSync "productbuild --component '#{options.dir}' /Applications --sign '#{options.sign.package}' '#{options.name}.pkg'"
-
-
-! grunt.registerTask 'release', ['build-inc', 'gitcommit', 'gittag', 'gitpush']
-
-! grunt.registerTask 'macos', ['clean:macos', 'update-keys', 'release-internal', 'electron:macos_internal']
-! grunt.registerTask 'macos-prod', ['clean:macos', 'update-keys', 'release-prod', 'electron:macos_prod', 'productbuild']
-
-! grunt.registerTask 'win', ['clean:win', 'update-keys', 'release-internal', 'electron:win_internal', 'create-windows-installer:internal']
-! grunt.registerTask 'win-prod', ['clean:win', 'update-keys', 'release-prod', 'electron:win_prod', 'create-windows-installer:prod']
-
-! grunt.registerTask 'linux', ['clean:linux', 'update-keys', 'release-internal', 'shell']
-! grunt.registerTask 'linux-prod', ['clean:linux', 'update-keys', 'release-prod', 'shell']
-! grunt.registerTask 'linux-local', ['clean:linux', 'update-keys', 'release-prod', 'electron:linux']
diff --git a/PKGBUILD b/PKGBUILD
index a741c672ea20..dcfc8d74eff6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Conor Anderson <conor.anderson@mail.utoronto.ca>
pkgname=wire-desktop-git
_pkgname=wire-desktop
+_name=wire
pkgver=2.11.2668.r0.gb724780
pkgrel=1
-pkgdesc='Modern communication, full privacy.'
+pkgdesc='Modern, private messenger. Based on Electron.'
arch=('x86_64' 'i686')
url='https://wire.com/'
license=('GPL3')
conflicts=('wire-desktop-bin' 'wire-desktop')
depends=('nss' 'alsa-lib' 'libxss' 'gconf' 'gtk2' 'libxtst')
-makedepends=('npm' 'nodejs-grunt-cli' 'gendesk' 'python2')
+makedepends=('npm' 'grunt-cli' 'gendesk' 'python2')
provides=('wire-desktop')
-source=("git://github.com/wireapp/wire-desktop.git"
- "Gruntfile.patch")
-sha256sums=('SKIP'
- 'ca467ed7cf823e1a47cc123793bae4fc536b3a44b0013c3cb30f8b8b37909dec')
+source=("git://github.com/wireapp/wire-desktop.git")
+sha256sums=('SKIP')
pkgver() {
cd ${srcdir}/${_pkgname}
@@ -22,37 +21,44 @@ pkgver() {
}
prepare() {
- gendesk -f -n --name=Wire --pkgname=${_pkgname} --pkgdesc="${pkgdesc}" --exec=wire --categories="Network"
- cd ${srcdir}/${_pkgname}
- patch -p0 < $startdir/Gruntfile.patch
+ gendesk -f -n --name=Wire --pkgname=${_name} --pkgdesc="${pkgdesc}" --exec=${_name} --categories="Network"
}
build() {
- cd ${srcdir}/${_pkgname}
+ cd ${srcdir}/${pkgname}-release-${pkgver}
npm install
- grunt linux-local
+ grunt 'clean:linux' 'update-keys' 'release-prod'
+ if [ $CARCH == 'x86_64' ]; then
+ node_modules/.bin/build --linux --x64 --dir
+ elif [ $CARCH == 'i686' ]; then
+ node_modules/.bin/build --linux --ia32 --dir
+ else
+ echo "Unknown architecture"; exit 1;
+ fi
}
package() {
# Place files
- install -d ${pkgdir}/opt/${_pkgname}
+ install -d ${pkgdir}/usr/lib/${_name}
if [ $CARCH == 'x86_64' ]; then
- cp -a ${srcdir}/${_pkgname}/wrap/build/Wire-linux-x64/* ${pkgdir}/opt/${_pkgname}
+ cp -a ${srcdir}/${_pkgname}/wrap/dist/linux-unpacked/* ${pkgdir}/usr/lib/${_name}
+ elif [ $CARCH == 'i686' ]; then
+ cp -a ${srcdir}/${_pkgname}/wrap/dist/linux-ia32-unpacked/* ${pkgdir}/usr/lib/${_name}
else
- cp -a ${srcdir}/${_pkgname}/wrap/build/Wire-linux-ia32/* ${pkgdir}/opt/${_pkgname}
+ echo "Unknown architecture"; exit 1;
fi
# Symlink main binary
install -d ${pkgdir}/usr/bin
- ln -s "/opt/${_pkgname}/Wire" "${pkgdir}/usr/bin/wire"
+ ln -s "/usr/lib/${_name}/Wire" "${pkgdir}/usr/bin/${_name}"
# Place desktop entry and icon
- install -Dm644 ${_pkgname}.desktop ${pkgdir}/usr/share/applications/${_pkgname}.desktop
- install -Dm644 ${srcdir}/${_pkgname}/electron/img/wire.png ${pkgdir}/usr/share/pixmaps/${_pkgname}.png
+ install -Dm644 ${_name}.desktop ${pkgdir}/usr/share/applications/${_name}.desktop
+ install -Dm644 ${srcdir}/${_pkgname}/electron/img/wire.png ${pkgdir}/usr/share/pixmaps/${_name}.png
# Place license files
- install -Dm644 "${pkgdir}/opt/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
- install -Dm644 "${pkgdir}/opt/${_pkgname}/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSES.chromium.html"
- rm "${pkgdir}/opt/${_pkgname}/LICENSE"
- rm "${pkgdir}/opt/${_pkgname}/LICENSES.chromium.html"
+ install -Dm644 "${pkgdir}/usr/lib/${_name}/LICENSE" "${pkgdir}/usr/share/licenses/${_name}/LICENSE"
+ install -Dm644 "${pkgdir}/usr/lib/${_name}/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${_name}/LICENSES.chromium.html"
+ rm "${pkgdir}/usr/lib/${_name}/LICENSE"
+ rm "${pkgdir}/usr/lib/${_name}/LICENSES.chromium.html"
}