summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEarnestly2016-01-22 23:36:19 +0000
committerEarnestly2016-01-22 23:36:19 +0000
commit50675f5ff1af64cbc69d07f2c7e019ae554e60b6 (patch)
treedff5490546c354185d0974628c0ac6e4cdadd675
parent827bfa62cb4a4234920c357662cdcb7b86eb8495 (diff)
downloadaur-50675f5ff1af64cbc69d07f2c7e019ae554e60b6.tar.gz
wlc: no weak linking, most optional deps are now required
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13bf15b92ade..3be8d1feefc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Jan 22 23:35:08 UTC 2016
pkgbase = wlc-git
- pkgdesc = Wayland compositor library.
- pkgver = r822.359cfe7
+ pkgdesc = Wayland compositor library
+ pkgver = r845.66425fb
pkgrel = 1
url = https://github.com/Cloudef/wlc
arch = i686
@@ -8,25 +10,22 @@ pkgbase = wlc-git
license = GPL
makedepends = git
makedepends = cmake
- makedepends = libx11
- makedepends = libxcb
- makedepends = libgl
- makedepends = xcb-util-image
depends = wayland
depends = pixman
depends = libxkbcommon
depends = libinput
- optdepends = libx11: Running the compositor as an Xorg client
- optdepends = libxcb: Running the compositor as an Xorg client
- optdepends = mesa: For optional platform support (GLESv2, EGL, DRM)
- optdepends = nvidia: For optional platform support (GLESv2, EGL)
- optdepends = xcb-util-image: Needed for xwayland support.
+ depends = libx11
+ depends = libxcb
+ depends = libgl
+ depends = libdrm
+ depends = mesa
+ depends = xcb-util-image
provides = wlc
conflicts = wlc
- options = !debug
+ options = debug
options = !strip
- source = git://github.com/Cloudef/wlc
- source = git://github.com/Cloudef/chck
+ source = git+https://github.com/Cloudef/wlc
+ source = git+https://github.com/Cloudef/chck
sha1sums = SKIP
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 11b1ae029877..28e388ca7db3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
pkgname=wlc-git
-pkgver=r822.359cfe7
+pkgver=r845.66425fb
pkgrel=1
-pkgdesc='Wayland compositor library.'
+pkgdesc='Wayland compositor library'
url='https://github.com/Cloudef/wlc'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('wayland' 'pixman' 'libxkbcommon' 'libinput')
-makedepends=('git' 'cmake' 'libx11' 'libxcb' 'libgl' 'xcb-util-image')
+options=('debug' '!strip')
-optdepends=('libx11: Running the compositor as an Xorg client'
- 'libxcb: Running the compositor as an Xorg client'
- 'mesa: For optional platform support (GLESv2, EGL, DRM)'
- 'nvidia: For optional platform support (GLESv2, EGL)'
- 'xcb-util-image: Needed for xwayland support.')
+depends=('wayland' 'pixman' 'libxkbcommon' 'libinput' 'libx11' 'libxcb' 'libgl'
+ 'libdrm' 'mesa' 'xcb-util-image')
+makedepends=('git' 'cmake')
provides=('wlc')
conflicts=('wlc')
-source=('git://github.com/Cloudef/wlc'
- 'git://github.com/Cloudef/chck')
+source=('git+https://github.com/Cloudef/wlc'
+ 'git+https://github.com/Cloudef/chck')
sha1sums=('SKIP' 'SKIP')
-options=('!debug' '!strip')
-
pkgver() {
cd wlc
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"