summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEarnestly2015-08-10 14:39:12 +0100
committerEarnestly2015-08-10 14:39:12 +0100
commit6ca906da0d15d79cc0d94c4a35e40a6c2759f8e7 (patch)
tree14c184c2353b5cf9381534ec700549b20fc877a3
downloadaur-6ca906da0d15d79cc0d94c4a35e40a6c2759f8e7.tar.gz
Add wlc-git
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD53
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed8c867fdc7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = wlc-git
+ pkgdesc = Wayland compositor library.
+ pkgver = r643.0cfdd6e
+ pkgrel = 2
+ url = https://github.com/Cloudef/wlc
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = wayland
+ depends = pixman
+ depends = libxkbcommon
+ depends = libinput
+ optdepends = mesa: For optional platform support (GLESv2, EGL, DRM)
+ optdepends = nvidia: For optional platform support (GLESv2, EGL)
+ optdepends = libx11: Running the compositor as an Xorg client
+ optdepends = libxcb: Running the compositor as an Xorg client
+ provides = wlc
+ conflicts = wlc
+ options = debug
+ options = !strip
+ source = git://github.com/Cloudef/wlc
+ source = git://github.com/Cloudef/chck
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = wlc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fcca645676f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+pkgname=wlc-git
+pkgver=r643.0cfdd6e
+pkgrel=2
+
+pkgdesc='Wayland compositor library.'
+url='https://github.com/Cloudef/wlc'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+depends=('wayland' 'pixman' 'libxkbcommon' 'libinput')
+makedepends=('git' 'cmake')
+optdepends=('mesa: For optional platform support (GLESv2, EGL, DRM)'
+ 'nvidia: For optional platform support (GLESv2, EGL)'
+ 'libx11: Running the compositor as an Xorg client'
+ 'libxcb: Running the compositor as an Xorg client')
+
+provides=('wlc')
+conflicts=('wlc')
+
+source=('git://github.com/Cloudef/wlc'
+ 'git://github.com/Cloudef/chck')
+
+md5sums=('SKIP' 'SKIP')
+
+options=('debug' '!strip')
+
+pkgver() {
+ cd wlc
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd wlc
+ git submodule init
+ git config submodule.chck.url "$srcdir"/chck
+ git submodule update lib/chck/src
+}
+
+build() {
+ cd wlc
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+check() {
+ cd wlc
+ make test
+}
+
+package() {
+ cd wlc
+ make DESTDIR="$pkgdir" install
+}