summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Herzberg2019-05-27 22:30:15 +0100
committerMichael Herzberg2019-05-27 22:30:15 +0100
commitbfd9f7ac7824ad2a4e1ac418e208d71f9882c7bb (patch)
treef7173e94d29bbd82fe5d947b91f4c777f9257453
downloadaur-wlr-brightness-git.tar.gz
Added wlr-brightness-git.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b6c37f86478
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wlr-brightness-git
+ pkgdesc = Adjust the brightness of wlroots-based compositors such as sway.
+ pkgver = r5.b498003
+ pkgrel = 1
+ url = https://github.com/mherzberg/wlr-brightness
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = glib2
+ depends = wayland
+ depends = wlroots
+ source = wlr-brightness-git::git+https://github.com/mherzberg/wlr-brightness.git
+ md5sums = SKIP
+
+pkgname = wlr-brightness-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..235e82d924bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Michael Herzberg <{firstname}@{firstinitial}{lastname}.de>
+
+pkgname=wlr-brightness-git
+pkgver=r5.b498003
+pkgrel=1
+pkgdesc='Adjust the brightness of wlroots-based compositors such as sway.'
+arch=('x86_64')
+license=('MIT')
+url='https://github.com/mherzberg/wlr-brightness'
+depends=('glib2' 'wayland' 'wlroots')
+makedepends=('git')
+source=("$pkgname"::"git+https://github.com/mherzberg/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make INSTALL_PATH="$pkgdir/usr" install
+ install -Dm644 res/wlr-brightness.service "$pkgdir/usr/lib/systemd/user/wlr-brightness.service"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}