summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Snowhill2024-05-04 16:21:51 -0700
committerChristopher Snowhill2024-05-04 16:21:51 -0700
commita6ae0dafeb75f1359f7ee89029816d02300a3e8d (patch)
treeabfb6ee07294b193d4f5dec77ef6839a26e1568f
parent21f341dab287f597ebb1a22e625e0e11f8d96d2a (diff)
downloadaur-wlroots-hidpi-xprop.tar.gz
Backport upstream merged patch
-rw-r--r--.SRCINFO4
-rw-r--r--4668.patch40
-rw-r--r--PKGBUILD9
3 files changed, 49 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a045cac45cf..8954511457a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wlroots-hidpi-xprop
pkgdesc = Modular Wayland compositor library (stable, with patches)
pkgver = 0.17.3
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.freedesktop.org/wlroots/wlroots
arch = x86_64
license = MIT
@@ -35,9 +35,11 @@ pkgbase = wlroots-hidpi-xprop
source = 0001-xwayland-support-HiDPI-scale.patch
source = 0002-Fix-configure_notify-event.patch
source = 0003-Fix-size-hints-under-Xwayland-scaling.patch
+ source = 4668.patch
sha512sums = fedb687840b1b0bd29049b3d7fae1f1b08c74d603b1e26b410d40a1fbcac05fef1a8b8d53f700a8c789f7280e8871776f02523635bf0d0aa7187511ef61af060
sha512sums = ca05b46c8222e6982c848944ff2afe7765a2e76bb90e29c9d5b5dde9b51a0038bce8b0d52d01c390c970319ef10614ab1454a66940bf3a5b6193fc7f189afe6b
sha512sums = 484c8a6848b1409a16403bf0c3e366bf5203716824c24e16efcdcdb71ff34c42b5da6e3da338fafea70ad80fcdd3d6e9f070fb809093d8b0b08ee0b2c95a4de4
sha512sums = 8e3e77f6df204b6e5aa770be61fc8a6525e295cc8acdb0084ce66463e78f11702cf066640b20d7ff9560bdcdf7fa626db2e90651dcd42670250f45ac0f636854
+ sha512sums = 72e48d6e98a702425055f4eda980e8997635b717eefcf4f2e35e7e6a0b9115bde9d000b8ec1d6c4a22d2050efc39e0035e9c590a643cc011a78d8b8ba2bc7198
pkgname = wlroots-hidpi-xprop
diff --git a/4668.patch b/4668.patch
new file mode 100644
index 000000000000..c39baa0e2a90
--- /dev/null
+++ b/4668.patch
@@ -0,0 +1,40 @@
+From 8fdf9dc4f0b62029018850bb11406b2e69d86905 Mon Sep 17 00:00:00 2001
+From: Kirill Primak <vyivel@eclair.cafe>
+Date: Sun, 5 May 2024 01:54:59 +0300
+Subject: [PATCH] scene: fix double scaling of opaque region for blend mode
+ optimization
+
+---
+ types/scene/wlr_scene.c | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/types/scene/wlr_scene.c b/types/scene/wlr_scene.c
+index 78c322d46..1d6d7ab9b 100644
+--- a/types/scene/wlr_scene.c
++++ b/types/scene/wlr_scene.c
+@@ -1181,16 +1181,19 @@ static void scene_entry_render(struct render_list_entry *entry, const struct ren
+ return;
+ }
+
++ int x = entry->x - data->logical.x;
++ int y = entry->y - data->logical.y;
++
+ struct wlr_box dst_box = {
+- .x = entry->x - data->logical.x,
+- .y = entry->y - data->logical.y,
++ .x = x,
++ .y = y,
+ };
+ scene_node_get_size(node, &dst_box.width, &dst_box.height);
+ scale_box(&dst_box, data->scale);
+
+ pixman_region32_t opaque;
+ pixman_region32_init(&opaque);
+- scene_node_opaque_region(node, dst_box.x, dst_box.y, &opaque);
++ scene_node_opaque_region(node, x, y, &opaque);
+ scale_output_damage(&opaque, data->scale);
+ pixman_region32_subtract(&opaque, &render_region, &opaque);
+
+--
+GitLab
+
diff --git a/PKGBUILD b/PKGBUILD
index c16751bd7f5d..4e72fbcacc68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-hidpi-xprop
pkgver=0.17.3
-pkgrel=1
+pkgrel=2
license=(MIT)
pkgdesc='Modular Wayland compositor library (stable, with patches)'
url=https://gitlab.freedesktop.org/wlroots/wlroots
@@ -42,11 +42,13 @@ makedepends=(
source=("${pkgname}::git+${url}#tag=${pkgver}"
0001-xwayland-support-HiDPI-scale.patch
0002-Fix-configure_notify-event.patch
- 0003-Fix-size-hints-under-Xwayland-scaling.patch)
+ 0003-Fix-size-hints-under-Xwayland-scaling.patch
+ 4668.patch)
sha512sums=('fedb687840b1b0bd29049b3d7fae1f1b08c74d603b1e26b410d40a1fbcac05fef1a8b8d53f700a8c789f7280e8871776f02523635bf0d0aa7187511ef61af060'
'ca05b46c8222e6982c848944ff2afe7765a2e76bb90e29c9d5b5dde9b51a0038bce8b0d52d01c390c970319ef10614ab1454a66940bf3a5b6193fc7f189afe6b'
'484c8a6848b1409a16403bf0c3e366bf5203716824c24e16efcdcdb71ff34c42b5da6e3da338fafea70ad80fcdd3d6e9f070fb809093d8b0b08ee0b2c95a4de4'
- '8e3e77f6df204b6e5aa770be61fc8a6525e295cc8acdb0084ce66463e78f11702cf066640b20d7ff9560bdcdf7fa626db2e90651dcd42670250f45ac0f636854')
+ '8e3e77f6df204b6e5aa770be61fc8a6525e295cc8acdb0084ce66463e78f11702cf066640b20d7ff9560bdcdf7fa626db2e90651dcd42670250f45ac0f636854'
+ '72e48d6e98a702425055f4eda980e8997635b717eefcf4f2e35e7e6a0b9115bde9d000b8ec1d6c4a22d2050efc39e0035e9c590a643cc011a78d8b8ba2bc7198')
prepare () {
cd "${pkgname}"
@@ -54,6 +56,7 @@ prepare () {
patch -Np1 < ../0001-xwayland-support-HiDPI-scale.patch
patch -Np1 < ../0002-Fix-configure_notify-event.patch
patch -Np1 < ../0003-Fix-size-hints-under-Xwayland-scaling.patch
+ patch -Np1 < ../4668.patch
}
build () {