summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2023-07-02 14:11:25 -0500
committerkyechou2023-07-02 14:11:30 -0500
commit8eeae2bb1734f427fd4b6be147c4d54844534c4a (patch)
tree34cac18b6f65e40600f4ec3c8700d89cc5e4c1f4
parentdf11728849ccfdec64a5404be0e75cd98db5d287 (diff)
downloadaur-wlroots-nvidia-git.tar.gz
Fix nvidia patch and package dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--nvidia.patch8
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 982806c01a5a..b08ed3453aa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wlroots-nvidia-git
pkgdesc = Modular Wayland compositor library (git version with nvidia patches)
- pkgver = 0.16.0.r58.g77d9fc08
+ pkgver = 0.16.0.r623.gbbd53b3b
pkgrel = 1
url = https://gitlab.freedesktop.org/wlroots/wlroots
arch = x86_64
@@ -18,6 +18,8 @@ pkgbase = wlroots-nvidia-git
depends = libudev.so
depends = libxcb
depends = libxkbcommon
+ depends = libdisplay-info
+ depends = libliftoff
depends = opengl-driver
depends = pixman
depends = wayland
@@ -36,6 +38,6 @@ pkgbase = wlroots-nvidia-git
source = wlroots-nvidia-git::git+https://gitlab.freedesktop.org/wlroots/wlroots.git
source = nvidia.patch
sha256sums = SKIP
- sha256sums = ab3aabd4be34c9a4d7fef86be37aa6c971b1106fb2bf7d7651c809338aff298c
+ sha256sums = 96d948ba58376178420bed763820fd274d230a1f7a82873a5b63de4c9a14e15f
pkgname = wlroots-nvidia-git
diff --git a/PKGBUILD b/PKGBUILD
index 3789af9c238f..acb8ae9a26b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Kuan-Yen Chou <kychou2@illinois.edu>
pkgname=wlroots-nvidia-git
-pkgver=0.16.0.r58.g77d9fc08
+pkgver=0.16.0.r623.gbbd53b3b
pkgrel=1
pkgdesc='Modular Wayland compositor library (git version with nvidia patches)'
-depends=(libglvnd libinput libudev.so libxcb libxkbcommon opengl-driver pixman
- wayland xcb-util-errors xcb-util-renderutil xcb-util-wm seatd
- vulkan-icd-loader vulkan-validation-layers xorg-xwayland)
+depends=(libglvnd libinput libudev.so libxcb libxkbcommon libdisplay-info
+ libliftoff opengl-driver pixman wayland xcb-util-errors
+ xcb-util-renderutil xcb-util-wm seatd vulkan-icd-loader
+ vulkan-validation-layers xorg-xwayland)
makedepends=(git glslang meson ninja systemd vulkan-headers wayland-protocols
xorg-xwayland)
optdepends=('xorg-xwayland: Xwayland support')
@@ -18,7 +19,7 @@ conflicts=(wlroots wlroots-git)
source=("$pkgname::git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
"nvidia.patch")
sha256sums=('SKIP'
- 'ab3aabd4be34c9a4d7fef86be37aa6c971b1106fb2bf7d7651c809338aff298c')
+ '96d948ba58376178420bed763820fd274d230a1f7a82873a5b63de4c9a14e15f')
pkgver() {
cd "$srcdir/$pkgname"
diff --git a/nvidia.patch b/nvidia.patch
index 306324bd7c2f..c76fcb673936 100644
--- a/nvidia.patch
+++ b/nvidia.patch
@@ -1,6 +1,6 @@
--- render/gles2/renderer.c
+++ render/gles2/renderer.c
-@@ -165,7 +165,7 @@
+@@ -175,7 +175,7 @@
assert(wlr_egl_is_current(renderer->egl));
push_gles2_debug(renderer);
@@ -11,7 +11,7 @@
--- types/output/render.c
+++ types/output/render.c
-@@ -327,22 +327,7 @@ struct wlr_drm_format *output_pick_format(struct wlr_output *output,
+@@ -240,22 +240,7 @@
}
uint32_t wlr_output_preferred_read_format(struct wlr_output *output) {
@@ -22,7 +22,7 @@
- return DRM_FORMAT_INVALID;
- }
-
-- if (!output_attach_back_buffer(output, &output->pending, NULL)) {
+- if (!wlr_output_attach_render(output, NULL)) {
- return false;
- }
-
@@ -34,4 +34,4 @@
+ return DRM_FORMAT_XRGB8888;
}
- bool output_is_direct_scanout(struct wlr_output *output,
+ struct wlr_render_pass *wlr_output_begin_render_pass(struct wlr_output *output,