summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 23:08:56 -0600
committerBrian Bidulock2015-06-10 23:08:56 -0600
commit623392e4222722e0e9e6e866c36b6404dbeb3c12 (patch)
tree52d243cea86d87160fb3f8ea13815161530613d6
downloadaur-wmsmpmon.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da5b5b1b326e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wmsmpmon
+ pkgdesc = A WindowMaker dockapp that graphs usage for multiple CPU's as well as memory and swap usage.
+ pkgver = 3.1
+ pkgrel = 2
+ url = http://www.ribbrock.org/binabit/wmSMPmon/index.en.htm
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxpm
+ source = http://lancre.ribbrock.org/uploads/TRi/wmSMPmon/wmSMPmon-3.1.tar.gz
+ md5sums = 37e379428c1f42d47b941647627cfabb
+
+pkgname = wmsmpmon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da2fbd2c91b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: John Patton <johnpatton66 at gmail.com>
+
+pkgname=wmsmpmon
+pkgver=3.1
+pkgrel=2
+pkgdesc="A WindowMaker dockapp that graphs usage for multiple CPU's as well as memory and swap usage."
+arch=('i686' 'x86_64')
+url="http://www.ribbrock.org/binabit/wmSMPmon/index.en.htm"
+depends=('libxpm')
+license=('GPL')
+source=("http://lancre.ribbrock.org/uploads/TRi/wmSMPmon/wmSMPmon-3.1.tar.gz")
+md5sums=('37e379428c1f42d47b941647627cfabb')
+
+build() {
+ cd "${srcdir}/wmSMPmon-$pkgver/wmSMPmon"
+ make
+}
+
+package() {
+ cd "${srcdir}/wmSMPmon-$pkgver/wmSMPmon"
+ install -d "${pkgdir}/usr/bin" "${pkgdir}/usr/share/man/man1"
+ make BINDIR="${pkgdir}/usr/bin" MANDIR="${pkgdir}/usr/share/man" INSTALL=/bin/install install
+}