summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Peschany2021-01-22 10:44:31 +0300
committerAlexey Peschany2021-01-22 10:44:31 +0300
commit90efa76988ebedd1bd9d95bf7246a5fb7c15e75c (patch)
tree856de9d716a082465ce578b165c674eecbbb2cf6
downloadaur-woeusb-gui.tar.gz
Make a new woeusb-gui package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6f6eee3fca1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = woeusb-gui
+ pkgdesc = A Linux program to create Windows USB stick installer from a Windows DVD or an image
+ pkgver = 3.3.1
+ pkgrel = 1
+ url = https://github.com/slacka/WoeUSB
+ arch = x86_64
+ license = GPL3
+ depends = dosfstools
+ depends = grub
+ depends = ntfs-3g
+ depends = parted
+ depends = wget
+ depends = wxgtk2
+ conflicts = woeusb
+ source = https://github.com/slacka/WoeUSB/archive/v3.3.1/woeusb-3.3.1.tar.gz
+ b2sums = 1423ecca39018c674b0eea36de732f54cfcdd14b8cc465e6d3c0639192cbd8355436b7a39ba453b19fa6f1c5b1f6938ef12f49710bc2a4af0f2eaed967e03ce7
+
+pkgname = woeusb-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e41baf5d159
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alexey Peschany <nelex111@gmail.com>
+# Contributor: Frederik Schwan <freswa at archlinux dot org>
+# Contributor: Giovanni Harting <539@idlegandalf.com>
+# Contributor: aimileus <me at aimileus dot nl>
+# Contributor: Salvador PardiƱas <darkfm@vera.com.uy>
+
+pkgname=woeusb-gui
+pkgver=3.3.1
+pkgrel=1
+pkgdesc='A Linux program to create Windows USB stick installer from a Windows DVD or an image'
+arch=('x86_64')
+url='https://github.com/slacka/WoeUSB'
+license=('GPL3')
+conflicts=('woeusb')
+depends=('dosfstools' 'grub' 'ntfs-3g' 'parted' 'wget' 'wxgtk2')
+source=("https://github.com/slacka/WoeUSB/archive/v${pkgver}/woeusb-${pkgver}.tar.gz")
+b2sums=('1423ecca39018c674b0eea36de732f54cfcdd14b8cc465e6d3c0639192cbd8355436b7a39ba453b19fa6f1c5b1f6938ef12f49710bc2a4af0f2eaed967e03ce7')
+
+prepare() {
+ cd WoeUSB-${pkgver}
+ find . -type f -print0 | xargs -0 sed -i "s/@@WOEUSB_VERSION@@/${pkgver}/" || die
+ autoreconf --install
+}
+
+build() {
+ cd WoeUSB-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd WoeUSB-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}