summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Keenan2015-06-08 17:58:15 -0700
committerColin Keenan2015-06-08 17:58:15 -0700
commit13c39c5b6d9d06712fd4f85ddeee78ebb0009363 (patch)
tree345e62261e5476f96d6339b475346059dac22732
downloadaur-wordbiz.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e196a15572d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wordbiz
+ pkgdesc = Internet Scrabble Club client
+ pkgver = 1.8.7
+ pkgrel = 2
+ url = http://www.isc.ro
+ arch = x86_64
+ arch = i686
+ license = unknown
+ depends = java-runtime
+ source = http://www.isc.ro/linux/WordBiz18linux.zip
+ source = https://raw.githubusercontent.com/colinkeenan/archpkg-wordbiz/v1.8.7/wordbiz
+ source = https://raw.githubusercontent.com/colinkeenan/archpkg-wordbiz/v1.8.7/wordbiz.desktop
+ md5sums = dd3c078f758196606e21430ac248b8d5
+ md5sums = 21544a9059d8d55dbdb24511fac98644
+ md5sums = 5b868fccffb9d25671bdd4d0175e9ea9
+
+pkgname = wordbiz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..631148167c4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: colinkeenan at gmail dot com
+pkgname=wordbiz
+pkgver=1.8.7
+pkgrel=2
+pkgdesc="Internet Scrabble Club client"
+arch=("x86_64" "i686")
+url="http://www.isc.ro"
+license=("unknown")
+depends=("java-runtime")
+source=("http://www.isc.ro/linux/WordBiz18linux.zip"
+ "https://raw.githubusercontent.com/colinkeenan/archpkg-${pkgname}/v${pkgver}/wordbiz"
+ "https://raw.githubusercontent.com/colinkeenan/archpkg-${pkgname}/v${pkgver}/wordbiz.desktop")
+md5sums=('dd3c078f758196606e21430ac248b8d5'
+ '21544a9059d8d55dbdb24511fac98644'
+ '5b868fccffb9d25671bdd4d0175e9ea9')
+
+package() {
+ for file in $(find WordBiz -type f); do
+ install -m 644 -D ${file} $pkgdir/opt/WordBiz/${file#WordBiz/}
+ done
+ install -m755 -D wordbiz $pkgdir/usr/bin/wordbiz
+ install -m644 -D wordbiz.desktop $pkgdir/usr/share/applications/wordbiz.desktop
+}