summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-03-16 01:01:51 +0000
committerxiota2024-03-16 01:01:51 +0000
commit666ee6dac53b7c4f6dc9225718a2663d5ab813b0 (patch)
treeb7ed69adce4005df8b7c84650063ffeb56b2c9ad
downloadaur-wrapland.tar.gz
0.600.0
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae07118f82d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wrapland
+ pkgdesc = Qt/C++ library wrapping libwayland (kwinft)
+ pkgver = 0.600.0
+ pkgrel = 1
+ url = https://github.com/winft/wrapland
+ arch = x86_64
+ arch = aarch64
+ license = LGPL-2.1-only
+ makedepends = doxygen
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = microsoft-gsl
+ makedepends = ninja
+ makedepends = wayland-protocols
+ depends = libglvnd
+ depends = qt6-base
+ depends = wayland
+ source = wrapland-0.600.0.tar.gz::https://github.com/winft/wrapland/archive/refs/tags/v0.600.0.tar.gz
+ sha256sums = 2a07b69b6489c2c83f75c346a3aeecf28cc79a7f5040ace467022f554290287e
+
+pkgname = wrapland
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eec9fbc9cb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer:
+
+_pkgname="wrapland"
+pkgname="$_pkgname"
+pkgver=0.600.0
+pkgrel=1
+pkgdesc='Qt/C++ library wrapping libwayland (kwinft)'
+url="https://github.com/winft/wrapland"
+license=('LGPL-2.1-only')
+arch=('x86_64' 'aarch64')
+
+depends=(
+ libglvnd
+ qt6-base
+ wayland
+)
+makedepends=(
+ doxygen
+ extra-cmake-modules
+ git
+ microsoft-gsl
+ ninja
+ wayland-protocols
+)
+
+_pkgsrc="$_pkgname-$pkgver"
+_pkgext="tar.gz"
+source=(
+ "$_pkgsrc.$_pkgext"::"$url/archive/refs/tags/v$pkgver.$_pkgext"
+)
+sha256sums=(
+ '2a07b69b6489c2c83f75c346a3aeecf28cc79a7f5040ace467022f554290287e'
+)
+
+build() {
+ local _cmake_options=(
+ -B build
+ -S "$_pkgsrc"
+ -G Ninja
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ -DBUILD_TESTING=OFF
+ -Wno-dev
+ )
+
+ cmake "${_cmake_options[@]}"
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}