summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorloh.tar2024-03-28 17:10:09 +0100
committerloh.tar2024-03-28 17:10:09 +0100
commitf9e4d96af53674f518d34b961590809b012be89d (patch)
tree94a27d16fb4b367923c61fc420c3197c80bdfd6a
parentc9b3c09d1509cb00e55b152399b20f3395cf3ea2 (diff)
downloadaur-wrt2pdf.tar.gz
Update to new release v0.6.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85a2b66161c6..59216e7ce812 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = wrt2pdf
pkgdesc = Create a PDF out of a plain text file
- pkgver = 0.6
+ pkgver = 0.6.1
pkgrel = 1
url = https://github.com/loh-tar/wrt2pdf
arch = x86_64
- license = GPL2
- depends = qt5-base
- source = wrt2pdf-0.6.tar.gz::https://github.com/loh-tar/wrt2pdf/archive/v0.6.tar.gz
- sha256sums = f204671e76bac20c4e039d4bec8bd7a52bdc69c2b62ce68d48ebadd29d8f8a87
+ license = GPL-2.0-or-later
+ depends = qt6-base
+ depends = gcc-libs
+ source = wrt2pdf-0.6.1.tar.gz::https://github.com/loh-tar/wrt2pdf/archive/v0.6.1.tar.gz
+ sha256sums = cb1e01428ef49ecb7d1ca517418a11ecf98a0f7afecf9014c91c5b2158cf5fab
pkgname = wrt2pdf
diff --git a/PKGBUILD b/PKGBUILD
index 0d16466ece27..e22d70941594 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: loh.tar <loh.tar at googlemail dot com>
pkgname="wrt2pdf"
-pkgver="0.6"
+pkgver="0.6.1"
pkgrel="1"
pkgdesc="Create a PDF out of a plain text file"
arch=("x86_64")
url="https://github.com/loh-tar/$pkgname"
-license=("GPL2")
-depends=("qt5-base")
+license=("GPL-2.0-or-later")
+depends=("qt6-base" "gcc-libs")
source=("$pkgname-$pkgver.tar.gz::https://github.com/loh-tar/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('f204671e76bac20c4e039d4bec8bd7a52bdc69c2b62ce68d48ebadd29d8f8a87')
+sha256sums=('cb1e01428ef49ecb7d1ca517418a11ecf98a0f7afecf9014c91c5b2158cf5fab')
build() {
cd "$pkgname-$pkgver"
- mkdir build
+ mkdir -p build
cmake -DCMAKE_BUILD_TYPE=Release -S "./" -B "build"
cd build
make