summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeal Miller2020-03-21 22:14:34 -0500
committerNeal Miller2020-03-21 22:14:34 -0500
commit66e23dcfac27b00df3ace0ebb485084dd0f9f9fc (patch)
treecc624516d62597a2c0c7150045976b9e7542073c
parentf029a297b0832d95c791a7df0d5bae5544781cba (diff)
downloadaur-66e23dcfac27b00df3ace0ebb485084dd0f9f9fc.tar.gz
Add patch for QT 5.14, issue with Qhash, temporary. See https://groups.io/g/WSJTX/topic/71254545\?p\=Created,,,20,2,0,0::recentpostdate%2Fsticky,,,20,2,20,71254545
Signed-off-by: Neal Miller <meltdown03@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--wsjtx.patch19
3 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a09f8e5a371d..478517b00f28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wsjtx-git
pkgdesc = Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)
- pkgver = r5460.24fcd17a
- pkgrel = 2
+ pkgver = r5497.0068f9bc
+ pkgrel = 1
url = http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
arch = i686
arch = x86_64
@@ -24,7 +24,7 @@ pkgbase = wsjtx-git
source = git+https://git.code.sf.net/p/wsjt/wsjtx/#tag=master
source = wsjtx.patch
md5sums = SKIP
- md5sums = c344fe634d4a9d1b15300970f0fa019b
+ md5sums = 337acf49878ae0f9980c2c9c9a0b7d7b
pkgname = wsjtx-git
diff --git a/PKGBUILD b/PKGBUILD
index 21eb1cbd45b0..e872286e2f1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Thomas Gatzweiler <thomas.gatzweiler@gmail.com> wsjtx-svn maintainer
pkgname=wsjtx-git
-pkgver=r5460.24fcd17a
-pkgrel=2
+pkgver=r5497.0068f9bc
+pkgrel=1
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)'
# change _wsjtx_tag to other versions such as wsjtx-2.1.0-rc5
_wsjtx_tag=master
@@ -17,7 +17,7 @@ conflicts=('wsjtx')
source=("git+https://git.code.sf.net/p/wsjt/wsjtx/#tag=$_wsjtx_tag"
"wsjtx.patch")
md5sums=('SKIP'
- 'c344fe634d4a9d1b15300970f0fa019b')
+ '337acf49878ae0f9980c2c9c9a0b7d7b')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -42,5 +42,4 @@ package() {
cd "$srcdir/${pkgname%-git}/build"
make DESTDIR="$pkgdir/" install
cd "$srcdir/${pkgname%-git}"
- patch -R CMakeLists.txt wsjtx.patch
}
diff --git a/wsjtx.patch b/wsjtx.patch
index c11041ef1d22..1d19a1bca12b 100644
--- a/wsjtx.patch
+++ b/wsjtx.patch
@@ -43,3 +43,22 @@
install (FILES
README
COPYING
+
+--- a/qt_helpers.hpp 2019-11-26 09:22:32.000000000 -0500
++++ b/qt_helpers.hpp 2020-02-03 11:30:07.488214336 -0500
+@@ -83,6 +83,7 @@
+ // std::hash<> specialization for QString based on the dbj2
+ // algorithm <http://www.cse.yorku.ca/~oz/hash.html> because qHash()
+ // is poor on 64-bit platforms due to being a 32-bit hash value
++ #if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
+ template<>
+ struct hash<QString>
+ {
+@@ -96,6 +97,7 @@
+ return hash;
+ }
+ };
++#endif
+ }
+
+ // Register some useful Qt types with QMetaType