summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Wu2019-03-19 09:46:34 +0800
committerPatrick Wu2019-03-19 09:46:34 +0800
commit0bfcffc2bcf7583a6a1f871d2e44a3d20fa9a61d (patch)
tree011590fe859bdcd8a9c67c397454c31d59ee53a9
downloadaur-wslu-dev-git.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2eabe8d013c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wslu-dev-git
+ pkgdesc = A collection of utilities for Windows 10 Linux Subsystems
+ pkgver = v20190319
+ pkgrel = 0
+ url = https://github.com/wslutilities/wslu
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ makedepends = gzip
+ depends = bc
+ depends = imagemagick
+ depends = bash-completion
+ source = git+https://github.com/wslutilities/wslu.git#branch=develop
+ sha256sums = SKIP
+
+pkgname = wslu-dev-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f36373179364
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Patrick Wu <wotingwu@live.com>
+
+pkgname=wslu-dev-git
+pkgver=v20190319
+pkgrel=0
+pkgdesc="A collection of utilities for Windows 10 Linux Subsystems"
+arch=('any')
+url='https://github.com/wslutilities/wslu'
+license=('GPL3')
+depends=('bc' 'imagemagick' 'bash-completion')
+makedepends=('git' 'make' 'gzip')
+source=("git+https://github.com/wslutilities/wslu.git#branch=develop")
+sha256sums=('SKIP')
+
+build() {
+ cd wslu
+ make
+}
+
+package() {
+ cd wslu
+
+ install -Dm 755 out/* -t "${pkgdir}"/usr/bin/
+ install -Dm 555 docs/* -t "${pkgdir}"/usr/share/man/man1/
+ install -Dm 555 src/etc/* -t "${pkgdir}"/usr/share/wslu/
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/wslu/
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file