summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHunter Peavey2020-02-12 16:25:03 -0800
committerHunter Peavey2020-02-12 16:25:03 -0800
commit975b57bf9934c6670d3e0af1d07c31181246d260 (patch)
tree09d7eb4a130e9c7febd031d69a4095cb2f250173
parentcc2342bce35c21ba7b4db961ea754a94a1c2d57e (diff)
downloadaur-975b57bf9934c6670d3e0af1d07c31181246d260.tar.gz
Update AUR for 1.3.0 release
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG6
-rw-r--r--PKGBUILD4
3 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 735523aaaf22..e3760101de30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wtwitch
pkgdesc = Terminal user interface for Twitch
- pkgver = 1.2.0
+ pkgver = 1.3.0
pkgrel = 1
url = https://git.sr.ht/~krathalan/wtwitch
changelog = CHANGELOG
@@ -12,11 +12,11 @@ pkgbase = wtwitch
depends = wget
optdepends = mpv: for watching streams
optdepends = vlc: for watching streams
- source = https://git.sr.ht/~krathalan/wtwitch/archive/1.2.0.tar.gz
- source = https://git.sr.ht/~krathalan/wtwitch/blob/master/signatures/1.2.0.tar.gz.sig
+ source = https://git.sr.ht/~krathalan/wtwitch/archive/1.3.0.tar.gz
+ source = https://git.sr.ht/~krathalan/wtwitch/blob/master/signatures/1.3.0.tar.gz.sig
validpgpkeys = 02AAA23ABDF1D538BD889D251AADE5E728FFC667
- sha256sums = de1d2a5732c72d50852e38c5acb9ae8f04312f2404ce8dffedf363f1eb4acba8
- sha256sums = b486d0657ba21288ef2c284f8421f01914146aa1252f699dd3f9ace11cdadd15
+ sha256sums = d5582256adc283f5dc1c338adfbf79816508fbb247c5129b0a4790cd4cc6f6c4
+ sha256sums = 1b25ad5d9fd666124f399f7bbffaf9a5c32aaefc05d2661bab66eddcf8189e55
pkgname = wtwitch
diff --git a/CHANGELOG b/CHANGELOG
index 8868478f0989..4aae209d6086 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,9 @@
+1.3.0 (February 12, 2020)
+ Option -t,--top-games changed to -t,--top and now lists top games *and* top streams
+ Started caching game IDs to again dramatically reduce strain on Twitch API
+ Added debugging information to more code
+ Reduced code duplication
+
1.2.0 (February 8, 2020)
Dramatically reduce the number of Twitch API calls with the -c,--check option
The above change should at least alleviate https://todo.sr.ht/~krathalan/wtwitch/2
diff --git a/PKGBUILD b/PKGBUILD
index 01069484d789..d12d381c4a06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# General package information
pkgname=wtwitch
-pkgver=1.2.0
+pkgver=1.3.0
pkgrel=1
pkgdesc="Terminal user interface for Twitch"
url="https://git.sr.ht/~krathalan/wtwitch"
@@ -20,7 +20,7 @@ optdepends=('mpv: for watching streams'
_packagesig="${url}/blob/master/signatures/${pkgver}.tar.gz.sig"
source=("${url}/archive/${pkgver}.tar.gz" "${_packagesig}")
validpgpkeys=("02AAA23ABDF1D538BD889D251AADE5E728FFC667")
-sha256sums=("de1d2a5732c72d50852e38c5acb9ae8f04312f2404ce8dffedf363f1eb4acba8" "b486d0657ba21288ef2c284f8421f01914146aa1252f699dd3f9ace11cdadd15")
+sha256sums=("d5582256adc283f5dc1c338adfbf79816508fbb247c5129b0a4790cd4cc6f6c4" "1b25ad5d9fd666124f399f7bbffaf9a5c32aaefc05d2661bab66eddcf8189e55")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"