summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2017-12-08 11:52:44 +0100
committerfelics@felics-tablet2017-12-08 11:52:44 +0100
commite99cc5c4e2059a1dba4a6d57403837d58684a268 (patch)
tree86751d5d191f12c4d77e24a61c3a5541a73ff060
parent7955d83f3c17901081eb55e7b1e5c55ad02c49c2 (diff)
downloadaur-e99cc5c4e2059a1dba4a6d57403837d58684a268.tar.gz
Updated initscripts to killal-9 if stopping fails.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--initscript_openrc7
-rw-r--r--initscript_sysvinit2
4 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6250abf0e807..6fbe09ed81e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wwwoffle-svn
pkgdesc = Simple caching proxy server with special features (request, recursive fetch, subscription, modify HTML, ...) for use with dial-up internet links. Includes startup scripts for OpenRC, System V init, systemd.
pkgver = 2.9j+svn2229
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = http://www.gedanken.org.uk/software/wwwoffle/
install = wwwoffle.install
@@ -35,9 +35,9 @@ pkgbase = wwwoffle-svn
source = wwwoffle.install
sha256sums = SKIP
sha256sums = 5491ffc23ae113db4b46167883594b5bcb6f1bbd0ce11432bc45047efbd635d2
- sha256sums = 5f6d81094d8031172733500597e3d608632da3241cfadff8c166723af97d996a
+ sha256sums = 5c1a2b853956780901b2aad49f9be3bc2060da88dd22ee38b235c24da8bda83f
sha256sums = 03bebce87a0da1b383666ab7a95b9810e15f2a024c0954f09c959d342c5d9c87
- sha256sums = c1c8f30bc0fe928d887212678c9857a526ea7767964192b13d994e81314ba002
+ sha256sums = 1a2ca91f9726d7a8e1c157db044d2af60a5b4691cb2ae489539b7813aef503f6
sha256sums = 106f4ce3de6d6ea020e8dcd8a4fd4f78ed2ae855e8a953a8783134e4d2cfba12
pkgname = wwwoffle-svn
diff --git a/PKGBUILD b/PKGBUILD
index d4b5953148c4..c395b257c1e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname="${_pkgname}-svn"
# _pkgver=2.9i
epoch=1
pkgver=2.9j+svn2229
-pkgrel=2
+pkgrel=3
pkgdesc="Simple caching proxy server with special features (request, recursive fetch, subscription, modify HTML, ...) for use with dial-up internet links. Includes startup scripts for OpenRC, System V init, systemd."
arch=('i686' 'x86_64' 'arm' 'arm64')
url="http://www.gedanken.org.uk/software/wwwoffle/"
@@ -57,9 +57,9 @@ sha256sums=(
# 'e6341a4ec2631dc22fd5209c7e5ffe628a5832ad191d444c56aebc3837eed2ae' # Main source, release
'SKIP' # Main source, SVN
'5491ffc23ae113db4b46167883594b5bcb6f1bbd0ce11432bc45047efbd635d2' # conf_d_wwwoffle
- '5f6d81094d8031172733500597e3d608632da3241cfadff8c166723af97d996a' # initscript_openrc
+ '5c1a2b853956780901b2aad49f9be3bc2060da88dd22ee38b235c24da8bda83f' # initscript_openrc
'03bebce87a0da1b383666ab7a95b9810e15f2a024c0954f09c959d342c5d9c87' # initscript_systemd
- 'c1c8f30bc0fe928d887212678c9857a526ea7767964192b13d994e81314ba002' # initscript_sysvinit
+ '1a2ca91f9726d7a8e1c157db044d2af60a5b4691cb2ae489539b7813aef503f6' # initscript_sysvinit
'106f4ce3de6d6ea020e8dcd8a4fd4f78ed2ae855e8a953a8783134e4d2cfba12' # ${install}
)
diff --git a/initscript_openrc b/initscript_openrc
index 666d6fe88fe7..1c5eaeb6dc2e 100644
--- a/initscript_openrc
+++ b/initscript_openrc
@@ -31,7 +31,12 @@ start() {
stop() {
ebegin "Stopping $(basename "${_DAEMON}")"
- start-stop-daemon --stop --exec "${_DAEMON}"
+ start-stop-daemon --stop --exec "${_DAEMON}" || {
+ _pids="$(pidof "${_DAEMON}")"
+ for _pid in ${_pids}; do
+ kill -9 "${_pid}" &> /dev/null
+ done
+ }
eend "$?"
}
diff --git a/initscript_sysvinit b/initscript_sysvinit
index 3c7f042b76ec..6f2c124b46de 100644
--- a/initscript_sysvinit
+++ b/initscript_sysvinit
@@ -42,7 +42,7 @@ case "$1" in
;;
stop)
stat_busy "Stopping ${_pretty_name}"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
+ [ ! -z "$PID" ] && kill $PID &> /dev/null || kill -9 $PID &>/dev/null
if [ $? -gt 0 ]; then
stat_fail
else