summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCosku Bas2018-03-07 19:51:25 +0300
committerCosku Bas2018-03-07 19:51:25 +0300
commitea6b75eb421ef33e7bd02e29ab0d4f50f35b831e (patch)
treeeb6cf58d62b4a3d1acbda84f1a743b8b8ef22167
parent3e4d419c0142ef0f242fdcb161e18d189d6ac755 (diff)
downloadaur-wxgtk-trenchbroom.tar.gz
Update to wx-3.1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--wxGLContext_ctor_x11Direct20160316.patch41
3 files changed, 9 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1425ce1bd253..78cf6fb50305 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wxgtk-trenchbroom
pkgdesc = GTK+2 implementation of wxWidgets API for GUI with TrenchBroom patches.
- pkgver = 3.1.0
- pkgrel = 5
+ pkgver = 3.1.1
+ pkgrel = 6
url = http://wxwidgets.org
arch = i686
arch = x86_64
@@ -18,14 +18,10 @@ pkgbase = wxgtk-trenchbroom
depends = libxxf86vm
depends = libnotify
options = !emptydirs
- source = https://github.com/wxWidgets/wxWidgets/releases/download/v3.1.0/wxWidgets-3.1.0.tar.bz2
+ source = https://github.com/wxWidgets/wxWidgets/releases/download/v3.1.1/wxWidgets-3.1.1.tar.bz2
source = make-abicheck-non-fatal.patch
- source = wxGLContext_ctor_x11Direct20160316.patch
- source = wxgtk-filezilla-assert.patch::https://github.com/wxWidgets/wxWidgets/commit/ce1dce11.patch
- sha1sums = 2170839cfa9d9322e8ee8368b21a15a2497b4f11
+ sha1sums = f999c3cf1887c0a60e519214c14b15cb9bb5ea6e
sha1sums = dfe38650c655395b90bf082b5734c4093508bfa3
- sha1sums = 6941a40b202f29f4ae36ff332fb8f1ff95244737
- sha1sums = 1da8af91ef6c590da9c43dd115f52d605730f16a
pkgname = wxgtk-trenchbroom
diff --git a/PKGBUILD b/PKGBUILD
index dc2eac428eec..240e6722d4dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Cosku Bas <cosku.bas@gmail.com>
pkgname=wxgtk-trenchbroom
-pkgver=3.1.0
-pkgrel=5
+pkgver=3.1.1
+pkgrel=6
pkgdesc="GTK+2 implementation of wxWidgets API for GUI with TrenchBroom patches."
arch=('i686' 'x86_64')
url="http://wxwidgets.org"
@@ -14,13 +14,10 @@ makedepends=('gst-plugins-base' 'gconf' 'glu' 'webkit2gtk' 'libnotify' 'gtk2')
options=('!emptydirs')
source=(https://github.com/wxWidgets/wxWidgets/releases/download/v${pkgver}/wxWidgets-${pkgver}.tar.bz2
- make-abicheck-non-fatal.patch
- wxGLContext_ctor_x11Direct20160316.patch
- wxgtk-filezilla-assert.patch::"https://github.com/wxWidgets/wxWidgets/commit/ce1dce11.patch")
-sha1sums=('2170839cfa9d9322e8ee8368b21a15a2497b4f11'
+ make-abicheck-non-fatal.patch)
+sha1sums=('f999c3cf1887c0a60e519214c14b15cb9bb5ea6e'
'dfe38650c655395b90bf082b5734c4093508bfa3'
- '6941a40b202f29f4ae36ff332fb8f1ff95244737'
- '1da8af91ef6c590da9c43dd115f52d605730f16a')
+ )
prepare() {
cd wxWidgets-${pkgver}
@@ -28,12 +25,6 @@ prepare() {
# C++ ABI check is too strict and breaks with GCC 5.1
# https://bugzilla.redhat.com/show_bug.cgi?id=1200611
patch -Np1 -i ../make-abicheck-non-fatal.patch
-
- # Apply TrenchBroom patch
- patch -p0 < ../wxGLContext_ctor_x11Direct20160316.patch
-
- # fix assert in FileZilla
- patch -p1 -i ../wxgtk-filezilla-assert.patch
}
build() {
diff --git a/wxGLContext_ctor_x11Direct20160316.patch b/wxGLContext_ctor_x11Direct20160316.patch
deleted file mode 100644
index 83f6283c383b..000000000000
--- a/wxGLContext_ctor_x11Direct20160316.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git src/unix/glx11.cpp src/unix/glx11.cpp
-index 6534601..90bfc93 100644
---- src/unix/glx11.cpp
-+++ src/unix/glx11.cpp
-@@ -486,18 +486,17 @@ wxGLContext::wxGLContext(wxGLCanvas *win,
-
- // We need to create a temporary context to get the
- // glXCreateContextAttribsARB function
-- GLXContext tempContext = glXCreateContext(dpy, vi, NULL,
-- win->GetGLCTXAttrs().x11Direct );
-+ GLXContext tempContext = glXCreateContext(dpy, vi, NULL, x11Direct);
- wxCHECK_RET(tempContext, "glXCreateContext failed" );
-
-- PFNGLXCREATECONTEXTATTRIBSARBPROC glXCreateContextAttribsARB
-+ PFNGLXCREATECONTEXTATTRIBSARBPROC wx_glXCreateContextAttribsARB
- = (PFNGLXCREATECONTEXTATTRIBSARBPROC)
- glXGetProcAddress((GLubyte *)"glXCreateContextAttribsARB");
-
- glXDestroyContext( dpy, tempContext );
-
- // The preferred way is using glXCreateContextAttribsARB, even for old context
-- if ( !glXCreateContextAttribsARB && needsARB ) // OpenGL 3 context creation
-+ if ( !wx_glXCreateContextAttribsARB && needsARB ) // OpenGL 3 context creation
- {
- wxLogMessage(_("OpenGL 3.0 or later is not supported by the OpenGL driver."));
- return;
-@@ -508,12 +507,12 @@ wxGLContext::wxGLContext(wxGLCanvas *win,
- g_ctxErrorOccurred = false;
- int (*oldHandler)(Display*, XErrorEvent*) = XSetErrorHandler(&CTXErrorHandler);
-
-- if ( glXCreateContextAttribsARB )
-+ if ( wx_glXCreateContextAttribsARB )
- {
- GLXFBConfig *fbc = win->GetGLXFBConfig();
- wxCHECK_RET( fbc, "Invalid GLXFBConfig for OpenGL" );
-
-- m_glContext = glXCreateContextAttribsARB( dpy, fbc[0],
-+ m_glContext = wx_glXCreateContextAttribsARB( dpy, fbc[0],
- other ? other->m_glContext : None,
- x11Direct, contextAttribs );
- }