summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Fleischer2017-03-26 15:11:20 +0200
committerLukas Fleischer2017-03-26 15:11:20 +0200
commit49526f1edf19e86518c83eba4820981957c8845f (patch)
tree213130313992e058777335814bf3c40a9ab0d541
downloadaur-49526f1edf19e86518c83eba4820981957c8845f.tar.gz
Initial import
Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f9ad10b91bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wyrd
+ pkgdesc = A text-based front-end to Remind.
+ pkgver = 1.4.6
+ pkgrel = 3
+ url = http://pessimization.com/software/wyrd/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = ocaml
+ makedepends = camlp4
+ depends = remind
+ depends = ncurses
+ source = http://pessimization.com/software/wyrd/wyrd-1.4.6.tar.gz
+ md5sums = 2fc561482fdac4daac0cb6735d934ebe
+
+pkgname = wyrd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a2fbb806fb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Jeff Mickey <jeff@archlinux.org>
+# Contributor: Daniel J Griffiths <griffithsdj@archlinux.us>
+
+pkgname=wyrd
+pkgver=1.4.6
+pkgrel=3
+pkgdesc='A text-based front-end to Remind.'
+arch=('i686' 'x86_64')
+url='http://pessimization.com/software/wyrd/'
+license=('GPL')
+depends=('remind' 'ncurses')
+makedepends=('ocaml' 'camlp4')
+source=("http://pessimization.com/software/wyrd/${pkgname}-${pkgver}.tar.gz")
+md5sums=('2fc561482fdac4daac0cb6735d934ebe')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-utf8
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}