summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-03-29 18:36:37 -0600
committerMark Wagie2020-03-29 18:36:37 -0600
commitbc8b1ac6cd19b0e6989e24d656ffa90a57f1d3c5 (patch)
tree5dd0533a5ce44671cec0ad72d339a2957626f578
parent5741a4e1e3387801f01fba3c5798467930c7c2fe (diff)
downloadaur-bc8b1ac6cd19b0e6989e24d656ffa90a57f1d3c5.tar.gz
Python 3 migration
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD52
2 files changed, 25 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e21ec50f6548..656fd153a81d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = x-tile-git
- pkgdesc = X-tile is an application that allows you to select a number of windows and tile them in different ways. It works on any X desktop (gnome, kde, xfce, lxde…).
- pkgver = 2.6.r3.gbc2ffd3
+ pkgdesc = Allows you to select a number of windows and tile them in different ways
+ pkgver = 3.0.r0.g435eef2
pkgrel = 1
- url = http://www.giuspen.com/x-tile
+ url = https://www.giuspen.com/x-tile
arch = any
license = GPL2
makedepends = git
- makedepends = python2-distutils-extra
- depends = gconf
- depends = libappindicator-gtk3
- depends = python2-gobject
+ depends = gtk3
+ depends = python-gobject
+ optdepends = libappindicator-gtk3: Tray icon support
provides = x-tile
conflicts = x-tile
- source = x-tile::git+https://github.com/giuspen/x-tile.git
+ source = git+https://github.com/giuspen/x-tile.git
sha256sums = SKIP
pkgname = x-tile-git
diff --git a/PKGBUILD b/PKGBUILD
index c116615b0420..1618e75a4662 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,27 @@
-
-_pkgname=x-tile
-pkgname=${_pkgname}-git
-pkgver=2.6.r3.gbc2ffd3
+# Maintainer: Fanch
+# Co-Maintainer: Mark Wagie <mark.wagie at tutanota dot com>
+pkgname=x-tile-git
+pkgver=3.0.r0.g435eef2
pkgrel=1
-pkgdesc="X-tile is an application that allows you to select a number of windows and tile them in different ways. It works on any X desktop (gnome, kde, xfce, lxde…)."
-arch=(any)
-url=http://www.giuspen.com/$_pkgname
-license=(GPL2)
-
-#depends=('hicolor-icon-theme' 'pygtk' 'python2-libappindicator')
-depends=('gconf' 'libappindicator-gtk3' 'python2-gobject')
-makedepends=('git' 'python2-distutils-extra')
-
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-
-source=("${_pkgname}::git+https://github.com/giuspen/${_pkgname}.git")
+pkgdesc="Allows you to select a number of windows and tile them in different ways"
+arch=('any')
+url="https://www.giuspen.com/x-tile"
+license=('GPL2')
+depends=('gtk3' 'python-gobject')
+makedepends=('git')
+optdepends=('libappindicator-gtk3: Tray icon support') # Tray icon MIA ?
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/giuspen/${pkgname%-git}.git")
sha256sums=('SKIP')
-prepare() {
- cd "${srcdir}/${_pkgname}"
- sed -i 's%#!/usr/bin/env python%#!/usr/bin/env python2%g' setup.py
-}
-
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd "${srcdir}/${_pkgname}"
-
- echo "python script, so nothing to build :) "
-}
-
package() {
- cd "${srcdir}/${_pkgname}"
-
- python2 setup.py install --prefix=/usr --root="${pkgdir}"
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --prefix=/usr --exec-prefix=/usr -f \
+ --root="$pkgdir/" --optimize=1
}
-
-