summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2018-08-04 09:01:22 -0400
committerCebtenzzre2018-08-04 09:15:38 -0400
commit20ec8deed3dbe79bcc60f6ade92f66fb97c43491 (patch)
tree21338a09aeb7d250858c05c0a250b669b89bc08c
downloadaur-x11clone.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ee79ae19cbd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = x11clone
+ pkgdesc = View and interact with another X11 server. Can be used in conjunction with ThinLinc.
+ pkgver = 1.8.80.3
+ pkgrel = 1
+ url = https://github.com/x11clone/x11clone
+ arch = x86_64
+ license = GPL2
+ depends = zlib
+ depends = hicolor-icon-theme
+ depends = libxfixes
+ source = https://github.com/x11clone/x11clone/releases/download/v1.8.80.3/x11clone-Linux-x86_64-1.8.80.3.tar.gz
+ sha256sums = 261c5454f0a17fd4e04736e55175c5956a87ccf5b19e8135ceb529247cd640e7
+
+pkgname = x11clone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c41c7cbef61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
+
+pkgname=x11clone
+pkgver=1.8.80.3
+pkgrel=1
+pkgdesc='View and interact with another X11 server. Can be used in conjunction with ThinLinc.'
+arch=(x86_64)
+url='https://github.com/x11clone/x11clone'
+license=(GPL2)
+
+depends=(zlib hicolor-icon-theme libxfixes)
+
+source=("https://github.com/x11clone/x11clone/releases/download/v$pkgver/x11clone-Linux-$CARCH-$pkgver.tar.gz")
+sha256sums=(261c5454f0a17fd4e04736e55175c5956a87ccf5b19e8135ceb529247cd640e7)
+
+build() {
+ # Do not install in /usr/local
+ if [ -d usr/local ]; then
+ cp -R usr/local/* usr
+ rm -rf usr/local
+ fi
+
+ # Fix empty dirs
+ rmdir usr/man{/man1,} || true
+}
+
+package() {
+ cp -R "$srcdir/usr" "$pkgdir"
+}