summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072024-03-18 01:09:00 +0100
committersL1pKn072024-03-18 01:09:00 +0100
commit112b1801d070bad8389caf6c2317245aa297ccb1 (patch)
treee5ad42533bd49193559d70463275c1f16d1d0f1b
parente72060ab3f6ada9b39efabb95666501bef78bc2b (diff)
downloadaur-x262-git.tar.gz
bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 366d21b57e7f..05e96d670d61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = x262-git
pkgdesc = x264 with MPEG-2 video support (GIT version)
- pkgver = 0.142.2633.bb887aa
- pkgrel = 2
+ pkgver = 0.142.2631+93.9679f15
+ pkgrel = 1
url = https://www.videolan.org/developers/x262.html
arch = x86_64
license = GPL
@@ -22,9 +22,9 @@ pkgbase = x262-git
conflicts = x262
options = debug
options = !lto
- source = git+https://git.videolan.org/git/x262.git
- source = git+https://github.com/ffmpeg/ffmpeg.git#tag=n2.7.7
- source = git+https://github.com/FFMS/ffms2.git#tag=2.20
+ source = git+https://github.com/kierank/x262.git#branch=obe
+ source = git+https://github.com/ffmpeg/ffmpeg.git#tag=n2.8.22
+ source = git+https://github.com/FFMS/ffms2.git#tag=2.21
source = mathops_fix.patch
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b14d289344e4..9e4b05b8fb8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: DrZaius <lou[at]fakeoutdoorsman.com>
pkgname=x262-git
-pkgver=0.142.2633.bb887aa
-pkgrel=2
+pkgver=0.142.2631+93.9679f15
+pkgrel=1
pkgdesc="x264 with MPEG-2 video support (GIT version)"
arch=('x86_64')
license=('GPL')
@@ -23,9 +23,9 @@ makedepends=(
)
url="https://www.videolan.org/developers/x262.html"
source=(
- 'git+https://git.videolan.org/git/x262.git'
- 'git+https://github.com/ffmpeg/ffmpeg.git#tag=n2.7.7'
- 'git+https://github.com/FFMS/ffms2.git#tag=2.20'
+ 'git+https://github.com/kierank/x262.git#branch=obe'
+ 'git+https://github.com/ffmpeg/ffmpeg.git#tag=n2.8.22'
+ 'git+https://github.com/FFMS/ffms2.git#tag=2.21'
'mathops_fix.patch'
)
provides=('x262')
@@ -50,13 +50,15 @@ prepare() {
}
build() {
+
msg2 "Build FFmpeg"
cd "${srcdir}/build-ffmpeg"
../ffmpeg/configure \
--prefix="${srcdir}/fakeroot" \
--disable-{network,{encod,mux}ers,hwaccels,{in,out}devs,debug,doc,vdpau,vaapi,programs} \
--enable-pic \
- --enable-gpl
+ --enable-gpl \
+ --disable-decoder=opus
make install-libs install-headers
@@ -65,7 +67,11 @@ build() {
msg2 "Build FFmpegsource"
cd "${srcdir}/build-ffms2"
- (cd "${srcdir}/ffms2"; mkdir -p src/config; autoreconf -vfi)
+ (
+ cd "${srcdir}/ffms2"
+ mkdir -p src/config
+ autoreconf -vfi
+ )
../ffms2/configure \
--prefix="${srcdir}/fakeroot" \
--enable-shared=no