summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYamashita Ren2015-09-09 22:20:42 +0200
committerYamashita Ren2015-09-09 22:20:42 +0200
commit9c2f0d3d647a14edb02115d48310dd42cbcc96e8 (patch)
tree04c07b3d635487cf074f2bb4f7f5e56987f986c1
downloadaur-x264-ymod-git.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afd7c8c39063
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = x264-ymod-git
+ pkgdesc = H.264 video encoder and library, with custom patchset.
+ pkgver = 148.r2610.09bc200
+ pkgrel = 2
+ url = https://github.com/YamashitaRen/x264_YMod
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = yasm
+ depends = glibc
+ provides = x264
+ conflicts = x264
+ source = git://github.com/YamashitaRen/x264_YMod.git
+ md5sums = SKIP
+
+pkgname = x264-ymod-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae9b6c90d27e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Yamashita Ren
+# Contributor: PelPix <kylebloss[at]pelpix[dot]info>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman.com>
+# Contributor: zhuqin <zhuqin83[at]gmail>
+# Contributor: pressh <pressh[at]gmail>
+
+pkgname=x264-ymod-git
+_gitname="x264_YMod"
+pkgver=148.r2610.09bc200
+pkgrel=2
+pkgdesc="H.264 video encoder and library, with custom patchset."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc')
+makedepends=('git' 'yasm')
+url="https://github.com/YamashitaRen/x264_YMod"
+conflicts=('x264')
+provides=('x264')
+source=('git://github.com/YamashitaRen/x264_YMod.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "%s.r%s.%s" "$(grep "#define X264_BUILD" x264.h | cut -d " " -f3)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_gitname
+
+ ./configure --prefix=/usr --bit-depth=10 --enable-pic
+ make
+ mv x264 x264-10bit
+
+ ./configure --prefix=/usr --enable-pic
+ make
+}
+
+package() {
+ cd $_gitname
+
+ make DESTDIR="$pkgdir" install
+ install -Dm755 x264-10bit "$pkgdir"/usr/bin/x264-10bit
+}