summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornik1232016-10-25 21:25:59 +0200
committernik1232016-10-25 21:25:59 +0200
commit7630a9d077c3cfe59c1b57cecd8978d9cb229be5 (patch)
treeeb3dd91f220acc32069baba8d1bd95b88a65f598
parentd576aee37434bb86ec970335c96ab0ca5a310274 (diff)
downloadaur-7630a9d077c3cfe59c1b57cecd8978d9cb229be5.tar.gz
Finnaly fixed CAVA-GUI
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a719f8d5489e..43559ded14ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
pkgname=cava-gui-git
-_pkgname=cava-gui
-pkgver=0.2
-pkgrel=2
+_pkgname=cava
+pkgver=r284.164c494
+pkgrel=1
pkgdesc='SDL2 Audio Visualizer for Alsa/Pulseaudio'
arch=('i686' 'x86_64')
url='https://github.com/nikp123/cava-gui'
license=('MIT')
-depends=('fftw' 'alsa-lib' 'iniparser' 'sdl2')
-makedepends=('git')
-source=('git+https://github.com/nikp123/cava-gui.git')
+depends=('fftw' 'alsa-lib' 'iniparser' 'libx11')
+makedepends=('git' 'libtool' 'automake')
+source=('git+https://github.com/nikp123/cava.git')
conflicts=($_pkgname)
provides=($_pkgname)
sha1sums=('SKIP')
@@ -19,10 +19,9 @@ pkgver() {
}
build() {
- chmod +x $_pkgname/autogen.sh
cd $_pkgname
./autogen.sh
- ./configure --prefix=/usr
+ ./configure
make
}
@@ -30,6 +29,6 @@ package() {
cd $_pkgname
install -Dm755 cava "$pkgdir/usr/bin/$_pkgname"
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
- install -Dm744 example_files/icon.png "$pkgdir/usr/share/$_pkgname/icon.png"
- install -Dm744 example_files/"$_pkgname".desktop "$pkgdir"/usr/share/applications/"$_pkgname".desktop
+ install -Dm744 example_files/desktop/icon.png "$pkgdir/usr/share/$_pkgname/icon.png"
+ install -Dm744 example_files/desktop/"$_pkgname".desktop "$pkgdir"/usr/share/applications/"$_pkgname".desktop
}