summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgreg20102022-03-15 21:54:43 -0400
committergreg20102022-03-15 23:08:43 -0400
commitfa82c41a737ec718fbb51287afae511d887e4cf6 (patch)
treec6f7f205a43aae4196d60a304461390f4d3a9b4a
parent403d3be3df6c9a770aad297878fb0e2da997a75a (diff)
downloadaur-xbindjoy-git.tar.gz
sync up with upstream
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--arch-package.patch (renamed from guile22.patch)14
-rw-r--r--gcc10.patch39
4 files changed, 8 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aae6367d39ab..db606978baef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xbindjoy-git
pkgdesc = Tool for making your joysticks and gamepads more useful
- pkgver = r93.e599772
+ pkgver = r95.5ffef01
pkgrel = 1
url = https://github.com/saulrh/XBindJoy
arch = x86_64
@@ -12,10 +12,8 @@ pkgbase = xbindjoy-git
provides = xbindjoy-git
conflicts = xbindjoy-git
source = git+https://github.com/saulrh/XBindJoy.git
- source = gcc10.patch
- source = guile22.patch
+ source = arch-package.patch
sha256sums = SKIP
- sha256sums = fe60cd4f60ad3406e86e13951706766e499cfc2602fae188c76cec215918c838
- sha256sums = 7a4cc5332bc6257c768c5482711e286f6aed57f100b39cc88320c8c4092471b6
+ sha256sums = 5cadaa5e7f38015f62ebfbc73d594915ed7d8289ffa2a74b09b84ad9fff44f81
pkgname = xbindjoy-git
diff --git a/PKGBUILD b/PKGBUILD
index 1cca187d8de9..10c95de61992 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Grigory Romodanovskiy <greg2008200 at gmail dot com>
pkgname=xbindjoy-git
_gitname=XBindJoy
-pkgver=r93.e599772
+pkgver=r95.5ffef01
pkgrel=1
pkgdesc="Tool for making your joysticks and gamepads more useful"
arch=(x86_64)
@@ -16,11 +16,10 @@ replaces=()
backup=()
options=()
install=
-source=("git+${url}.git" 'gcc10.patch' 'guile22.patch')
+source=("git+${url}.git" 'arch-package.patch')
noextract=()
sha256sums=('SKIP'
- 'fe60cd4f60ad3406e86e13951706766e499cfc2602fae188c76cec215918c838'
- '7a4cc5332bc6257c768c5482711e286f6aed57f100b39cc88320c8c4092471b6')
+ '5cadaa5e7f38015f62ebfbc73d594915ed7d8289ffa2a74b09b84ad9fff44f81')
pkgver() {
cd ${_gitname}
@@ -31,8 +30,7 @@ pkgver() {
prepare() {
cd "${_gitname}"
- git apply "${srcdir}/gcc10.patch"
- git apply "${srcdir}/guile22.patch"
+ git apply "${srcdir}/arch-package.patch"
}
build() {
diff --git a/guile22.patch b/arch-package.patch
index 77977971e997..9e57e5d6fde3 100644
--- a/guile22.patch
+++ b/arch-package.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile b/Makefile
-index a89ceda..b426a14 100644
+index a89ceda..b7834d8 100644
--- a/Makefile
+++ b/Makefile
@@ -28,12 +28,12 @@ src := $(wildcard src/*.c)
@@ -34,18 +34,6 @@ index a89ceda..b426a14 100644
- rm -f $(obj) libguilexbindjoy.so
+ rm -f $(obj) $(solib)
rm -f $(dep)
-diff --git a/examples/generic.scm b/examples/generic.scm
-index 53168c8..53b6e44 100755
---- a/examples/generic.scm
-+++ b/examples/generic.scm
-@@ -35,7 +35,6 @@
- ;;; but we're not going to do that, because this is an example that we want people to be able to
- ;;; run right after they grab the code. so we just use the first joystick that's plugged in.
- (define jsd "/dev/input/js0")
--
- (define naxes (get-js-num-axes jsd))
- (define nbuttons (get-js-num-buttons jsd))
- (init-xbindjoy nbuttons naxes)
diff --git a/saulrh/xbindjoy.scm b/saulrh/xbindjoy.scm
index 856d79d..0803471 100644
--- a/saulrh/xbindjoy.scm
diff --git a/gcc10.patch b/gcc10.patch
deleted file mode 100644
index e94ae903d825..000000000000
--- a/gcc10.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/src/xbindjoy.c b/src/xbindjoy.c
-index 70d5b66..f1021e1 100644
---- a/src/xbindjoy.c
-+++ b/src/xbindjoy.c
-@@ -40,6 +40,9 @@
- // /////////////////////////////////////////////////////////////////////////////
- // variables
-
-+int verbose;
-+Display* display;
-+
- // the file descriptor for our joystick
- int jsfd;
-
-@@ -79,7 +82,7 @@ static void timer_callback(EV_P_ ev_timer* w, int revents) {
- last_time.tv_nsec = cur_time.tv_nsec;
- }
-
--static void sigint_callback(EV_P_ ev_timer* w, int revents) {
-+static void sigint_callback(EV_P_ ev_signal* w, int revents) {
- ev_break(loop, EVBREAK_ALL);
- }
-
-diff --git a/src/xbindjoy.h b/src/xbindjoy.h
-index 7d257dc..ff4b848 100644
---- a/src/xbindjoy.h
-+++ b/src/xbindjoy.h
-@@ -21,8 +21,9 @@
-
- #include<X11/Xlib.h>
-
--int verbose;
--Display* display;
-+extern int verbose;
-+extern Display* display;
-+
-
- typedef enum {
- PRESS,