summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2023-04-01 19:58:24 +0200
committerAntonio Rojas2023-04-01 19:58:24 +0200
commit671b49630ce6d95c806109091eccf854c52f77ac (patch)
tree80275265788dbda305211443b4c09d6f6aa558de
downloadaur-xdiskusage.tar.gz
import from community
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d98676527a60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xdiskusage
+ pkgdesc = A user-friendly program to show you what is using up all your disk space
+ pkgver = 1.60
+ pkgrel = 2
+ url = https://xdiskusage.sourceforge.net
+ arch = x86_64
+ license = GPL
+ makedepends = libxi
+ depends = fltk
+ options = !emptydirs
+ source = https://xdiskusage.sourceforge.net/xdiskusage-1.60.tgz
+ sha256sums = 7b536dc6f1bdc6d9bec7c29b9435c23d9d32bff8a0ebee26b9966b273dc9f67e
+
+pkgname = xdiskusage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8edaa26438af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Jason Chu <jason@archlinux.org>
+
+pkgname=xdiskusage
+pkgver=1.60
+pkgrel=2
+pkgdesc="A user-friendly program to show you what is using up all your disk space"
+arch=('x86_64')
+depends=('fltk')
+makedepends=('libxi')
+license=('GPL')
+url="https://xdiskusage.sourceforge.net"
+options=(!emptydirs)
+source=("https://xdiskusage.sourceforge.net/$pkgname-$pkgver.tgz")
+sha256sums=('7b536dc6f1bdc6d9bec7c29b9435c23d9d32bff8a0ebee26b9966b273dc9f67e')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -d "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man1"
+ make prefix="$pkgdir/usr" mandir="$pkgdir/usr/share/man" install
+ chmod 0644 "$pkgdir"/usr/share/man/man1/*
+}