summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamLukeYes2020-06-25 16:01:25 +0800
committerSamLukeYes2020-06-25 16:01:25 +0800
commit2c81bb2d7b05824ef6981fe9de7ef71a275fce81 (patch)
tree7a6ab7d5a43ad72e0f5f8204b615ec6363458923
parent91bf6baa1e4b0fd7cbabc0b2a17e2be93411fb01 (diff)
downloadaur-xdroid-installer.tar.gz
update 4.0082
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD15
-rw-r--r--xdroid-installer.install8
-rw-r--r--xdroid-installer.py15
4 files changed, 23 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1684b8b2536d..380e1cd4cd8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xdroid-installer
pkgdesc = The installer and uninstaller of xDroid, a closed source Android container that uses similar techniques to Anbox.
- pkgver = 4.0078
+ pkgver = 4.0082
pkgrel = 1
url = https://www.linzhuotech.com/index.php/home/index/xdroid.html
install = xdroid-installer.install
@@ -11,20 +11,19 @@ pkgbase = xdroid-installer
depends = qt5-virtualkeyboard
depends = openssl-1.0
depends = tar
- depends = python
+ depends = python-easygui
optdepends = fcitx-qt5: Asian input method support
- optdepends = python-easygui: for choosing to reinstall or uninstall after the first installation
- noextract = xDroidInstall-x86_64-v4.0078-20200620101733.tar.gz
- source = https://github.com/SamLukeYes/xdroid-installer/releases/download/v4.0078/xDroidInstall-x86_64-v4.0078-20200620101733.tar.gz
+ noextract = xDroidInstall-x86_64-v4.0082-20200624145405.tar.gz
+ source = https://github.com/SamLukeYes/xdroid-installer/releases/download/v4.0082/xDroidInstall-x86_64-v4.0082-20200624145405.tar.gz
source = xdroid-installer.desktop
source = LICENSE
source = xdroid-installer.install
source = xdroid-installer.py
- md5sums = f6941c16177c72e376ffd105677cd75c
+ md5sums = 05b605ec88b235ec81b42ef85f0945de
md5sums = e467770854d49aea2d94c451a443471e
md5sums = 08c8f971fe3ae5cac148ef220975291b
- md5sums = da271d861635cabc2bafac5b01b0fa13
- md5sums = e55a42b96e3a8d975df5770e6e0bf28b
+ md5sums = 0daa8ce21eef5c3c4b7ffcca1433d4b1
+ md5sums = f84a84c2627ac973a3af96bd918a8f02
pkgname = xdroid-installer
diff --git a/PKGBUILD b/PKGBUILD
index 4422b8c995bc..737b5158b05f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Sam L. Yes <manjaroyes123@outlook.com>
pkgname=xdroid-installer
-pkgver=4.0078
+pkgver=4.0082
pkgrel=1
pkgdesc="The installer and uninstaller of xDroid, a closed source Android container that uses similar techniques to Anbox."
arch=('x86_64')
url="https://www.linzhuotech.com/index.php/home/index/xdroid.html"
license=('custom')
groups=()
-depends=('gtk3' 'qt5-wayland' 'qt5-virtualkeyboard' 'openssl-1.0' 'tar' 'python')
+depends=('gtk3' 'qt5-wayland' 'qt5-virtualkeyboard' 'openssl-1.0' 'tar' 'python-easygui')
makedepends=()
-optdepends=('fcitx-qt5: Asian input method support'
- 'python-easygui: for choosing to reinstall or uninstall after the first installation')
+optdepends=('fcitx-qt5: Asian input method support')
provides=()
conflicts=()
replaces=()
@@ -18,18 +17,18 @@ backup=()
options=()
install="${pkgname}.install"
changelog=
-_filename="xDroidInstall-x86_64-v${pkgver}-20200620101733.tar.gz"
+_filename="xDroidInstall-x86_64-v${pkgver}-20200624145405.tar.gz"
source=("https://github.com/SamLukeYes/xdroid-installer/releases/download/v${pkgver}/${_filename}"
"${pkgname}.desktop"
"LICENSE"
"${pkgname}.install"
"${pkgname}.py")
noextract=(${_filename})
-md5sums=('f6941c16177c72e376ffd105677cd75c'
+md5sums=('05b605ec88b235ec81b42ef85f0945de'
'e467770854d49aea2d94c451a443471e'
'08c8f971fe3ae5cac148ef220975291b'
- '025974b0e37da69e031e6ec1e346fef8'
- '74c526e3fadfeb135faf1f2826daf33b')
+ '0daa8ce21eef5c3c4b7ffcca1433d4b1'
+ 'f84a84c2627ac973a3af96bd918a8f02')
package() {
#_target=${pkgdir}/opt/${pkgname}
diff --git a/xdroid-installer.install b/xdroid-installer.install
index 3bc7ef1dc060..c8769ffac1c6 100644
--- a/xdroid-installer.install
+++ b/xdroid-installer.install
@@ -8,14 +8,6 @@ post_install() {
echo "#############################################################################"
}
-pre_upgrade() {
- rm -rf /opt/xdroid-installer
-}
-
-post_upgrade() {
- post_install
-}
-
post_remove() {
echo "Note: you can still uninstall xDroid by executing /opt/xdroid/remove-xdroid-launcher after removing xdroid-installer"
} \ No newline at end of file
diff --git a/xdroid-installer.py b/xdroid-installer.py
index 5fa9f0e29369..c9ac977771c3 100644
--- a/xdroid-installer.py
+++ b/xdroid-installer.py
@@ -5,10 +5,12 @@ import os, sys
try:
import easygui as eg
dialogs = True
-except:
+except ModuleNotFoundError:
dialogs = False
uninstaller = '/opt/xdroid/remove-xdroid-launcher'
+reinstall = 'Upgrade/Reinstall'
+uninstall = 'Uninstall'
def install():
sys.exit(os.system('tar -xzvf /opt/xdroid-installer/xdroid.tar.gz -C /tmp \
@@ -25,14 +27,15 @@ if os.getuid() == 0:
if os.path.isfile(uninstaller):
if dialogs:
- option = eg.choicebox("Do you want to reinstall or uninstall xDroid?", "xDroid Installer",
- choices=["Reinstall", "Uninstall"])
+ option = eg.choicebox("You have xDroid installed already. What do you want to do next?",
+ title="xDroid Installer",
+ choices=[reinstall, uninstall])
else:
- option = "Uninstall"
+ option = uninstall
- if option == "Reinstall":
+ if option == reinstall:
install()
- elif option == "Uninstall":
+ elif option == uninstall:
os.system(uninstaller)
else: