summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Mulvey2022-02-15 10:48:22 -0800
committerSam Mulvey2022-02-15 10:48:22 -0800
commit8c88ec2784c97e91dd385acdc0aefd5744fd2da4 (patch)
tree29b634906d6b49aaa6fce1562f8aeedc6b86e8be
parent7fc682c016914818a945d55b65a853495e9092b9 (diff)
downloadaur-8c88ec2784c97e91dd385acdc0aefd5744fd2da4.tar.gz
qemu depackaging in an if statement
-rw-r--r--.SRCINFO2
-rw-r--r--ChangeLog4
-rw-r--r--PKGBUILD34
3 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 202e57ea34ac..f895757a2981 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xen
pkgdesc = Open-source type-1 or baremetal hypervisor
pkgver = 4.16.0
- pkgrel = 2
+ pkgrel = 3
url = https://xenproject.org/
arch = x86_64
license = GPL2
diff --git a/ChangeLog b/ChangeLog
index a70d703d6137..e028522ceed7 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2022-02-15
+ * 4.16.0-3
+ * forgot to wrap qemu subpackage in an if
+
2022-02-06
* 4.16.0-2
* security patches
diff --git a/PKGBUILD b/PKGBUILD
index f14a378d18bb..436961c18314 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ _zlib=1.2.3
pkgbase=xen
pkgname=("xen" "xen-docs")
pkgver=4.16.0
-pkgrel=2
+pkgrel=3
pkgdesc='Open-source type-1 or baremetal hypervisor'
arch=('x86_64')
url='https://xenproject.org/'
@@ -296,20 +296,24 @@ package_xen() {
rm -r "${pkgdir}/usr/lib/xen/boot"
# remove qemu
- rm -r "${pkgdir}/usr/share/qemu-xen"
- rm -r \
- "${pkgdir}/usr/lib/xen/include/qemu-plugin.h" \
- "${pkgdir}/usr/lib/xen/bin/qemu-pr-helper" \
- "${pkgdir}/usr/lib/xen/bin/qemu-edid" \
- "${pkgdir}/usr/lib/xen/bin/elf2dmp" \
- "${pkgdir}/usr/lib/xen/bin/qemu-storage-daemon" \
- "${pkgdir}/usr/lib/xen/bin/qemu-nbd" \
- "${pkgdir}/usr/lib/xen/bin/qemu-io" \
- "${pkgdir}/usr/lib/xen/bin/qemu-img" \
- "${pkgdir}/usr/lib/xen/bin/qemu-system-i386" \
- "${pkgdir}/usr/lib/xen/libexec/virtiofsd" \
- "${pkgdir}/usr/lib/xen/libexec/qemu-bridge-helper" \
- "${pkgdir}/usr/lib/xen/libexec/virtfs-proxy-helper"
+ if [ "${_build_qemu}" == "true" ]; then
+
+ rm -r "${pkgdir}/usr/share/qemu-xen"
+ rm -r \
+ "${pkgdir}/usr/lib/xen/include/qemu-plugin.h" \
+ "${pkgdir}/usr/lib/xen/bin/qemu-pr-helper" \
+ "${pkgdir}/usr/lib/xen/bin/qemu-edid" \
+ "${pkgdir}/usr/lib/xen/bin/elf2dmp" \
+ "${pkgdir}/usr/lib/xen/bin/qemu-storage-daemon" \
+ "${pkgdir}/usr/lib/xen/bin/qemu-nbd" \
+ "${pkgdir}/usr/lib/xen/bin/qemu-io" \
+ "${pkgdir}/usr/lib/xen/bin/qemu-img" \
+ "${pkgdir}/usr/lib/xen/bin/qemu-system-i386" \
+ "${pkgdir}/usr/lib/xen/libexec/virtiofsd" \
+ "${pkgdir}/usr/lib/xen/libexec/qemu-bridge-helper" \
+ "${pkgdir}/usr/lib/xen/libexec/virtfs-proxy-helper"
+
+ fi
}