summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTarn Burton2019-01-24 13:11:30 -0500
committerTarn Burton2019-01-24 13:11:30 -0500
commit0c4c6daf211af201aa5e8b6cbe462feb2e1563b7 (patch)
tree02d2616abc702bdf1399c95858604b91f16355d4
parent6af7991de585b78ead27517a5f8a27fb088ab923 (diff)
downloadaur-0c4c6daf211af201aa5e8b6cbe462feb2e1563b7.tar.gz
Update version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--package.patch41
3 files changed, 16 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce4962d6ceed..8734d85f4357 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Mar 25 13:34:51 UTC 2018
pkgbase = xeus
pkgdesc = C++ implementation of the Jupyter kernel protocol
- pkgver = 0.11.0
+ pkgver = 0.18.1
pkgrel = 1
url = https://github.com/QuantStack/xeus
arch = x86_64
@@ -11,18 +9,18 @@ pkgbase = xeus
depends = nlohmann-json
depends = xtl
depends = zeromq
- source = xeus::https://github.com/QuantStack/xeus/archive/{0.11.0}.tar.gz
+ source = xeus-0.18.1.tar.gz::https://github.com/QuantStack/xeus/archive/0.18.1.tar.gz
source = https://raw.githubusercontent.com/zeromq/cppzmq/master/zmq_addon.hpp
source = Findcppzmq.cmake
source = Findcryptopp.cmake
source = FindZeroMQ.cmake
source = package.patch
- sha256sums = 479bf8ed915d325efe3b237697b50d8113f74928130a35be7f44dce87912d7a8
- sha256sums = f3ad054859fa34c214f25d850c3103816c63b835f3c34a753e878b87307ea945
+ sha256sums = b2bf124d015399ba5a40bc77b80254c9217944223295a8b9b764ec179d0e4b9a
+ sha256sums = bcb34c2cd5393673679c46034ad7ae882206d68321e3b4532b895dc666139a34
sha256sums = 9f2f6f73af088945f0c6610d6e3024083b7dee89b0f5df2d816cd7925564108e
sha256sums = 1b00b80c30a17d917ce5374d870e15f5a5fa60e1120b1c485b87e4b88ef6f0f3
sha256sums = c0d3f386032d07adcf3ee9a39cfc8df643f182d2b1190c1e7e4a3014a4f01a04
- sha256sums = fd016c48aad15e7425705c0412fa811240c3a3a055dc25a0c0cb20d23fa0111a
+ sha256sums = 4886a128fcb62f0591c9a5566e574e8a93dc086486ea7f2e52529b2b643bc04f
pkgname = xeus
diff --git a/PKGBUILD b/PKGBUILD
index 83e8cd835f6f..7a3767ba923d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tarn Burton <twburton at gmail dot com>
pkgname=xeus
-pkgver=0.11.0
+pkgver=0.18.1
pkgrel=1
pkgdesc="C++ implementation of the Jupyter kernel protocol"
arch=("x86_64")
@@ -9,18 +9,18 @@ license=('BSD')
depends=('crypto++' 'nlohmann-json' 'xtl' 'zeromq')
makedepend=('cmake')
source=(
- "$pkgname.tar.gz::https://github.com/QuantStack/xeus/archive/{$pkgver}.tar.gz"
+ "$pkgname-$pkgver.tar.gz::https://github.com/QuantStack/xeus/archive/$pkgver.tar.gz"
"https://raw.githubusercontent.com/zeromq/cppzmq/master/zmq_addon.hpp"
'Findcppzmq.cmake'
'Findcryptopp.cmake'
'FindZeroMQ.cmake'
'package.patch')
-sha256sums=('479bf8ed915d325efe3b237697b50d8113f74928130a35be7f44dce87912d7a8'
- 'f3ad054859fa34c214f25d850c3103816c63b835f3c34a753e878b87307ea945'
+sha256sums=('b2bf124d015399ba5a40bc77b80254c9217944223295a8b9b764ec179d0e4b9a'
+ 'bcb34c2cd5393673679c46034ad7ae882206d68321e3b4532b895dc666139a34'
'9f2f6f73af088945f0c6610d6e3024083b7dee89b0f5df2d816cd7925564108e'
'1b00b80c30a17d917ce5374d870e15f5a5fa60e1120b1c485b87e4b88ef6f0f3'
'c0d3f386032d07adcf3ee9a39cfc8df643f182d2b1190c1e7e4a3014a4f01a04'
- 'fd016c48aad15e7425705c0412fa811240c3a3a055dc25a0c0cb20d23fa0111a')
+ '4886a128fcb62f0591c9a5566e574e8a93dc086486ea7f2e52529b2b643bc04f')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/package.patch b/package.patch
index a405790addbc..23fe8862bdaa 100644
--- a/package.patch
+++ b/package.patch
@@ -1,44 +1,15 @@
diff -aur -bZwB -x .git xeus-0.11.0.old/CMakeLists.txt xeus-0.11.0/CMakeLists.txt
--- xeus-0.11.0.old/CMakeLists.txt 2018-03-25 09:33:11.000929782 -0400
+++ xeus-0.11.0/CMakeLists.txt 2018-03-25 09:34:42.577890245 -0400
-@@ -107,8 +107,8 @@
+@@ -129,9 +129,9 @@
target_include_directories(xeus PUBLIC $<BUILD_INTERFACE:${XEUS_INCLUDE_DIR}>
$<INSTALL_INTERFACE:include>)
target_link_libraries(xeus
- PUBLIC cppzmq
-- PRIVATE cryptopp-static
+ PUBLIC zmq
-+ PRIVATE cryptopp
- PRIVATE xtl)
-
+ PUBLIC nlohmann_json::nlohmann_json
+ PUBLIC xtl
+- PRIVATE cryptopp-static)
++ PRIVATE cryptopp)
+
if(NOT MSVC)
-diff -aur -bZwB -x .git xeus-0.11.0.old/src/xauthentication.cpp xeus-0.11.0/src/xauthentication.cpp
---- xeus-0.11.0.old/src/xauthentication.cpp 2018-03-25 09:33:11.001928616 -0400
-+++ xeus-0.11.0/src/xauthentication.cpp 2018-03-25 09:33:15.811442497 -0400
-@@ -24,7 +24,7 @@
- public:
-
- using hmac_type = CryptoPP::HMAC<T>;
-- using signature_type = std::array<byte, hmac_type::DIGESTSIZE>;
-+ using signature_type = std::array<CryptoPP::byte, hmac_type::DIGESTSIZE>;
-
- explicit xauthentication_impl(const std::string& key);
- virtual ~xauthentication_impl() = default;
-@@ -101,7 +101,7 @@
- template <class T>
- xauthentication_impl<T>::xauthentication_impl(const std::string& key)
- {
-- m_hmac = hmac_type(reinterpret_cast<const byte*>(key.c_str()), key.size());
-+ m_hmac = hmac_type(reinterpret_cast<const CryptoPP::byte*>(key.c_str()), key.size());
- }
-
- template <class T>
-@@ -137,7 +137,7 @@
- std::string hex_sig = hex_string(sig);
-
- // Reduces the vulnerability to timing attacks.
-- bool res = CryptoPP::VerifyBufsEqual(reinterpret_cast<const byte*>(hex_sig.c_str()),
-+ bool res = CryptoPP::VerifyBufsEqual(reinterpret_cast<const CryptoPP::byte*>(hex_sig.c_str()),
- signature.data<const unsigned char>(),
- hex_sig.size());
- return res;