summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Land2019-10-05 11:45:40 -0400
committerGreg Land2019-10-05 11:45:40 -0400
commit517c8e03b6576f097e2713eda38a60213f1ce579 (patch)
tree2ec15316afcce210f5a91d42f76458dea7a49bcf
parent0c4c6daf211af201aa5e8b6cbe462feb2e1563b7 (diff)
downloadaur-517c8e03b6576f097e2713eda38a60213f1ce579.tar.gz
First pass at getting this functional
Updated to 0.23.2 Removed cryptopp Removed zmq_addon.hpp Added static libraries as required for building xeus-cling
-rw-r--r--.SRCINFO13
-rw-r--r--Findcryptopp.cmake25
-rw-r--r--PKGBUILD12
-rw-r--r--package.patch26
4 files changed, 20 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8734d85f4357..870ce9448acd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xeus
pkgdesc = C++ implementation of the Jupyter kernel protocol
- pkgver = 0.18.1
+ pkgver = 0.23.2
pkgrel = 1
url = https://github.com/QuantStack/xeus
arch = x86_64
@@ -9,18 +9,15 @@ pkgbase = xeus
depends = nlohmann-json
depends = xtl
depends = zeromq
- source = xeus-0.18.1.tar.gz::https://github.com/QuantStack/xeus/archive/0.18.1.tar.gz
- source = https://raw.githubusercontent.com/zeromq/cppzmq/master/zmq_addon.hpp
+ options = staticlibs
+ source = xeus-0.23.2.tar.gz::https://github.com/QuantStack/xeus/archive/0.23.2.tar.gz
source = Findcppzmq.cmake
- source = Findcryptopp.cmake
source = FindZeroMQ.cmake
source = package.patch
- sha256sums = b2bf124d015399ba5a40bc77b80254c9217944223295a8b9b764ec179d0e4b9a
- sha256sums = bcb34c2cd5393673679c46034ad7ae882206d68321e3b4532b895dc666139a34
+ sha256sums = 62d4734a27609b389df34b56793245d4afd8f8346dba2e5c0e78bb02637a1e5c
sha256sums = 9f2f6f73af088945f0c6610d6e3024083b7dee89b0f5df2d816cd7925564108e
- sha256sums = 1b00b80c30a17d917ce5374d870e15f5a5fa60e1120b1c485b87e4b88ef6f0f3
sha256sums = c0d3f386032d07adcf3ee9a39cfc8df643f182d2b1190c1e7e4a3014a4f01a04
- sha256sums = 4886a128fcb62f0591c9a5566e574e8a93dc086486ea7f2e52529b2b643bc04f
+ sha256sums = 83ed536b214b3f36852799a963397ac8c6f83a67b692d5f83204714b0141cbcf
pkgname = xeus
diff --git a/Findcryptopp.cmake b/Findcryptopp.cmake
deleted file mode 100644
index 7f62fa9c01ae..000000000000
--- a/Findcryptopp.cmake
+++ /dev/null
@@ -1,25 +0,0 @@
-find_path(CryptoPP_INCLUDE_DIR NAMES cryptopp/config.h DOC "CryptoPP include directory")
-find_library(CryptoPP_LIBRARY NAMES cryptopp DOC "CryptoPP library")
-
-if(CryptoPP_INCLUDE_DIR)
- file(STRINGS ${CryptoPP_INCLUDE_DIR}/cryptopp/config.h _config_version REGEX "CRYPTOPP_VERSION")
- string(REGEX MATCH "([0-9])([0-9])([0-9])" _match_version ${_config_version})
- set(CryptoPP_VERSION_STRING "${CMAKE_MATCH_1}.${CMAKE_MATCH_2}.${CMAKE_MATCH_3}")
-endif()
-
-include(FindPackageHandleStandardArgs)
-find_package_handle_standard_args(CryptoPP
- REQUIRED_VARS CryptoPP_INCLUDE_DIR CryptoPP_LIBRARY
- FOUND_VAR CryptoPP_FOUND
- VERSION_VAR CryptoPP_VERSION_STRING)
-
-if(CryptoPP_FOUND AND NOT TARGET CryptoPP::CryptoPP)
- add_library(CryptoPP::CryptoPP UNKNOWN IMPORTED)
- set_target_properties(CryptoPP::CryptoPP PROPERTIES
- IMPORTED_LOCATION "${CryptoPP_LIBRARY}"
- INTERFACE_INCLUDE_DIRECTORIES "${CryptoPP_INCLUDE_DIR}")
-endif()
-
-mark_as_advanced(CryptoPP_INCLUDE_DIR CryptoPP_LIBRARY)
-set(CryptoPP_INCLUDE_DIRS ${CryptoPP_INCLUDE_DIR})
-set(CryptoPP_LIBRARIES ${CryptoPP_LIBRARY})
diff --git a/PKGBUILD b/PKGBUILD
index 7a3767ba923d..4beb8d096c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tarn Burton <twburton at gmail dot com>
pkgname=xeus
-pkgver=0.18.1
+pkgver=0.23.2
pkgrel=1
pkgdesc="C++ implementation of the Jupyter kernel protocol"
arch=("x86_64")
@@ -10,22 +10,18 @@ depends=('crypto++' 'nlohmann-json' 'xtl' 'zeromq')
makedepend=('cmake')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/QuantStack/xeus/archive/$pkgver.tar.gz"
- "https://raw.githubusercontent.com/zeromq/cppzmq/master/zmq_addon.hpp"
'Findcppzmq.cmake'
- 'Findcryptopp.cmake'
'FindZeroMQ.cmake'
'package.patch')
-sha256sums=('b2bf124d015399ba5a40bc77b80254c9217944223295a8b9b764ec179d0e4b9a'
- 'bcb34c2cd5393673679c46034ad7ae882206d68321e3b4532b895dc666139a34'
+sha256sums=('62d4734a27609b389df34b56793245d4afd8f8346dba2e5c0e78bb02637a1e5c'
'9f2f6f73af088945f0c6610d6e3024083b7dee89b0f5df2d816cd7925564108e'
- '1b00b80c30a17d917ce5374d870e15f5a5fa60e1120b1c485b87e4b88ef6f0f3'
'c0d3f386032d07adcf3ee9a39cfc8df643f182d2b1190c1e7e4a3014a4f01a04'
- '4886a128fcb62f0591c9a5566e574e8a93dc086486ea7f2e52529b2b643bc04f')
+ '83ed536b214b3f36852799a963397ac8c6f83a67b692d5f83204714b0141cbcf')
+options=(staticlibs)
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -Np1 -i ../package.patch
- cp ../../zmq_addon.hpp include
}
build() {
diff --git a/package.patch b/package.patch
index 23fe8862bdaa..7a74d53656f7 100644
--- a/package.patch
+++ b/package.patch
@@ -1,15 +1,11 @@
-diff -aur -bZwB -x .git xeus-0.11.0.old/CMakeLists.txt xeus-0.11.0/CMakeLists.txt
---- xeus-0.11.0.old/CMakeLists.txt 2018-03-25 09:33:11.000929782 -0400
-+++ xeus-0.11.0/CMakeLists.txt 2018-03-25 09:34:42.577890245 -0400
-@@ -129,9 +129,9 @@
- target_include_directories(xeus PUBLIC $<BUILD_INTERFACE:${XEUS_INCLUDE_DIR}>
- $<INSTALL_INTERFACE:include>)
- target_link_libraries(xeus
-- PUBLIC cppzmq
-+ PUBLIC zmq
- PUBLIC nlohmann_json::nlohmann_json
- PUBLIC xtl
-- PRIVATE cryptopp-static)
-+ PRIVATE cryptopp)
-
- if(NOT MSVC)
+--- old/CMakeLists.txt 2019-09-10 11:07:54.000000000 -0400
++++ CMakeLists.txt 2019-09-30 17:31:38.300168873 -0400
+@@ -198,7 +198,7 @@
+ )
+ target_link_libraries(
+ ${target_name}
+- PUBLIC cppzmq
++ PUBLIC zmq
+ PUBLIC nlohmann_json::nlohmann_json
+ PUBLIC xtl
+ )