summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Land2019-10-05 15:25:15 -0400
committerGreg Land2019-10-05 15:25:15 -0400
commit8afbcd6ebab65665d5d02efc2f5a4cff9cd151a4 (patch)
tree6f1273ace3812308604d8cc4a9d3d5a04fce3cd8
parent517c8e03b6576f097e2713eda38a60213f1ce579 (diff)
downloadaur-8afbcd6ebab65665d5d02efc2f5a4cff9cd151a4.tar.gz
Removed old cmake overrides
-rw-r--r--.SRCINFO6
-rw-r--r--FindZeroMQ.cmake17
-rw-r--r--Findcppzmq.cmake16
-rw-r--r--PKGBUILD10
4 files changed, 4 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 870ce9448acd..c9705208d10a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xeus
pkgdesc = C++ implementation of the Jupyter kernel protocol
pkgver = 0.23.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/QuantStack/xeus
arch = x86_64
license = BSD
@@ -11,12 +11,8 @@ pkgbase = xeus
depends = zeromq
options = staticlibs
source = xeus-0.23.2.tar.gz::https://github.com/QuantStack/xeus/archive/0.23.2.tar.gz
- source = Findcppzmq.cmake
- source = FindZeroMQ.cmake
source = package.patch
sha256sums = 62d4734a27609b389df34b56793245d4afd8f8346dba2e5c0e78bb02637a1e5c
- sha256sums = 9f2f6f73af088945f0c6610d6e3024083b7dee89b0f5df2d816cd7925564108e
- sha256sums = c0d3f386032d07adcf3ee9a39cfc8df643f182d2b1190c1e7e4a3014a4f01a04
sha256sums = 83ed536b214b3f36852799a963397ac8c6f83a67b692d5f83204714b0141cbcf
pkgname = xeus
diff --git a/FindZeroMQ.cmake b/FindZeroMQ.cmake
deleted file mode 100644
index 40cc0eb0ac9f..000000000000
--- a/FindZeroMQ.cmake
+++ /dev/null
@@ -1,17 +0,0 @@
-# - Try to find ZMQ
-# Once done this will define
-# ZMQ_FOUND - System has ZMQ
-# ZMQ_INCLUDE_DIRS - The ZMQ include directories
-# ZMQ_LIBRARIES - The libraries needed to use ZMQ
-# ZMQ_DEFINITIONS - Compiler switches required for using ZMQ
-
-find_path ( ZMQ_INCLUDE_DIR zmq.h )
-find_library ( ZMQ_LIBRARY NAMES zmq )
-
-set ( ZMQ_LIBRARIES ${ZMQ_LIBRARY} )
-set ( ZMQ_INCLUDE_DIRS ${ZMQ_INCLUDE_DIR} )
-
-include ( FindPackageHandleStandardArgs )
-# handle the QUIETLY and REQUIRED arguments and set ZMQ_FOUND to TRUE
-# if all listed variables are TRUE
-find_package_handle_standard_args ( ZMQ DEFAULT_MSG ZMQ_LIBRARY ZMQ_INCLUDE_DIR )
diff --git a/Findcppzmq.cmake b/Findcppzmq.cmake
deleted file mode 100644
index 77dfbc19af77..000000000000
--- a/Findcppzmq.cmake
+++ /dev/null
@@ -1,16 +0,0 @@
-# - Find CPPZMQ
-# Find CPPZMQ library.
-# Once done this will define
-#
-# CPPZMQ_INCLUDE_DIR - where to find CPPZMQ header files, etc.
-# CPPZMQ_FOUND - True if CPPZMQ found.
-#
-
-find_path(CPPZMQ_INCLUDE_DIR NAMES zmq.hpp HINTS ${CPPZMQ_ROOT_DIR} ${CMAKE_SOURCE_DIR}/external/cppzmq)
-
-# handle the QUIETLY and REQUIRED arguments and set CPPZMQ_FOUND to TRUE if
-# all listed variables are TRUE
-include(FindPackageHandleStandardArgs)
-find_package_handle_standard_args(CPPZMQ REQUIRED_VARS CPPZMQ_INCLUDE_DIR)
-
-mark_as_advanced(CPPZMQ_INCLUDE_DIR)
diff --git a/PKGBUILD b/PKGBUILD
index 4beb8d096c66..31f911af90b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,17 @@
# Maintainer: Tarn Burton <twburton at gmail dot com>
pkgname=xeus
pkgver=0.23.2
-pkgrel=1
+pkgrel=2
pkgdesc="C++ implementation of the Jupyter kernel protocol"
arch=("x86_64")
url="https://github.com/QuantStack/xeus"
license=('BSD')
depends=('crypto++' 'nlohmann-json' 'xtl' 'zeromq')
-makedepend=('cmake')
+makedepend=('cmake' 'zeromq' 'cppzmq')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/QuantStack/xeus/archive/$pkgver.tar.gz"
- 'Findcppzmq.cmake'
- 'FindZeroMQ.cmake'
'package.patch')
sha256sums=('62d4734a27609b389df34b56793245d4afd8f8346dba2e5c0e78bb02637a1e5c'
- '9f2f6f73af088945f0c6610d6e3024083b7dee89b0f5df2d816cd7925564108e'
- 'c0d3f386032d07adcf3ee9a39cfc8df643f182d2b1190c1e7e4a3014a4f01a04'
'83ed536b214b3f36852799a963397ac8c6f83a67b692d5f83204714b0141cbcf')
options=(staticlibs)
@@ -28,7 +24,7 @@ build() {
cd "$pkgname-$pkgver"
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_MODULE_PATH=$PWD/../.. ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
make
}