summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Land2019-10-07 17:26:51 -0400
committerGreg Land2019-10-07 17:28:46 -0400
commitb78c988b25c98db00773263051166cdae3cb04c9 (patch)
tree619d7086137913f9121678d506a7dfc3b2a8ccc5
parent8afbcd6ebab65665d5d02efc2f5a4cff9cd151a4 (diff)
downloadaur-b78c988b25c98db00773263051166cdae3cb04c9.tar.gz
Resolved issue with libpgm in community that made the .patch file necessary
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--package.patch11
3 files changed, 4 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9705208d10a..3c92308df6b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xeus
pkgdesc = C++ implementation of the Jupyter kernel protocol
pkgver = 0.23.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/QuantStack/xeus
arch = x86_64
license = BSD
@@ -11,9 +11,7 @@ pkgbase = xeus
depends = zeromq
options = staticlibs
source = xeus-0.23.2.tar.gz::https://github.com/QuantStack/xeus/archive/0.23.2.tar.gz
- source = package.patch
sha256sums = 62d4734a27609b389df34b56793245d4afd8f8346dba2e5c0e78bb02637a1e5c
- sha256sums = 83ed536b214b3f36852799a963397ac8c6f83a67b692d5f83204714b0141cbcf
pkgname = xeus
diff --git a/PKGBUILD b/PKGBUILD
index 31f911af90b2..1865c7db49d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,17 @@
# Maintainer: Tarn Burton <twburton at gmail dot com>
pkgname=xeus
pkgver=0.23.2
-pkgrel=2
+pkgrel=3
pkgdesc="C++ implementation of the Jupyter kernel protocol"
arch=("x86_64")
url="https://github.com/QuantStack/xeus"
license=('BSD')
depends=('crypto++' 'nlohmann-json' 'xtl' 'zeromq')
makedepend=('cmake' 'zeromq' 'cppzmq')
-source=(
- "$pkgname-$pkgver.tar.gz::https://github.com/QuantStack/xeus/archive/$pkgver.tar.gz"
- 'package.patch')
-sha256sums=('62d4734a27609b389df34b56793245d4afd8f8346dba2e5c0e78bb02637a1e5c'
- '83ed536b214b3f36852799a963397ac8c6f83a67b692d5f83204714b0141cbcf')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/QuantStack/xeus/archive/$pkgver.tar.gz")
+sha256sums=('62d4734a27609b389df34b56793245d4afd8f8346dba2e5c0e78bb02637a1e5c')
options=(staticlibs)
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np1 -i ../package.patch
-}
-
build() {
cd "$pkgname-$pkgver"
mkdir -p build
diff --git a/package.patch b/package.patch
deleted file mode 100644
index 7a74d53656f7..000000000000
--- a/package.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- old/CMakeLists.txt 2019-09-10 11:07:54.000000000 -0400
-+++ CMakeLists.txt 2019-09-30 17:31:38.300168873 -0400
-@@ -198,7 +198,7 @@
- )
- target_link_libraries(
- ${target_name}
-- PUBLIC cppzmq
-+ PUBLIC zmq
- PUBLIC nlohmann_json::nlohmann_json
- PUBLIC xtl
- )