summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregor Kälin2024-07-29 14:01:32 +0200
committerGregor Kälin2024-07-29 14:01:32 +0200
commitc079e9957a5f6b42ab1989c71704d2e13920caeb (patch)
treefaf4e8afc11d5716cd1baa26969b60d517732fa3
parentfb69113cde34146508e18f16fa1869c6c1de0f3e (diff)
downloadaur-xeus3.tar.gz
Cleaning up PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e42b2b52f661..093a6ff39d08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xeus3
pkgdesc = C++ implementation of the Jupyter kernel protocol - Legacy version 3.2
pkgver = 3.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/QuantStack/xeus
arch = x86_64
license = BSD
@@ -16,6 +16,7 @@ pkgbase = xeus3
provides = xeus=3.2.0
conflicts = xeus
options = staticlibs
+ options = !debug
source = xeus3-3.2.0.tar.gz::https://github.com/QuantStack/xeus/archive/3.2.0.tar.gz
sha256sums = c0bf95e0cc58c083c99f49cdbf84fc60a1c03bed89d2cd63c10697ae8c87d1d1
diff --git a/PKGBUILD b/PKGBUILD
index 728ac0ba90e2..61cf6c804784 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gregor Kaelin <kaelingre at gmail dot com>
pkgname=xeus3
pkgver=3.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="C++ implementation of the Jupyter kernel protocol - Legacy version 3.2"
arch=("x86_64")
url="https://github.com/QuantStack/xeus"
@@ -10,10 +10,9 @@ depends=('openssl' 'crypto++' 'nlohmann-json' 'xtl' 'zeromq')
makedepends=('cmake' 'zeromq' 'cppzmq')
conflicts=('xeus')
provides=('xeus=3.2.0')
-options=(!debug)
source=("$pkgname-$pkgver.tar.gz::https://github.com/QuantStack/xeus/archive/$pkgver.tar.gz")
sha256sums=('c0bf95e0cc58c083c99f49cdbf84fc60a1c03bed89d2cd63c10697ae8c87d1d1')
-options=(staticlibs)
+options=(staticlibs !debug)
build() {
cd "xeus-$pkgver"