summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjskier2019-12-03 10:17:35 -0600
committerjskier2019-12-03 10:17:35 -0600
commitcb3cb3314142c0822ba7599945a22c47f77806c3 (patch)
treeb086b83c6182ea84c91195914fe70e6d18313463
downloadaur-cb3cb3314142c0822ba7599945a22c47f77806c3.tar.gz
new package name, initial push version 1.3.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..094c770ca431
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xfce-classiclooks
+ pkgdesc = The Xfce Evolution theme attempts to rid the Xfce desktop of visual distractions by providing a more consistent look (buttons, scrollbars, menus, etc) across older and newer applications.
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = http://www.itgroup.ro/WSX/browser.htm?.landingpage=wsx_content/en/linux/classiclooks.html#scroll-page
+ arch = any
+ license = GPLv2
+ depends = gtk-engine-murrine
+ optdepends = lib32-gtk-engine-murrine
+ optdepends = qt5-styleplugins
+ optdepends = noto-fonts
+ optdepends = elementary-xfce-icons
+ optdepends = nemo
+ conflicts = xfce-evolution-themes
+ source = https://downloads.sourceforge.net/project/classiclooks/classiclooks-1.3.2.zip
+ sha512sums = 54a8aa0865ad9e90ac259967e104e194969d4baa957ff7dbc5aae97fab0e06964e151e28370a62ca270c85a64c7eff851d5f95194847959d2c41752a825fe521
+
+pkgname = xfce-classiclooks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4424d87d63ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jeremy MountainJohnson <jskier@gmail.com>
+# Contributor: Jeremy MountainJohnson <jskier@gmail.com>
+
+pkgname=xfce-classiclooks
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="The Xfce Evolution theme attempts to rid the Xfce desktop of visual distractions by providing a more consistent look (buttons, scrollbars, menus, etc) across older and newer applications."
+arch=('any')
+url="http://www.itgroup.ro/WSX/browser.htm?.landingpage=wsx_content/en/linux/classiclooks.html#scroll-page"
+license=(GPLv2)
+depends=(gtk-engine-murrine)
+optdepends=(lib32-gtk-engine-murrine qt5-styleplugins noto-fonts elementary-xfce-icons nemo)
+source=(https://downloads.sourceforge.net/project/classiclooks/classiclooks-${pkgver}.zip)
+sha512sums=('54a8aa0865ad9e90ac259967e104e194969d4baa957ff7dbc5aae97fab0e06964e151e28370a62ca270c85a64c7eff851d5f95194847959d2c41752a825fe521')
+conflicts=('xfce-evolution-themes')
+
+package() {
+ # Set correct mode on files from zip source extraction
+ find $srcdir -type f -exec chmod 644 {} +
+ find $srcdir -type d -exec chmod 755 {} +
+
+ # Prepare all theme directories for package
+ for i in $srcdir/ClassicLooks*; do
+ if [ -d "$i" ]; then
+ install -dm 755 "$pkgdir/usr/share/themes/${i##*/}"
+ cp -rp "${i##*/}" "$pkgdir/usr/share/themes/"
+ fi
+ done
+
+ # Copy QT font fix over to global font conf
+ install -dm 755 "$pkgdir/etc/fonts/conf.avail/" "$pkgdir/etc/fonts/conf.d"
+
+ # Remove unnecessary TOOLS folder
+ rm -rf "$pkgdir/usr/share/themes/ClassicLooks/TOOLS"
+}