summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorghostbuster2022-01-15 00:47:30 +0100
committerghostbuster2022-01-15 00:47:30 +0100
commit5fbf8363656ac4382c495d35d7d1b76fa1f25df8 (patch)
tree42cfd02c9c56e2bba070cd5b8be212cdd8945979
parente3133702c85663167a3c1372864ffd0218bf27fb (diff)
downloadaur-xfce4-kbdleds-plugin.tar.gz
update to 0.2.5; PKGBUILD maintenance
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
-rw-r--r--deprecation_fixes.patch42
3 files changed, 14 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17ea0bb8c5fa..78f452f237e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xfce4-kbdleds-plugin
pkgdesc = Xfce keyboard LEDs panel plugin
- pkgver = 0.2.3
+ pkgver = 0.2.5
pkgrel = 1
url = https://github.com/oco2000/xfce4-kbdleds-plugin
install = xfce4-kbdleds-plugin.install
@@ -11,10 +11,7 @@ pkgbase = xfce4-kbdleds-plugin
makedepends = xfce4-dev-tools
depends = xfce4-panel
conflicts = xfce4-kbdleds-plugin-git
- source = https://github.com/oco2000/xfce4-kbdleds-plugin/archive/xfce4-kbdleds-plugin-0.2.3.tar.gz
- source = deprecation_fixes.patch
- sha256sums = a6af2764d2e5d62d27f17145601ae25469a9c0b39ca880fa46944f1ab283932e
- sha256sums = c3447e8a972fb263731a3c91b104b2cb706330069819ed0822df8689f4663601
+ source = https://github.com/oco2000/xfce4-kbdleds-plugin/archive/xfce4-kbdleds-plugin-0.2.5.tar.gz
+ sha256sums = d4af60e89230bdc36771c20531b19fe92efab2d1ade80f5856fc8a8fb9201668
pkgname = xfce4-kbdleds-plugin
-
diff --git a/PKGBUILD b/PKGBUILD
index 0eac7e7b5f2a..420375765a4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Raphael Scholer <rscholer@gmx.de>
+# Maintainer: ghostbuster <ghost_buster+aur@posteo.de>
+# Contributor: Raphael Scholer <rscholer@gmx.de>
# Contributor: tomberry88 <tomberry@live.it>
# Contributor: Gour-Gadadhara Dasa <gour@atmarama.net>
pkgname=xfce4-kbdleds-plugin
-pkgver=0.2.3
+pkgver=0.2.5
pkgrel=1
pkgdesc="Xfce keyboard LEDs panel plugin"
arch=('i686' 'x86_64')
@@ -11,28 +12,18 @@ license=('GPL2')
conflicts=("xfce4-kbdleds-plugin-git")
depends=('xfce4-panel')
makedepends=('intltool' 'xfce4-dev-tools')
-source=("https://github.com/oco2000/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
- deprecation_fixes.patch)
+source=("https://github.com/oco2000/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz")
install="${pkgname}.install"
-sha256sums=('a6af2764d2e5d62d27f17145601ae25469a9c0b39ca880fa46944f1ab283932e'
- 'c3447e8a972fb263731a3c91b104b2cb706330069819ed0822df8689f4663601')
-
-prepare() {
- cd "${pkgname}-${pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/deprecation_fixes.patch"
-}
-
-
+sha256sums=('d4af60e89230bdc36771c20531b19fe92efab2d1ade80f5856fc8a8fb9201668')
build() {
- cd "${pkgname}-${pkgname}-${pkgver}"
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cd "${pkgname}-${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${pkgname}-${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "${pkgname}-${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
-# vim:set ts=2 sw=2 et:
diff --git a/deprecation_fixes.patch b/deprecation_fixes.patch
deleted file mode 100644
index 44d19af75099..000000000000
--- a/deprecation_fixes.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/panel-plugin/kbdleds-dialogs.c b/panel-plugin/kbdleds-dialogs.c
-index 7f751f3..b8a56c8 100644
---- a/panel-plugin/kbdleds-dialogs.c
-+++ b/panel-plugin/kbdleds-dialogs.c
-@@ -26,6 +26,7 @@
-
- #include <libxfce4ui/libxfce4ui.h>
- #include <libxfce4panel/xfce-panel-plugin.h>
-+#include <libxfce4panel/xfce-panel-convenience.h>
-
- #include "kbdleds.h"
- #include "kbdleds-dialogs.h"
-diff --git a/panel-plugin/kbdleds.c b/panel-plugin/kbdleds.c
-index 9c78d40..5f655d0 100644
---- a/panel-plugin/kbdleds.c
-+++ b/panel-plugin/kbdleds.c
-@@ -28,6 +28,7 @@
-
- #include <gtk/gtk.h>
- #include <libxfce4util/libxfce4util.h>
-+#include <libxfce4panel/libxfce4panel.h>
- #include <libxfce4panel/xfce-panel-plugin.h>
-
- #include "kbdleds.h"
-@@ -140,7 +141,7 @@ kbdleds_new (XfcePanelPlugin *plugin)
- GtkWidget *label;
-
- /* allocate memory for the plugin structure */
-- kbdleds = panel_slice_new0 (kbdledsPlugin);
-+ kbdleds = g_slice_new0 (kbdledsPlugin);
-
- /* pointer to plugin */
- kbdleds->plugin = plugin;
-@@ -187,7 +188,7 @@ kbdleds_free (XfcePanelPlugin *plugin,
- //g_free (kbdleds->setting1);
-
- /* free the plugin structure */
-- panel_slice_free (kbdledsPlugin, kbdleds);
-+ g_slice_free (kbdledsPlugin, kbdleds);
-
- /* free the timeout */
- if (timeoutId) {