summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Scholer2015-06-13 02:46:35 +0200
committerRaphael Scholer2015-06-13 02:46:35 +0200
commit50ba40bbf97c47a4d95ebe5fbed7624fb4af0f71 (patch)
tree5f73e1450f3c658abc879016724b66c18fcb7e73
downloadaur-xfce4-kbdleds-plugin-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--xfce4-kbdleds-plugin-git.install13
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e829e6da558
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xfce4-kbdleds-plugin-git
+ pkgdesc = Xfce keyboard LEDs panel plugin
+ pkgver = 0.0.6_7_gecc3609
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-kbdleds-plugin
+ install = xfce4-kbdleds-plugin-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = intltool
+ makedepends = xfce4-dev-tools
+ depends = xfce4-panel
+ conflicts = xfce4-kbdleds-plugin
+ source = git+git://git.xfce.org/panel-plugins/xfce4-kbdleds-plugin
+ sha256sums = SKIP
+
+pkgname = xfce4-kbdleds-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..612cfb1e9299
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Raphael Scholer <rscholer@gmx.de>
+_pkgname=xfce4-kbdleds-plugin
+pkgname=${_pkgname}-git
+pkgver=0.0.6_7_gecc3609
+pkgrel=1
+pkgdesc="Xfce keyboard LEDs panel plugin"
+arch=('i686' 'x86_64')
+url="http://goodies.xfce.org/projects/panel-plugins/${_pkgname}"
+license=('GPL2')
+depends=('xfce4-panel')
+makedepends=('git' 'intltool' 'xfce4-dev-tools')
+conflicts=("${_pkgname}")
+source=("git+git://git.xfce.org/panel-plugins/${_pkgname}")
+install="${pkgname}.install"
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ echo "$(git describe --always |sed "s#${_pkgname}-##g;s#-#_#g;s#v##")"
+}
+
+build() {
+ cd "${_pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
+# vim:set ts=2 sw=2 et:
diff --git a/xfce4-kbdleds-plugin-git.install b/xfce4-kbdleds-plugin-git.install
new file mode 100644
index 000000000000..375ad822c231
--- /dev/null
+++ b/xfce4-kbdleds-plugin-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+# vim:set ts=2 sw=2 et: