summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmcb2023-05-10 20:26:15 +0100
committerjmcb2023-05-10 20:26:15 +0100
commit35b9717811a419a4a4acac1e198a16a4f9c8cfce (patch)
tree43a24156c71bd70d4d7ca16fe78e6bffee971b23
parent07110d5c8f63f114f31cf6fe6df2678349a22b0b (diff)
downloadaur-xfer9860.tar.gz
Fix patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--xfer9860-0.2.2.patch142
3 files changed, 146 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edfc31978857..1779df32dbce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,8 @@ pkgbase = xfer9860
makedepends = scons
depends = libusb
source = https://downloads.sourceforge.net/project/xfer9860/xfer9860/0.2.2/xfer9860-0.2.2.tar.bz2
- source = xfer9860-0.2.2.patch::https://github.com/sanjay900/xfer9860/commit/10cc090e363644be3aa070e6e795e1972bf28427.patch
+ source = xfer9860-0.2.2.patch
sha256sums = bc245995a6987fe4706144b4e95af6391d94d82e226ca2bf3d799b9ec733d7ac
- sha256sums = 1283b75134ad42e9b67d5ba6ef8f0ecef5dcdc1de0be7a329b1bd8a3ddfbeee9
+ sha256sums = 199532c548b0e123b9db9d866c1d0bcdd3af5fbd9b2db498a454ec202a07faa6
pkgname = xfer9860
diff --git a/PKGBUILD b/PKGBUILD
index 23b3d7bf4345..cf5c34fe2a97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,9 +13,9 @@ optdepends=()
provides=()
conflicts=()
source=("https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
- "$pkgname-$pkgver.patch::https://github.com/sanjay900/xfer9860/commit/10cc090e363644be3aa070e6e795e1972bf28427.patch")
+ "$pkgname-$pkgver.patch")
sha256sums=('bc245995a6987fe4706144b4e95af6391d94d82e226ca2bf3d799b9ec733d7ac'
- '1283b75134ad42e9b67d5ba6ef8f0ecef5dcdc1de0be7a329b1bd8a3ddfbeee9')
+ '199532c548b0e123b9db9d866c1d0bcdd3af5fbd9b2db498a454ec202a07faa6')
prepare() {
cd "$pkgname-$pkgver"
diff --git a/xfer9860-0.2.2.patch b/xfer9860-0.2.2.patch
new file mode 100644
index 000000000000..33551caeeaca
--- /dev/null
+++ b/xfer9860-0.2.2.patch
@@ -0,0 +1,142 @@
+Only in b: config.log
+Only in b: .sconf_temp
+Only in b: .sconsign.dblite
+Only in b: SConstruct.orig
+Only in b: SConstruct.rej
+Only in b/src: Casio9860.o
+Only in b/src: downloadfile.o
+Only in b/src: getinfo.o
+Only in b/src: optimizememory.o
+diff '--color=auto' --unified --recursive --text a/src/SConstruct b/src/SConstruct
+--- a/src/SConstruct 2023-05-10 20:24:53.017829272 +0100
++++ b/src/SConstruct 2023-05-10 20:24:41.417718309 +0100
+@@ -54,10 +54,10 @@
+ # Check for bin= flag, which enables static build and included binary on dist=
+ #
+ if ARGUMENTS.get('bin', 0):
+- print '!!! You are building a binary release (static linked). NOT'
+- print '!!! recommended for normal users. If you want to distribute the'
+- print '!!! binary, you must include sources for libusb, to comply with'
+- print '!!! libusb\'s licensing (LGPL)'
++ print('!!! You are building a binary release (static linked). NOT')
++ print('!!! recommended for normal users. If you want to distribute the')
++ print('!!! binary, you must include sources for libusb, to comply with')
++ print('!!! libusb\'s licensing (LGPL)')
+ default_env.Append(LINKFLAGS = '-static')
+ dist = bindist
+
+@@ -66,9 +66,9 @@
+ #
+ if ARGUMENTS.get('distclean', 0):
+ import os
+- print '==== Cleaning %s with the version %s ====' % (dist, version)
++ print('==== Cleaning %s with the version %s ====' % (dist, version))
+ os.system('rm -rf /tmp/%s-%s*' % (dist, version))
+- print 'Done'
++ print('Done')
+ Exit()
+
+ ########################################
+@@ -76,22 +76,22 @@
+ #
+ if ARGUMENTS.get('dist', 0):
+ import os
+- print '!!! Making a dist requires that the code is downloaded through SVN.'
++ print('!!! Making a dist requires that the code is downloaded through SVN.')
+ if not os.path.exists('/tmp/'):
+- print 'Cannot find /tmp, exiting!'
++ print('Cannot find /tmp, exiting!')
+ Exit()
+ os.system('rm -rf /tmp/%s-%s/' % (dist, version)) # delete possible old dists
+- print 'Exporting sources to /tmp/%s-%s/...' % (dist, version)
++ print('Exporting sources to /tmp/%s-%s/...' (dist, version) )
+ os.system('svn export .. /tmp/%s-%s/' % (dist, version))
+ if ARGUMENTS.get('bin', 0): # include the actual binary, dist refers to xfer9860-bin here
+- print 'Copying %s into bin/' % dist
++ print('Copying %s into bin/' % dist )
+ if not os.path.exists(dist):
+- print '!!! Could not find binary, remember to compile with bin=1 first!'
++ print('!!! Could not find binary, remember to compile with bin=1 first!')
+ os.system('rm -rf /tmp/%s-%s/' % (dist, version)) # remove dir again
+ Exit()
+ os.system('mkdir /tmp/%s-%s/bin/' % (dist, version))
+ os.system('cp %s /tmp/%s-%s/bin/' % (dist, dist, version))
+- print 'Done. Test dist directory before packing.'
++ print('Done. Test dist directory before packing.')
+ Exit()
+
+ ########################################
+@@ -101,30 +101,30 @@
+ import os
+ os.system('rm -rf /tmp/%s-%s.tar.bz2' % (dist, version)) # delete old packages
+ if not os.path.exists('/tmp/%s-%s/' % (dist, version)):
+- print '!!! Could not find dist directory. Remember to dist first.'
++ print('!!! Could not find dist directory. Remember to dist first.')
+ Exit()
+ if ARGUMENTS.get('bin', 0) and not os.path.exists('/tmp/%s-%s/bin/' % (dist, version)):
+- print '!!! Could not find bin directory, compile and dist with bin=1!'
++ print('!!! Could not find bin directory, compile and dist with bin=1!')
+ Exit()
+
+- print 'Archiving distribution into /tmp/%s-%s.tar.bz2...' % (dist, version)
++ print('Archiving distribution into /tmp/%s-%s.tar.bz2...' % (dist, version))
+ os.system('tar -cjf /tmp/%s-%s.tar.bz2 -C /tmp %s-%s/' % (dist, version, dist, version) )
+- print 'Done.'
++ print('Done.')
+ Exit()
+
+ ########################################
+ # Checks for required libs and includes
+ #
+ if not default_env.GetOption('clean'): # don't perform on clean
+- print '==== Looking for required libraries ===='
++ print('==== Looking for required libraries ====')
+ conf = Configure(default_env)
+ # libraries with their headers
+ if not conf.CheckLibWithHeader('usb-1.0', 'libusb-1.0/libusb.h', 'C') \
+ :
+- print 'Did not find the needed libraries or headers, exiting!'
++ print('Did not find the needed libraries or headers, exiting!')
+ Exit(1)
+ # general headers
+- print '\n==== Looking for required includes ===='
++ print('\n==== Looking for required includes ====')
+ if not conf.CheckCHeader('unistd.h') \
+ or not conf.CheckCHeader('stdio.h') \
+ or not conf.CheckCHeader('string.h') \
+@@ -133,18 +133,18 @@
+ or not conf.CheckCHeader('sys/stat.h') \
+ or not conf.CheckCHeader('math.h') \
+ :
+- print 'Did not find needed includes, exiting!'
++ print('Did not find needed includes, exiting!')
+ Exit(1)
+
+ default_env = conf.Finish()
+
+-print ''
++print('')
+ ########################################
+ # Enable macro def's in case of debug or snoop mode
+ #
+ debug = ARGUMENTS.get('debug', 0)
+ if int(debug):
+- print '==== Compiling in DEBUG/SNOOP MODE! ===='
++ print('==== Compiling in DEBUG/SNOOP MODE! ====')
+ default_env.Append(CPPDEFINES = Split('DEBUG SNOOP'))
+
+ ########################################
+@@ -156,7 +156,7 @@
+ objlist = versioned.Object('xfer9860.c')
+
+ if not default_env.GetOption('clean'):
+- print '==== Starting program compilation ===='
++ print('==== Starting program compilation ====')
+ xfer9860 = default_env.Program(target = dist, source = srclist + objlist, LIBS = liblist)
+ # makes sure to remove both binaries, and logfiles
+ Clean(xfer9860, [dist, bindist, 'config.log', '../config.log'])
+Only in b/src: uploadfile.o
+Only in b/src: usbio.o
+Only in b/src: xfer9860
+Only in b/src: xfer9860.o
+Only in b: xfer9860