summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Augusto2020-02-17 14:50:08 -0300
committerJose Augusto2020-02-17 14:50:08 -0300
commited239856740d3cb522a98b9ff4c0f7030abb3e57 (patch)
treebd5670acda14869c6f2e557d2d5f36d364fb259f
downloadaur-xfetch.tar.gz
Commit inicial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0137790947e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xfetch
+ pkgdesc = Yet another fetch written in ruby
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/JAugusto42/xfetch
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = ruby
+ source = xfetch-2.0.0.tar.gz::https://github.com/JAugusto42/xfetch/archive/2.0.0.tar.gz
+ md5sums = e25e4b9de90b727e9802f791a59f292b
+
+pkgname = xfetch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c046dba7203
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jose Augusto <joseaugusto.881 at outlook dot com>
+
+pkgname=xfetch
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Yet another fetch written in ruby"
+arch=('any')
+url="https://github.com/JAugusto42/xfetch"
+license=('MIT')
+
+source=(
+ "$pkgname-$pkgver.tar.gz"::https://github.com/JAugusto42/xfetch/archive/$pkgver.tar.gz
+)
+
+md5sums=('e25e4b9de90b727e9802f791a59f292b')
+depends=('ruby')
+makedepends=('git')
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 xfetch ${pkgdir}/usr/bin/xfetch
+}
+