summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 16:32:22 +0200
committerChristian Hesse2015-06-29 16:32:22 +0200
commiteccd34834651e09ab6580b4e22a2620b54930401 (patch)
treecdd2a98205a26f84ce02604f92c6fc8dd9b88b17
downloadaur-xfwm4-themes-curvish.tar.gz
initial import of xfwm4-themes-curvish 0.0.3-3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..631675562599
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = xfwm4-themes-curvish
+ pkgdesc = Popular 'Curve' window decorations, modified to support theme colors
+ pkgver = 0.0.3
+ pkgrel = 3
+ url = http://www.eworm.de/
+ arch = any
+ license = GPL
+ depends = xfwm4
+ source = http://www.eworm.de/download/xfwm4-themes-curvish/xfwm4-themes-curvish-0.0.3.tar.bz2
+ sha256sums = 9dd7db51c13728588079653d37072d70abeb4121a6470074aa73637dec6d800d
+
+pkgname = xfwm4-themes-curvish
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b795bb07159c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=xfwm4-themes-curvish
+pkgver=0.0.3
+pkgrel=3
+pkgdesc="Popular 'Curve' window decorations, modified to support theme colors"
+arch=('any')
+depends=('xfwm4')
+url='http://www.eworm.de/'
+license=('GPL')
+source=("http://www.eworm.de/download/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('9dd7db51c13728588079653d37072d70abeb4121a6470074aa73637dec6d800d')
+
+package() {
+ cd "${srcdir}"
+ for FILE in $(find CurvishDark/ -type f); do
+ install -D -m0644 ${FILE} ${pkgdir}/usr/share/themes/${FILE}
+ done
+ for FILE in $(find Curvish/ -type f); do
+ install -D -m0644 ${FILE} ${pkgdir}/usr/share/themes/${FILE}
+ [ -f ${pkgdir}/usr/share/themes/CurvishDark/xfwm4/${FILE##*/} ] || ln -s ../../${FILE} ${pkgdir}/usr/share/themes/CurvishDark/xfwm4/${FILE##*/}
+ done
+}
+