summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2016-02-11 09:59:26 +0600
committerKonstantin Shalygin2016-02-11 09:59:26 +0600
commitc55d48b872a29aa206c893d7fe83affd7d2cb469 (patch)
tree2aaf9099860e10414e7f693d737660a77f6b2aee
parent5d0bc02d92942b461113916eb74a7991d66dee75 (diff)
downloadaur-xidle.tar.gz
bump to 26052015
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD53
4 files changed, 25 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d195fa6a6db9..a233e2106326 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
# Generated by mksrcinfo v8
-# Thu Feb 11 03:50:48 UTC 2016
+# Thu Feb 11 03:59:07 UTC 2016
pkgbase = xidle
pkgdesc = xidle runs a program on X inactivity
- pkgver = 24102005
+ pkgver = 26052015
pkgrel = 1
url = http://www.freshports.org/x11/xidle
- arch = i686
- arch = x86_64
+ arch = any
license = BSD
depends = libxss
depends = libxext
depends = libx11
source = Makefile
- source = LICENSE
- source = http://distcache.freebsd.org/local-distfiles/novel/xidle-24102005.tar.bz2
- md5sums = acfd0e9b0f8e9d123edd9f7575696981
- md5sums = fc5e113e43e90e9b23299ee186aca0c8
- md5sums = 6d4067b5adac594aa5917f2265cc02ee
+ source = http://distcache.freebsd.org/local-distfiles/novel/xidle-26052015.tar.bz2
+ sha256sums = 157242d569537ae00b2ddc57b3b7abdbb551b5294adfaefb7bd02f00ee6c3cc8
+ sha256sums = a7ba1b887c0f4d9d080dc7f49569bf48e3df1d9f2c08b11cffd159c5a15b174c
pkgname = xidle
diff --git a/.gitignore b/.gitignore
index d263cd870684..50cfebb9693c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
pkg/*
src/*
*.tar.*
-*.zip*
+
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 781e5142773f..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-$OpenBSD: xidle.c,v 1.10 2005/10/07 19:47:26 fgsch Exp $
-
-Copyright (c) 2005 Federico G. Schwindt.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions
-are met:
-1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
-2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
-
-THIS SOFTWARE IS PROVIDED BY THE OPENBSD PROJECT AND CONTRIBUTORS
-``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OPENBSD
-PROJECT OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 03e938951d10..610341cbb11d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,26 @@
-# Maintainer: MichaƂ Kazior <kazikcz at gmail dot com>
-pkgname=xidle
-pkgver=24102005
-pkgrel=1
-epoch=
+# Maintainer: Konstantin Shalygin <k0ste@cn.ru>
+
+pkgname='xidle'
+pkgver='26052015'
+pkgrel='1'
pkgdesc="xidle runs a program on X inactivity"
-arch=(i686 x86_64)
-url="http://www.freshports.org/x11/xidle"
+arch=('any')
+url="http://www.freshports.org/x11/${pkgname}"
license=('BSD')
-groups=()
-depends=(libxss libxext libx11)
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=(Makefile LICENSE http://distcache.freebsd.org/local-distfiles/novel/$pkgname-$pkgver.tar.bz2)
-noextract=()
-
+depends=('libxss' 'libxext' 'libx11')
+source=("Makefile"
+ "http://distcache.freebsd.org/local-distfiles/novel/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('157242d569537ae00b2ddc57b3b7abdbb551b5294adfaefb7bd02f00ee6c3cc8'
+ 'a7ba1b887c0f4d9d080dc7f49569bf48e3df1d9f2c08b11cffd159c5a15b174c')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- make -f ../Makefile
-}
-
-check() {
- return 0
+ pushd "${pkgname}-${pkgver}"
+ make -f ../Makefile
+ popd
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make -f ../Makefile DESTDIR="$pkgdir/" install
- install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ pushd "${pkgname}-${pkgver}"
+ make -f ../Makefile DESTDIR="${pkgdir}" install
+ popd
}
-
-md5sums=('acfd0e9b0f8e9d123edd9f7575696981'
- 'fc5e113e43e90e9b23299ee186aca0c8'
- '6d4067b5adac594aa5917f2265cc02ee')